aboutsummaryrefslogtreecommitdiff
path: root/security/fpm
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2003-12-22 17:05:05 +0000
committerAnders Nordby <anders@FreeBSD.org>2003-12-22 17:05:05 +0000
commit91e47145c37c3358673b209ea800b34a0624aeed (patch)
tree76c7203504f029fb18d929e2a4a20de59dab54d0 /security/fpm
parent4e17168b302f4086f7d6945118c9d3ee79cebbe1 (diff)
downloadports-91e47145c37c3358673b209ea800b34a0624aeed.tar.gz
ports-91e47145c37c3358673b209ea800b34a0624aeed.zip
Notes
Diffstat (limited to 'security/fpm')
-rw-r--r--security/fpm/Makefile17
-rw-r--r--security/fpm/distinfo2
-rw-r--r--security/fpm/files/patch-config.h2
3 files changed, 14 insertions, 7 deletions
diff --git a/security/fpm/Makefile b/security/fpm/Makefile
index fda0a8250bff..a6b8a49f460c 100644
--- a/security/fpm/Makefile
+++ b/security/fpm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fpm
-PORTVERSION= 0.53
+PORTVERSION= 0.59
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,11 +18,15 @@ USE_GNOME= gnomeprefix gnomehack gnomelibs
USE_X_PREFIX= yes
USE_REINPLACE= yes
-SOURCEFILES= main.c fpm.c support.c interface.c passfile.c callbacks.c \
- blowfish.c fpm_crypt.c fpm_gpw.c md5.c fpm_clist.c fpm_pref.c
+GPASSOURCE= file.c librc2.c
+GPASVERS= 1.3.0
+SOURCEFILES= blowfish.c callbacks.c fpm.c fpm_clist.c fpm_crypt.c \
+ fpm_gpw.c fpm_launcher.c fpm_pref.c import_gpasman.c \
+ interface.c main.c md5.c passfile.c support.c
DOCS= AUTHORS ChangeLog README TODO
-GNOME_CFLAGS?= `${GNOME_CONFIG} --cflags gnomeui`
+GNOME_CFLAGS?= `${GNOME_CONFIG} --cflags gnomeui` \
+ `${LOCALBASE}/bin/xml-config --cflags`
GNOME_LIBS?= `${GNOME_CONFIG} --libs gnomeui` \
`${LOCALBASE}/bin/xml-config --libs`
CFLAGS+= -DHAVE_CONFIG_H -I. -I.. ${GNOME_CFLAGS}
@@ -31,11 +35,14 @@ pre-build:
${REINPLACE_CMD} -E -e "s@encrypt\(@bfishencrypt\(@g" ${WRKSRC}/src/blowfish.c
do-build:
+.for f in ${GPASSOURCE}
+ (cd ${WRKSRC}/src/gpasman-${GPASVERS}; ${CC} ${CFLAGS} ${GNOME_CFLAGS} -c ${f})
+.endfor
.for f in ${SOURCEFILES}
(cd ${WRKSRC}/src; ${CC} ${CFLAGS} ${GNOME_CFLAGS} -c ${f})
.endfor
(cd ${WRKSRC}/src; ${CC} ${CFLAGS} -o fpm ${SOURCEFILES:S/.c/.o/g} \
- ${GNOME_LIBS})
+ ${GPASSOURCE:S/.c/.o/g:S/^/gpasman-${GPASVERS}\//g} ${GNOME_LIBS})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/fpm ${PREFIX}/bin
diff --git a/security/fpm/distinfo b/security/fpm/distinfo
index 53505d65a342..3be795be9b06 100644
--- a/security/fpm/distinfo
+++ b/security/fpm/distinfo
@@ -1 +1 @@
-MD5 (fpm-0.53.tar.gz) = 16ea9a86b9216b150e04d8bfcfb34d70
+MD5 (fpm-0.59.tar.gz) = 28b3b89878db9dc3f555c52aa1b41afa
diff --git a/security/fpm/files/patch-config.h b/security/fpm/files/patch-config.h
index bfd7d90c2764..b7422a8b02b1 100644
--- a/security/fpm/files/patch-config.h
+++ b/security/fpm/files/patch-config.h
@@ -133,5 +133,5 @@
+#define PACKAGE "fpm"
+
+/* Version number of package */
-+#define VERSION "0.53"
++#define VERSION "0.59"
+