aboutsummaryrefslogtreecommitdiff
path: root/security/fragroute
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-03-30 08:35:23 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-03-30 08:35:23 +0000
commit948b7d0f40f04a96d69e69b13562865fb1749325 (patch)
tree1742d152d48e54c96a5caf9f8f830777aa22e6aa /security/fragroute
parent1e2dd0bc6cf916a2c918eee238b205c1f39dfd52 (diff)
downloadports-948b7d0f40f04a96d69e69b13562865fb1749325.tar.gz
ports-948b7d0f40f04a96d69e69b13562865fb1749325.zip
Notes
Diffstat (limited to 'security/fragroute')
-rw-r--r--security/fragroute/Makefile2
-rw-r--r--security/fragroute/files/patch-mod.c11
-rw-r--r--security/fragroute/files/patch-pkt.h18
3 files changed, 30 insertions, 1 deletions
diff --git a/security/fragroute/Makefile b/security/fragroute/Makefile
index c391b7a9d564..49fd11473bb3 100644
--- a/security/fragroute/Makefile
+++ b/security/fragroute/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fragroute
PORTVERSION= 1.2
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= security net
MASTER_SITES= http://monkey.org/~dugsong/fragroute/ \
PACKETSTORM/UNIX/security
diff --git a/security/fragroute/files/patch-mod.c b/security/fragroute/files/patch-mod.c
new file mode 100644
index 000000000000..691fa3a79e44
--- /dev/null
+++ b/security/fragroute/files/patch-mod.c
@@ -0,0 +1,11 @@
+--- mod.c.orig 2020-03-22 06:34:47 UTC
++++ mod.c
+@@ -151,7 +151,7 @@ mod_close(void)
+ {
+ struct rule *rule;
+
+- TAILQ_FOREACH_REVERSE(rule, &rules, next, head) {
++ TAILQ_FOREACH_REVERSE(rule, &rules, head, next) {
+ if (rule->mod->close != NULL)
+ rule->data = rule->mod->close(rule->data);
+ TAILQ_REMOVE(&rules, rule, next);
diff --git a/security/fragroute/files/patch-pkt.h b/security/fragroute/files/patch-pkt.h
new file mode 100644
index 000000000000..3b818108f263
--- /dev/null
+++ b/security/fragroute/files/patch-pkt.h
@@ -0,0 +1,18 @@
+--- pkt.h.orig 2002-04-07 22:55:20 UTC
++++ pkt.h
+@@ -9,10 +9,14 @@
+ #ifndef PKT_H
+ #define PKT_H
+
++#include <sys/queue.h>
+ #include <sys/time.h>
+ #include <dnet.h>
+ #include <event.h>
+-#include "queue.h"
++
++#ifndef TAILQ_END
++#define TAILQ_END(head) NULL
++#endif
+
+ #define PKT_BUF_LEN (ETH_HDR_LEN + ETH_MTU)
+ #define PKT_BUF_ALIGN 2