aboutsummaryrefslogtreecommitdiff
path: root/security/fswatch/Makefile
diff options
context:
space:
mode:
authorJean Milanez Melo <jmelo@FreeBSD.org>2006-04-25 01:55:02 +0000
committerJean Milanez Melo <jmelo@FreeBSD.org>2006-04-25 01:55:02 +0000
commit22e951ba0f46694523a5fb9572f636b3880c47d2 (patch)
tree00b5d1b0ca4a38684cf0f8db3e47bc19114559ff /security/fswatch/Makefile
parent816aad728f8f03b664239948e797198e5b80ae51 (diff)
Notes
Diffstat (limited to 'security/fswatch/Makefile')
-rw-r--r--security/fswatch/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/fswatch/Makefile b/security/fswatch/Makefile
new file mode 100644
index 000000000000..42084f494650
--- /dev/null
+++ b/security/fswatch/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: fswatch
+# Date created: 18 April 2006
+# Whom: dominik karczmarski <dominik@karczmarski.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fswatch
+DISTVERSION= 0.02beta5
+CATEGORIES= security sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fswatch
+
+MAINTAINER= dominik@karczmarski.com
+COMMENT= File system checksum checker
+
+HAS_CONFIGURE= yes
+SUB_FILES= pkg-message
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b/beta/}/
+
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --enable-regex \
+ --enable-stflags
+
+PLIST_FILES= bin/fswbuild bin/fswcmp bin/fswshow \
+ bin/fswconf etc/fswatch.conf.sample
+
+MAN1= fswbuild.1 fswcmp.1 fswshow.1 fswconf.1
+MAN5= fswatch.conf.5
+MAN7= fswatch.7
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>