aboutsummaryrefslogtreecommitdiff
path: root/security/ftimes
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2007-04-15 06:12:51 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2007-04-15 06:12:51 +0000
commitb63d075a085e9cc72c9b8d7bf0850da1577bb767 (patch)
treed290c8a1455c84fdbf4fdb8320a99d9b3c614dbd /security/ftimes
parentb22cfea3e8fa37438cd4d81fca9079e13c6caa64 (diff)
downloadports-b63d075a085e9cc72c9b8d7bf0850da1577bb767.tar.gz
ports-b63d075a085e9cc72c9b8d7bf0850da1577bb767.zip
Notes
Diffstat (limited to 'security/ftimes')
-rw-r--r--security/ftimes/Makefile22
-rw-r--r--security/ftimes/distinfo6
-rw-r--r--security/ftimes/pkg-plist4
3 files changed, 26 insertions, 6 deletions
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index 26d7912f1a76..3647bcacfa34 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ftimes
-PORTVERSION= 3.7.0
+PORTVERSION= 3.8.0
CATEGORIES= security sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ftimes
@@ -16,7 +16,7 @@ MAINTAINER= klm@uidzero.org
COMMENT= A system baselining and evidence collection tool
GNU_CONFIGURE= yes
-USE_PERL5_RUN= yes
+USE_PERL5= yes
MAN1= ftimes.1
@@ -24,13 +24,20 @@ OPTIONS= DIG_TOOLS "install dig tools" on \
HASHDIG_TOOLS "install hashdig tools" on \
MAP_TOOLS "install map tools" on \
PCRE "PCRE support" on \
- SSL "OpenSSL support" on
+ SSL "OpenSSL support" on \
+ XMAGIC "XMagic support" on
.include <bsd.port.pre.mk>
+.if defined(WITH_DIG_TOOLS) || defined(WITH_MAP_TOOLS)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
.if defined(WITH_DIG_TOOLS)
PLIST_SUB+= DIG_TOOLS=""
CONFIGURE_ARGS+= --with-dig-tools
+MAN1+= ftimes-crv2dbi.1 ftimes-crv2raw.1 ftimes-dig2ctx.1 ftimes-dig2dbi.1 hipdig.1
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
.else
PLIST_SUB+= DIG_TOOLS="@comment "
.endif
@@ -38,6 +45,7 @@ PLIST_SUB+= DIG_TOOLS="@comment "
.if defined(WITH_HASHDIG_TOOLS)
PLIST_SUB+= HASHDIG_TOOLS=""
CONFIGURE_ARGS+= --with-hashdig-tools
+MAN1+= hashdig-bash.1 hashdig-bind.1 hashdig-dump.1 hashdig-find.1 hashdig-filter.1 hashdig-harvest-sunsolve.1 hashdig-harvest.1 hashdig-make.1 hashdig-resolve-sunsolve.1 hashdig-stat.1 hashdig-weed.1
.else
PLIST_SUB+= HASHDIG_TOOLS="@comment "
.endif
@@ -45,6 +53,7 @@ PLIST_SUB+= HASHDIG_TOOLS="@comment "
.if defined(WITH_MAP_TOOLS)
PLIST_SUB+= MAP_TOOLS=""
CONFIGURE_ARGS+= --with-map-tools
+MAN1+= ftimes-cmp2dbi.1 ftimes-map2dbi.1 ftimes-map2mac.1 tarmap.1
.else
PLIST_SUB+= MAP_TOOLS="@comment "
.endif
@@ -64,6 +73,13 @@ CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
CONFIGURE_ARGS+= --without-ssl
.endif
+.if defined(WITH_XMAGIC)
+PLIST_SUB+= XMAGIC=""
+CONFIGURE_ARGS+= --enable-xmagic
+.else
+PLIST_SUB+= XMAGIC="@comment "
+.endif
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/ftimes
diff --git a/security/ftimes/distinfo b/security/ftimes/distinfo
index 8ea41ee3d777..c4cc2f0b14c0 100644
--- a/security/ftimes/distinfo
+++ b/security/ftimes/distinfo
@@ -1,3 +1,3 @@
-MD5 (ftimes-3.7.0.tgz) = 86be96d746b844354f5dc5b422bae43f
-SHA256 (ftimes-3.7.0.tgz) = 767b58636f3812dbf89a9f1849e9568540a9f30648023bef95d7bab301c9fa37
-SIZE (ftimes-3.7.0.tgz) = 440445
+MD5 (ftimes-3.8.0.tgz) = b4bc8a3c00b3aed9e9cc9583234ec6a7
+SHA256 (ftimes-3.8.0.tgz) = 8d25ea7a5778438fcee469f8824aa64b3a209769d358260e6c94a927e7064e58
+SIZE (ftimes-3.8.0.tgz) = 452880
diff --git a/security/ftimes/pkg-plist b/security/ftimes/pkg-plist
index 64f01eebbe27..d07d4f972126 100644
--- a/security/ftimes/pkg-plist
+++ b/security/ftimes/pkg-plist
@@ -1,9 +1,12 @@
+%%DIG_TOOLS%%bin/ftimes-crv2dbi.pl
%%DIG_TOOLS%%bin/ftimes-crv2raw.pl
%%DIG_TOOLS%%bin/ftimes-dig2ctx.pl
+%%DIG_TOOLS%%bin/ftimes-dig2dbi.pl
%%DIG_TOOLS%%bin/hipdig.pl
%%HASHDIG_TOOLS%%bin/hashdig-bash.pl
%%HASHDIG_TOOLS%%bin/hashdig-bind.pl
%%HASHDIG_TOOLS%%bin/hashdig-dump.pl
+%%HASHDIG_TOOLS%%bin/hashdig-find.pl
%%HASHDIG_TOOLS%%bin/hashdig-filter.pl
%%HASHDIG_TOOLS%%bin/hashdig-harvest-sunsolve.pl
%%HASHDIG_TOOLS%%bin/hashdig-harvest.pl
@@ -14,6 +17,7 @@
%%MAP_TOOLS%%bin/ftimes-cmp2dbi.pl
%%MAP_TOOLS%%bin/ftimes-map2dbi.pl
%%MAP_TOOLS%%bin/ftimes-map2mac.pl
+%%MAP_TOOLS%%bin/tarmap
bin/ftimes
etc/digfull.cfg.sample
etc/diglean.cfg.sample