aboutsummaryrefslogtreecommitdiff
path: root/security/ftimes
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-02 22:00:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-02 22:00:44 +0000
commit3f4c003065dc7fed769611d9faa69b05d4bc39f6 (patch)
tree1fe9f3eb198c36e5127dc4957e507b25d73758b7 /security/ftimes
parenta37d2439ba13db24936ce9ad972307c2c88eb3a6 (diff)
downloadports-3f4c003065dc7fed769611d9faa69b05d4bc39f6.tar.gz
ports-3f4c003065dc7fed769611d9faa69b05d4bc39f6.zip
Notes
Diffstat (limited to 'security/ftimes')
-rw-r--r--security/ftimes/Makefile56
-rw-r--r--security/ftimes/pkg-plist40
2 files changed, 82 insertions, 14 deletions
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index 68439ac3f2cf..a137c5f5a14b 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ftimes
PORTVERSION= 3.10.0
+PORTREVISION= 1
CATEGORIES= security sysutils
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
@@ -10,14 +11,46 @@ EXTRACT_SUFX= .tgz
MAINTAINER= klm@uidzero.org
COMMENT= System baselining and evidence collection tool
-LICENSE= BSD APACHE20 MIT
+LICENSE= BSD3CLAUSE APACHE20 MIT
LICENSE_COMB= multi
GNU_CONFIGURE= yes
-USES= perl5
-
-MAN1= ftimes.1
-MAN3= FTimes::EadRoutines.3 FTimes::Properties.3
+USES= perl5 shebangfix
+USE_PERL5= run build fixpacklist
+SHEBANG_FILES= \
+ ${WRKSRC}/tools/dig/ftimes-crv2dbi.pl \
+ ${WRKSRC}/tools/dig/ftimes-crv2raw.pl \
+ ${WRKSRC}/tools/dig/ftimes-dig2ctx.pl \
+ ${WRKSRC}/tools/dig/ftimes-dig2dbi.pl \
+ ${WRKSRC}/tools/dig/hipdig.pl \
+ ${WRKSRC}/tools/ftimes-cmp2diff/ftimes-cmp2diff \
+ ${WRKSRC}/tools/ftimes-dbm-bash/ftimes-dbm-bash \
+ ${WRKSRC}/tools/ftimes-dbm-dump/ftimes-dbm-dump \
+ ${WRKSRC}/tools/ftimes-dbm-find/ftimes-dbm-find \
+ ${WRKSRC}/tools/ftimes-dbm-make/ftimes-dbm-make \
+ ${WRKSRC}/tools/ftimes-dbm-reap/ftimes-dbm-reap \
+ ${WRKSRC}/tools/ftimes-dbm-weed/ftimes-dbm-weed \
+ ${WRKSRC}/tools/ftimes-encoder/ftimes-encoder \
+ ${WRKSRC}/tools/ftimes-grabber/ftimes-grabber \
+ ${WRKSRC}/tools/ftimes-proximo/ftimes-proximo \
+ ${WRKSRC}/tools/ftimes-sizimus/ftimes-sizimus \
+ ${WRKSRC}/tools/ftimes-sortini/ftimes-sortini \
+ ${WRKSRC}/tools/ftimes-xformer/ftimes-xformer \
+ ${WRKSRC}/tools/hashdig/hashdig-bash.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-bind.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-dump.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-filter.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-find.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-harvest-sunsolve.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-harvest.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-make.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-resolve-sunsolve.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-stat.pl \
+ ${WRKSRC}/tools/hashdig/hashdig-weed.pl \
+ ${WRKSRC}/tools/map/ftimes-cmp2dbi.pl \
+ ${WRKSRC}/tools/map/ftimes-map2dbi.pl \
+ ${WRKSRC}/tools/map/ftimes-map2mac.pl \
+ ${WRKSRC}/tools/zipmap/zipmap
OPTIONS_DEFINE= DBM_TOOLS DIG_TOOLS FILE_HOOKS HASHDIG_TOOLS MAP_TOOLS SSL XMAGIC
OPTIONS_DEFAULT= DBM_TOOLS DIG_TOOLS FILE_HOOKS HASHDIG_TOOLS MAP_TOOLS SSL XMAGIC
@@ -28,18 +61,16 @@ HASHDIG_TOOLS_DESC= Install hashdig tools
MAP_TOOLS_DESC= Install map tools
XMAGIC_DESC= XMagic support
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
-STRIP_FILES= ${PREFIX}/bin/ftimes
+STRIP_FILES= ${STAGEDIR}${PREFIX}/bin/ftimes
.if ${PORT_OPTIONS:MDBM_TOOLS}
PLIST_SUB+= DBM_TOOLS=""
CONFIGURE_ARGS+= --with-dbm-tools
-MAN1+= ftimes-dbm-bash.1 ftimes-dbm-dump.1 ftimes-dbm-find.1 ftimes-dbm-make.1 ftimes-dbm-reap.1 ftimes-dbm-weed.1
.else
PLIST_SUB+= DBM_TOOLS="@comment "
.endif
@@ -47,14 +78,13 @@ PLIST_SUB+= DBM_TOOLS="@comment "
.if ${PORT_OPTIONS:MDIG_TOOLS}
PLIST_SUB+= DIG_TOOLS=""
CONFIGURE_ARGS+= --with-dig-tools
-MAN1+= ftimes-crv2dbi.1 ftimes-crv2raw.1 ftimes-dig2ctx.1 ftimes-dig2dbi.1 hipdig.1
RUN_DEPENDS+= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
.else
PLIST_SUB+= DIG_TOOLS="@comment "
.endif
.if ${PORT_OPTIONS:MFILE_HOOKS}
-LIB_DEPENDS+= klel:${PORTSDIR}/devel/libklel
+LIB_DEPENDS+= libklel.so:${PORTSDIR}/devel/libklel
CONFIGURE_ARGS+= --enable-file-hooks --with-klel=${LOCALBASE} --with-perl=${LOCALBASE}/bin/perl
.else
PLIST_SUB+= WITH_FILE_HOOKS="@comment "
@@ -63,7 +93,6 @@ PLIST_SUB+= WITH_FILE_HOOKS="@comment "
.if ${PORT_OPTIONS:MHASHDIG_TOOLS}
PLIST_SUB+= HASHDIG_TOOLS=""
CONFIGURE_ARGS+= --with-hashdig-tools
-MAN1+= hashdig-bash.1 hashdig-bind.1 hashdig-dump.1 hashdig-filter.1 hashdig-find.1 hashdig-harvest.1 hashdig-harvest-sunsolve.1 hashdig-make.1 hashdig-resolve-sunsolve.1 hashdig-stat.1 hashdig-weed.1
.else
PLIST_SUB+= HASHDIG_TOOLS="@comment "
.endif
@@ -71,8 +100,7 @@ PLIST_SUB+= HASHDIG_TOOLS="@comment "
.if ${PORT_OPTIONS:MMAP_TOOLS}
PLIST_SUB+= MAP_TOOLS=""
CONFIGURE_ARGS+= --with-map-tools
-MAN1+= ftimes-cat.1 ftimes-cmp2dbi.1 ftimes-cmp2diff.1 ftimes-encoder.1 ftimes-grabber.1 ftimes-map2dbi.1 ftimes-map2mac.1 ftimes-proximo.1 ftimes-sizimus.1 ftimes-sortini.1 ftimes-xformer.1 ftimes-xpa.1 hashcp.1 tarmap.1 zipmap.1
-STRIP_FILES+= ${PREFIX}/bin/ftimes-cat ${PREFIX}/bin/ftimes-xpa ${PREFIX}/bin/hashcp ${PREFIX}/bin/tarmap
+STRIP_FILES+= ${STAGEDIR}${PREFIX}/bin/ftimes-cat ${STAGEDIR}${PREFIX}/bin/ftimes-xpa ${STAGEDIR}${PREFIX}/bin/hashcp ${STAGEDIR}${PREFIX}/bin/tarmap
.else
PLIST_SUB+= MAP_TOOLS="@comment "
.endif
diff --git a/security/ftimes/pkg-plist b/security/ftimes/pkg-plist
index 9647a2e7dc8f..0685f1ec598d 100644
--- a/security/ftimes/pkg-plist
+++ b/security/ftimes/pkg-plist
@@ -43,5 +43,45 @@ etc/ftimes-map.cfg.sample
%%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes/.packlist
%%SITE_PERL%%/FTimes/EadRoutines.pm
%%SITE_PERL%%/FTimes/Properties.pm
+man/man1/ftimes.1.gz
+%%DBM_TOOLS%%man/man1/ftimes-dbm-bash.1.gz
+%%DBM_TOOLS%%man/man1/ftimes-dbm-dump.1.gz
+%%DBM_TOOLS%%man/man1/ftimes-dbm-find.1.gz
+%%DBM_TOOLS%%man/man1/ftimes-dbm-make.1.gz
+%%DBM_TOOLS%%man/man1/ftimes-dbm-reap.1.gz
+%%DBM_TOOLS%%man/man1/ftimes-dbm-weed.1.gz
+%%DIG_TOOLS%%man/man1/ftimes-crv2dbi.1.gz
+%%DIG_TOOLS%%man/man1/ftimes-crv2raw.1.gz
+%%DIG_TOOLS%%man/man1/ftimes-dig2ctx.1.gz
+%%DIG_TOOLS%%man/man1/ftimes-dig2dbi.1.gz
+%%DIG_TOOLS%%man/man1/hipdig.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-bash.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-bind.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-dump.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-filter.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-find.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-harvest.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-harvest-sunsolve.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-make.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-resolve-sunsolve.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-stat.1.gz
+%%HASHDIG_TOOLS%%man/man1/hashdig-weed.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-cat.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-cmp2dbi.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-cmp2diff.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-encoder.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-grabber.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-map2dbi.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-map2mac.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-proximo.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-sizimus.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-sortini.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-xformer.1.gz
+%%MAP_TOOLS%%man/man1/ftimes-xpa.1.gz
+%%MAP_TOOLS%%man/man1/hashcp.1.gz
+%%MAP_TOOLS%%man/man1/tarmap.1.gz
+%%MAP_TOOLS%%man/man1/zipmap.1.gz
+man/man3/FTimes::EadRoutines.3.gz
+man/man3/FTimes::Properties.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes
@dirrm %%SITE_PERL%%/FTimes