aboutsummaryrefslogtreecommitdiff
path: root/security/fuzzdb/Makefile
diff options
context:
space:
mode:
authorNiels Heinen <niels@FreeBSD.org>2010-04-20 21:15:42 +0000
committerNiels Heinen <niels@FreeBSD.org>2010-04-20 21:15:42 +0000
commit382057dc867f4b847bca9f0d25c9c91fa7678527 (patch)
tree85f96c4bbb97b501a1645978a07ab953578dbc21 /security/fuzzdb/Makefile
parent44cef5647cb86af87bbbd606a233f3e44e1504e1 (diff)
Notes
Diffstat (limited to 'security/fuzzdb/Makefile')
-rw-r--r--security/fuzzdb/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/security/fuzzdb/Makefile b/security/fuzzdb/Makefile
index 0aefdad6fb6e..34fc89dcb47d 100644
--- a/security/fuzzdb/Makefile
+++ b/security/fuzzdb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fuzzdb
-PORTVERSION= 1.01
+PORTVERSION= 1.05
CATEGORIES= security www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
@@ -17,15 +17,24 @@ COMMENT= A comprehensive set of fuzzing patterns
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude .svn
-PORTDOCS= copyright.txt
+PORTDOCS= _copyright.txt _readme.txt
+PORTDIRS= attack-payloads wordlists-misc discovery \
+ web-backdoors wordlists-user-passwd
.include <bsd.port.pre.mk>
+post-extract:
+ @${RM} ${WRKSRC}/wordlists-user-passwd/~
+
do-install:
- ( cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR} "! -name ${PORTDOCS}" )
+.for dir in ${PORTDIRS}
+ ( cd ${WRKSRC}/${dir} && ${COPYTREE_SHARE} . ${DATADIR}/${dir} )
+.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+. for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.post.mk>