aboutsummaryrefslogtreecommitdiff
path: root/security/fwbuilder/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-05-03 03:14:39 +0000
committerCy Schubert <cy@FreeBSD.org>2011-05-03 03:14:39 +0000
commit21ec1413962e9495880ce4be2fede956b695de10 (patch)
tree88918e6d2d99989b8903f12f78e2d1f4695d4f9a /security/fwbuilder/Makefile
parent763f9e966135f66abb55b5d9ad5b9aa298feb426 (diff)
downloadports-21ec1413962e9495880ce4be2fede956b695de10.tar.gz
ports-21ec1413962e9495880ce4be2fede956b695de10.zip
Notes
Diffstat (limited to 'security/fwbuilder/Makefile')
-rw-r--r--security/fwbuilder/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 8e901e357f50..54e2f6d2c6a6 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -6,29 +6,33 @@
#
PORTNAME= fwbuilder
-DISTVERSION= 4.1.3
+DISTVERSION= 4.2.0
PORTVERSION= ${DISTVERSION}
CATEGORIES= security
-.if defined(BUILD)
+BUILD= 3530
+.if defined(DEVEL)
MASTER_SITES= http://www.fwbuilder.org/nightly_builds/fwbuilder-4.0/build-${BUILD}/
PKGNAMESUFFIX= -devel
PORTVERSION= ${DISTVERSION}.b${BUILD}
.else
MASTER_SITES= SF/${PORTNAME}/Current_Packages/${PORTVERSION}
+DISTVERSIONSUFFIX= .${BUILD}
.endif
MAINTAINER= cy@FreeBSD.org
COMMENT= Firewall Builder GUI and policy compilers
-.if defined(BUILD)
-CONFLICTS= fwbuilder-[23].* fwbuilder-devel-[23].*
-LIB_DEPENDS= fwbuilder.9:${PORTSDIR}/security/libfwbuilder-devel
+.if defined(DEVEL)
+CONFLICTS= fwbuilder-[23].* fwbuilder-devel-[23].* \
+ libfwbuilder-[23].* libfwbuilder-devel-[23].*
.else
-CONFLICTS= fwbuilder-[23].* fwbuilder-devel-*
-LIB_DEPENDS= fwbuilder.9:${PORTSDIR}/security/libfwbuilder
+CONFLICTS= fwbuilder-[23].* fwbuilder-devel-* \
+ libfwbuilder-[23].* libfwbuilder-devel-*
.endif
+LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt \
+ netsnmp.20:${PORTSDIR}/net-mgmt/net-snmp
-PLIST_SUB= BUILD_VERSION=${DISTVERSION}
+PLIST_SUB= BUILD_VERSION=${DISTVERSION}.${BUILD}
USE_QT_VER= 4
QT_COMPONENTS= corelib \
gui \