aboutsummaryrefslogtreecommitdiff
path: root/security/fwbuilder
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2009-10-27 20:12:54 +0000
committerCy Schubert <cy@FreeBSD.org>2009-10-27 20:12:54 +0000
commit87b82e965d42fa3e0aaa6d10ae5b930100b90853 (patch)
treefa895392dc0eff99ee75cef19318d6d842be9391 /security/fwbuilder
parentbf227be8f1d9f0a4d3f58c2d418607ffff2d430d (diff)
downloadports-87b82e965d42fa3e0aaa6d10ae5b930100b90853.tar.gz
ports-87b82e965d42fa3e0aaa6d10ae5b930100b90853.zip
Notes
Diffstat (limited to 'security/fwbuilder')
-rw-r--r--security/fwbuilder/Makefile1
-rw-r--r--security/fwbuilder/files/patch-src-pflib-PolicyCompiler_pf.cpp24
2 files changed, 25 insertions, 0 deletions
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index a828bb3a84f5..ab986486fad8 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fwbuilder
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= security
.if defined(BUILD)
MASTER_SITES= http://www.fwbuilder.org/nightly_builds/fwbuilder-3.0/build-${BUILD}/
diff --git a/security/fwbuilder/files/patch-src-pflib-PolicyCompiler_pf.cpp b/security/fwbuilder/files/patch-src-pflib-PolicyCompiler_pf.cpp
new file mode 100644
index 000000000000..9cf6bf34c322
--- /dev/null
+++ b/security/fwbuilder/files/patch-src-pflib-PolicyCompiler_pf.cpp
@@ -0,0 +1,24 @@
+diff -urPN --exclude=CVS --exclude=.svn --exclude=00_TRANS.TBL export/home/cy/freebsd/fwbuilder/work/fwbuilder-3.0.7/src/pflib/PolicyCompiler_pf.cpp usr/ports/security/fwbuilder.old/work/fwbuilder-3.0.6/src/pflib/PolicyCompiler_pf.cpp
+--- src/pflib/PolicyCompiler_pf.cpp 2009-09-18 12:28:39.000000000 -0700
++++ src/pflib/PolicyCompiler_pf.cpp 2009-08-18 08:27:52.000000000 -0700
+@@ -521,8 +521,7 @@
+ {
+ PolicyRule *rule=getNext(); if (rule==NULL) return false;
+
+- if (rule->getDirection()==PolicyRule::Both &&
+- rule->getAction()==PolicyRule::Route)
++ if (rule->getDirection()==PolicyRule::Both)
+ {
+ PolicyRule *r= compiler->dbcopy->createPolicyRule();
+ compiler->temp_ruleset->add(r);
+@@ -1080,9 +1079,7 @@
+ add( new fillDirection("determine directions" ));
+
+ // commented out for bug #2828602
+-// ... and put back per #2844561
+-// both bug reports/patches are by Tom Judge (tomjudge on sourceforge)
+- add( new SplitDirection("split rules with direction 'both'" ));
++// add( new SplitDirection("split rules with direction 'both'" ));
+
+ add( new addLoopbackForRedirect(
+ "add loopback to rules that permit redirected services" ) );