aboutsummaryrefslogtreecommitdiff
path: root/security/fwbuilder
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-20 15:44:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-20 15:44:02 +0000
commit0c3a7b3879f3c557ecb0fc91673756289eafaed4 (patch)
tree0b6926a0c757657654940e740136201ac56da66c /security/fwbuilder
parente877ae152258014a5d1e648b40a4428e0906625c (diff)
Notes
Diffstat (limited to 'security/fwbuilder')
-rw-r--r--security/fwbuilder/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 050a6fc68aea..58b86a5e85b2 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -48,7 +48,7 @@ USE_QT4= corelib \
QTDIR?= ${QT_PREFIX}
USE_OPENSSL= yes
-USES= autoreconf gmake libtool
+USES= autoreconf:build gmake libtool
GNU_CONFIGURE= yes
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
INSTALL_ROOT=${STAGEDIR}
@@ -64,20 +64,27 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
PORTDOCS= *
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} >= 1000055
# IMPORTANT: Newer versions of rcs will NOT work with fwbuilder.
RUN_DEPENDS= rcs:${PORTSDIR}/devel/rcs57
.endif
+.if empty(PORT_OPTIONS:MDOCS)
+BROKEN= DOCS must be enabled in this port
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} '/^\.\/configure/d' ${WRKSRC}/autogen.sh
+
+pre-configure:
+ (cd ${WRKSRC} && ./autogen.sh)
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fwbuilder
@${ECHO} If you are upgrading from a previous version of fwbuilder,
@${ECHO} please make sure to backup your fwbuilder database files
@${ECHO} prior to invoking fwbuilder for the first time.
-.if empty(PORT_OPTIONS:MDOCS)
-BROKEN= DOCS must be enabled in this port
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>