aboutsummaryrefslogtreecommitdiff
path: root/security/fwipe/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-24 21:19:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-24 21:19:48 +0000
commit141f8510d6c622c9b1a8f7dd1cac5a5a32082ef3 (patch)
tree8d3a35663747ff659c251ace73b8b08873b2317a /security/fwipe/Makefile
parentf45289b20433b8b7a00f197c339ff4fe0522391d (diff)
Notes
Diffstat (limited to 'security/fwipe/Makefile')
-rw-r--r--security/fwipe/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/security/fwipe/Makefile b/security/fwipe/Makefile
new file mode 100644
index 000000000000..05f4cbd07448
--- /dev/null
+++ b/security/fwipe/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: wipe
+# Date created: 2006-09-22
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fwipe
+PORTVERSION= 0.36
+CATEGORIES= security
+MASTER_SITES= http://jeenyus.net/~budney/linux/software/fwipe/ \
+ http://redundancy.redundancy.org/mirror/
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A djb-style file wiping utility
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+PLIST_FILES= bin/fwipe bin/fwipe0 bin/echo0
+MAN1= fwipe0.1 echo0.1 fwipe.1
+
+post-extract:
+ @${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO_CMD} "${CC} -s" > ${WRKSRC}/conf-ld
+ @${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-home
+ @${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-root
+
+.include <bsd.port.mk>