aboutsummaryrefslogtreecommitdiff
path: root/security/fwipe
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-26 18:09:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-26 18:09:39 +0000
commit256f8e13d6a99b5e78a675387d720f1f6e468884 (patch)
treeee77707e06333eb0619c6140c725b2a1bf5d1d27 /security/fwipe
parent0052bd39a666d6f1723d568cbf5d705f1e6ce4fc (diff)
downloadports-256f8e13d6a99b5e78a675387d720f1f6e468884.tar.gz
ports-256f8e13d6a99b5e78a675387d720f1f6e468884.zip
Notes
Diffstat (limited to 'security/fwipe')
-rw-r--r--security/fwipe/Makefile5
-rw-r--r--security/fwipe/files/patch-hier.c22
2 files changed, 20 insertions, 7 deletions
diff --git a/security/fwipe/Makefile b/security/fwipe/Makefile
index 05f4cbd07448..f6d3e056d6c6 100644
--- a/security/fwipe/Makefile
+++ b/security/fwipe/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fwipe
PORTVERSION= 0.36
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://jeenyus.net/~budney/linux/software/fwipe/ \
http://redundancy.redundancy.org/mirror/
@@ -15,10 +16,10 @@ MAINTAINER= lx@redundancy.redundancy.org
COMMENT= A djb-style file wiping utility
ALL_TARGET= it
-INSTALL_TARGET= setup check
+INSTALL_TARGET= setup
PLIST_FILES= bin/fwipe bin/fwipe0 bin/echo0
-MAN1= fwipe0.1 echo0.1 fwipe.1
+MAN1= fwipe0.1 echo0.1 fwipe.1
post-extract:
@${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
diff --git a/security/fwipe/files/patch-hier.c b/security/fwipe/files/patch-hier.c
index 7fbb91692abd..b31374fb3f28 100644
--- a/security/fwipe/files/patch-hier.c
+++ b/security/fwipe/files/patch-hier.c
@@ -1,10 +1,22 @@
---- hier.c.orig Fri Sep 22 07:11:47 2006
-+++ hier.c Fri Sep 22 07:12:15 2006
-@@ -10,11 +10,7 @@
+--- hier.c.orig Sat Apr 14 04:53:05 2001
++++ hier.c Tue Sep 26 08:56:49 2006
+@@ -2,19 +2,15 @@
- d(auto_home,"man",-1,-1,02755);
- d(auto_home,"man/man1",-1,-1,02755);
+ void hier()
+ {
+- h(auto_home,-1,-1,02755);
+- d(auto_home,"bin",-1,-1,02755);
++ h(auto_home,-1,-1,0755);
++ d(auto_home,"bin",-1,-1,0755);
+ c(auto_home,"bin","fwipe0",-1,-1,0755);
+ c(auto_home,"bin","echo0",-1,-1,0755);
+ c(auto_home,"bin","fwipe",-1,-1,0755);
+
+- d(auto_home,"man",-1,-1,02755);
+- d(auto_home,"man/man1",-1,-1,02755);
- d(auto_home,"man/cat1",-1,-1,02755);
++ d(auto_home,"man",-1,-1,0755);
++ d(auto_home,"man/man1",-1,-1,0755);
c(auto_home,"man/man1","fwipe0.1",-1,-1,0644);
- c(auto_home,"man/cat1","fwipe0.0",-1,-1,0644);
c(auto_home,"man/man1","echo0.1",-1,-1,0644);