aboutsummaryrefslogtreecommitdiff
path: root/security/fwlogwatch
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2002-10-27 22:59:15 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2002-10-27 22:59:15 +0000
commite91ca99d32957a7d74852b25b0451f44a51f81ee (patch)
tree3850c88eac00393a451ed2b5047296a6f2038c22 /security/fwlogwatch
parent6434a53a9ab856f18660558fe7c0f58c21a59e2e (diff)
downloadports-e91ca99d32957a7d74852b25b0451f44a51f81ee.tar.gz
ports-e91ca99d32957a7d74852b25b0451f44a51f81ee.zip
Notes
Diffstat (limited to 'security/fwlogwatch')
-rw-r--r--security/fwlogwatch/Makefile15
-rw-r--r--security/fwlogwatch/distinfo2
-rw-r--r--security/fwlogwatch/files/patch-Makefile88
-rw-r--r--security/fwlogwatch/files/patch-main.h17
4 files changed, 77 insertions, 45 deletions
diff --git a/security/fwlogwatch/Makefile b/security/fwlogwatch/Makefile
index bbc28afa607b..751e837247b1 100644
--- a/security/fwlogwatch/Makefile
+++ b/security/fwlogwatch/Makefile
@@ -7,27 +7,22 @@
#
PORTNAME= fwlogwatch
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.9
CATEGORIES= security
-MASTER_SITES= http://www.kyb.uni-stuttgart.de/boris/sw/
+MASTER_SITES= http://www.kybs.de/boris/sw/
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+USE_BZIP2= yes
USE_REINPLACE= yes
+MAKE_ENV= MKDIR="${MKDIR}"
INSTALL_TARGET= install install-config install-i18n
-MANCOMPRESSES= no
+
MAN8= fwlogwatch.8
-MAKE_ENV= MKDIR="${MKDIR}"
post-patch:
- @${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,g; \
- s,/usr/local,${PREFIX},g; \
- s,/usr/share,${PREFIX}/share,g; \
- s,%%LOCALBASE%%,${LOCALBASE},g' \
- ${WRKSRC}/Makefile ${WRKSRC}/main.h
@${REINPLACE_CMD} -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
post-install:
diff --git a/security/fwlogwatch/distinfo b/security/fwlogwatch/distinfo
index d48d17b71d5c..39fd259e5cfc 100644
--- a/security/fwlogwatch/distinfo
+++ b/security/fwlogwatch/distinfo
@@ -1 +1 @@
-MD5 (fwlogwatch-0.6.tar.gz) = cdc5ba4d72c2a528503e2682fb24f493
+MD5 (fwlogwatch-0.9.tar.bz2) = b58bfa714f10995a0012df87a6ae7fc9
diff --git a/security/fwlogwatch/files/patch-Makefile b/security/fwlogwatch/files/patch-Makefile
index ce7ea4e47653..b7264cb1bb82 100644
--- a/security/fwlogwatch/files/patch-Makefile
+++ b/security/fwlogwatch/files/patch-Makefile
@@ -1,58 +1,78 @@
---- Makefile.orig Sun Feb 24 07:15:21 2002
-+++ Makefile Wed Mar 13 05:04:51 2002
+--- Makefile.orig Sun Aug 18 21:32:26 2002
++++ Makefile Fri Oct 25 03:16:30 2002
@@ -1,10 +1,10 @@
- # $Id: Makefile,v 1.56 2002/02/24 12:15:21 bw Exp $
+ # $Id: Makefile,v 1.66 2002/08/18 12:32:26 bw Exp $
# Linux
-CC = gcc
--CFLAGS = -pipe -O2 -Wall #-pedantic -Wpointer-arith #-g #-p
+-CFLAGS = -DHAVE_ZLIB -DHAVE_GETTEXT -DHAVE_IPV6 -pipe -O2 -Wall #-pedantic -Wpointer-arith #-g #-p
-LDFLAGS = #-g #-static -p
-LIBS = -lcrypt -lz #-lc_p
+#CC = gcc
-+#CFLAGS = -pipe -O2 -Wall #-pedantic -Wpointer-arith #-g #-p
++#CFLAGS = -DHAVE_ZLIB -DHAVE_GETTEXT -DHAVE_IPV6 -pipe -O2 -Wall #-pedantic -Wpointer-arith #-g #-p
+#LDFLAGS = #-g #-static -p
+#LIBS = -lcrypt -lz #-lc_p
# Solaris
- #LIBS = -lnsl -lsocket -lz -lcrypt
-@@ -23,8 +23,8 @@
+ #LIBS = -lnsl -lsocket -lcrypt -lz
+@@ -22,9 +22,12 @@
+ #LIBS = -L/usr/local/lib -lz -lintl
# FreeBSD
- #CC = gcc
--#CFLAGS = -pipe -O2 -Wall -I/usr/local/include
--#LIBS = -L/usr/local/lib -lintl -lcrypt -lz
-+CFLAGS += -I%%LOCALBASE%%/include
-+LIBS = -L%%LOCALBASE%%/lib -lintl -lcrypt -lz
+-#CC = gcc
+-#CFLAGS = -DHAVE_ZLIB -DHAVE_GETTEXT -pipe -O2 -Wall -I/usr/local/include
+-#LIBS = -L/usr/local/lib -lcrypt -lz -lintl
++CC ?= gcc
++CFLAGS += -DHAVE_ZLIB -DHAVE_GETTEXT -I${LOCALBASE}/include \
++ -DINSTALL_DIR=\"${INSTALL_DIR}\" \
++ -DCONF_DIR=\"${CONF_DIR}\" \
++ -DLOCALE_DIR=\"${LOCALE_DIR}\"
++LIBS = -L${LOCALBASE}/lib -lcrypt -lz -lintl
# You might want to add -DSHORT_NAMES to CFLAGS if you only intend to
# analyze log formats with short list/chain/branch/interface names like
-@@ -35,10 +35,9 @@
- LEX = flex
+@@ -37,12 +40,12 @@
LFLAGS = -B #-f #-p -p -d
--INSTALL = install
+ INSTALL = install
-INSTALL_PROGRAM = $(INSTALL) -s -m 0755
-INSTALL_SCRIPT = $(INSTALL) -m 0755
-INSTALL_DATA = $(INSTALL) -m 0644
-+INSTALL_PROGRAM= ${BSD_INSTALL_PROGRAM}
-+INSTALL_DATA= ${BSD_INSTALL_DATA}
-+INSTALL_SCRIPT= ${BSD_INSTALL_SCRIPT}
+-INSTALL_DIR = /usr/local
+-CONF_DIR = /etc
+-LOCALE_DIR = /usr
++INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
++INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
++INSTALL_DATA = ${BSD_INSTALL_DATA}
++INSTALL_DIR = ${PREFIX}
++CONF_DIR = ${INSTALL_DIR}/etc
++LOCALE_DIR = ${INSTALL_DIR}
- OBJS = cisco_ios.o cisco_pix.o compare.o ipchains.o ipfilter.o \
- main.o modes.o net.o netfilter.o output.o parser.o \
-@@ -82,10 +81,15 @@
+ OBJS = cisco_ios.o cisco_pix.o compare.o ipchains.o ipfilter.o lancom.o \
+ main.o modes.o net.o netfilter.o netscreen.o output.o parser.o \
+@@ -82,18 +85,23 @@
+ $(INSTALL_PROGRAM) fwlogwatch $(INSTALL_DIR)/sbin/fwlogwatch
+ $(INSTALL_SCRIPT) contrib/fwlw_notify $(INSTALL_DIR)/sbin/fwlw_notify
+ $(INSTALL_SCRIPT) contrib/fwlw_respond $(INSTALL_DIR)/sbin/fwlw_respond
+- $(INSTALL_DATA) fwlogwatch.8 $(INSTALL_DIR)/share/man/man8/fwlogwatch.8
++ $(INSTALL_DATA) fwlogwatch.8 $(INSTALL_DIR)/man/man8/fwlogwatch.8
+
+ install-config:
+ $(INSTALL_DATA) fwlogwatch.config $(CONF_DIR)/fwlogwatch.config
+ $(INSTALL_DATA) fwlogwatch.template $(CONF_DIR)/fwlogwatch.template
install-i18n:
- cd po; make
-+ ${MKDIR} ${PREFIX}/share/locale/de/LC_MESSAGES
- $(INSTALL_DATA) po/de.mo /usr/share/locale/de/LC_MESSAGES/fwlogwatch.mo
-+ ${MKDIR} ${PREFIX}/share/locale/pt_BR/LC_MESSAGES
- $(INSTALL_DATA) po/pt_BR.mo /usr/share/locale/pt_BR/LC_MESSAGES/fwlogwatch.mo
-+ ${MKDIR} ${PREFIX}/share/locale/sv/LC_MESSAGES
- $(INSTALL_DATA) po/sv.mo /usr/share/locale/sv/LC_MESSAGES/fwlogwatch.mo
-+ ${MKDIR} ${PREFIX}/share/locale/zh_CN/LC_MESSAGES
- $(INSTALL_DATA) po/zh_CN.mo /usr/share/locale/zh_CN/LC_MESSAGES/fwlogwatch.mo
-+ ${MKDIR} ${PREFIX}/share/locale/zh_TW/LC_MESSAGES
- $(INSTALL_DATA) po/zh_TW.mo /usr/share/locale/zh_TW/LC_MESSAGES/fwlogwatch.mo
-
- uninstall:
+- cd po; make
++ cd po; $(MAKE)
++ ${MKDIR} $(LOCALE_DIR)/share/locale/de/LC_MESSAGES
+ $(INSTALL_DATA) po/de.mo $(LOCALE_DIR)/share/locale/de/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} $(LOCALE_DIR)/share/locale/pt_BR/LC_MESSAGES
+ $(INSTALL_DATA) po/pt_BR.mo $(LOCALE_DIR)/share/locale/pt_BR/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} $(LOCALE_DIR)/share/locale/sv/LC_MESSAGES
+ $(INSTALL_DATA) po/sv.mo $(LOCALE_DIR)/share/locale/sv/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} $(LOCALE_DIR)/share/locale/zh_CN/LC_MESSAGES
+ $(INSTALL_DATA) po/zh_CN.mo $(LOCALE_DIR)/share/locale/zh_CN/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} $(LOCALE_DIR)/share/locale/zh_TW/LC_MESSAGES
+ $(INSTALL_DATA) po/zh_TW.mo $(LOCALE_DIR)/share/locale/zh_TW/LC_MESSAGES/fwlogwatch.mo
+
+ install-rhinit:
diff --git a/security/fwlogwatch/files/patch-main.h b/security/fwlogwatch/files/patch-main.h
new file mode 100644
index 000000000000..582e88e9f976
--- /dev/null
+++ b/security/fwlogwatch/files/patch-main.h
@@ -0,0 +1,17 @@
+--- main.h.orig Wed Aug 21 04:53:51 2002
++++ main.h Fri Oct 25 03:09:26 2002
+@@ -9,9 +9,15 @@
+
+ /* Paths */
+
++#ifndef INSTALL_DIR
+ #define INSTALL_DIR "/usr/local"
++#endif
++#ifndef CONF_DIR
+ #define CONF_DIR "/etc"
++#endif
++#ifndef LOCALE_DIR
+ #define LOCALE_DIR "/usr"
++#endif
+
+ /* i18n */