aboutsummaryrefslogtreecommitdiff
path: root/security/gaim-otr
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-21 15:36:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-21 15:36:17 +0000
commit229e5a2ac7b9dce0f13b6c4ecd06f5cd72c2acb0 (patch)
tree94b5d345d5a90b68648f1b2e69183dc2f493770d /security/gaim-otr
parentbd054a43d9e311d4fe3d23532e16c2c53f6e3a74 (diff)
downloadports-229e5a2ac7b9dce0f13b6c4ecd06f5cd72c2acb0.tar.gz
ports-229e5a2ac7b9dce0f13b6c4ecd06f5cd72c2acb0.zip
Notes
Diffstat (limited to 'security/gaim-otr')
-rw-r--r--security/gaim-otr/Makefile30
-rw-r--r--security/gaim-otr/distinfo4
-rw-r--r--security/gaim-otr/files/patch-Makefile43
-rw-r--r--security/gaim-otr/files/patch-gaim-otr-Makefile22
-rw-r--r--security/gaim-otr/files/patch-gtk-dialog.c19
-rw-r--r--security/gaim-otr/files/patch-libotr-Makefile9
-rw-r--r--security/gaim-otr/files/patch-libotr-context11
-rw-r--r--security/gaim-otr/files/patch-libotr-privkey11
-rw-r--r--security/gaim-otr/files/patch-tools-Makefile44
-rw-r--r--security/gaim-otr/pkg-plist6
10 files changed, 62 insertions, 137 deletions
diff --git a/security/gaim-otr/Makefile b/security/gaim-otr/Makefile
index 198bee86df96..f7431d261e48 100644
--- a/security/gaim-otr/Makefile
+++ b/security/gaim-otr/Makefile
@@ -1,3 +1,4 @@
+# ex:ts=8
# New ports collection makefile for: Gaim-OTR
# Date created: 2004-12-17
# Whom: Conor McDermottroe <ports@mcdermottroe.com>
@@ -6,47 +7,32 @@
#
PORTNAME= otr
-PORTVERSION= 1.0.1
+PORTVERSION= 2.0.1
CATEGORIES= security net
-MASTER_SITES= http://www.cypherpunks.ca/otr/
+MASTER_SITES= http://www.cypherpunks.ca/otr/ \
+ http://www.xelerance.com/mirror/otr/
PKGNAMEPREFIX= gaim-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@mcdermottroe.com
COMMENT= Allows deniable private conversations using GAIM
-BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim \
- pkg-config:${PORTSDIR}/devel/pkgconfig
+BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim
RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim
-LIB_DEPENDS= gpg-error:${PORTSDIR}/security/libgpg-error \
+LIB_DEPENDS= otr:${PORTSDIR}/security/libotr \
gcrypt:${PORTSDIR}/security/libgcrypt
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gtk20
USE_REINPLACE= yes
-MAN1= otr_toolkit.1
-MLINKS= otr_toolkit.1 otr_parse.1 \
- otr_toolkit.1 otr_sesskeys.1 \
- otr_toolkit.1 otr_mackey.1 \
- otr_toolkit.1 otr_readforge.1 \
- otr_toolkit.1 otr_modify.1 \
- otr_toolkit.1 otr_remac.1
-
post-patch:
${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
- ${WRKSRC}/gaim-otr/Makefile \
- ${WRKSRC}/libotr/Makefile \
- ${WRKSRC}/tools/Makefile
+ ${WRKSRC}/Makefile
${REINPLACE_CMD} -e "s|%%X11BASE%%|${X11BASE}|g" \
- ${WRKSRC}/gaim-otr/Makefile
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_DATA} ${WRKSRC}/gaim-otr.so ${PREFIX}/lib/gaim
- ${INSTALL_MAN} ${WRKSRC}/tools/otr_toolkit.1 ${PREFIX}/man/man1
-.for P in otr_parse otr_sesskeys otr_mackey otr_readforge otr_modify otr_remac
- ${INSTALL_PROGRAM} ${WRKSRC}/${P} ${PREFIX}/bin
-.endfor
.include <bsd.port.mk>
diff --git a/security/gaim-otr/distinfo b/security/gaim-otr/distinfo
index 7e395c136491..63da3f77bc2c 100644
--- a/security/gaim-otr/distinfo
+++ b/security/gaim-otr/distinfo
@@ -1,2 +1,2 @@
-MD5 (gaim-otr-1.0.1.tar.gz) = efc22af7c4a17448da75419bbaeb80d6
-SIZE (gaim-otr-1.0.1.tar.gz) = 76536
+MD5 (gaim-otr-2.0.1.tar.gz) = 873568dac983b7182ad3ac6545567377
+SIZE (gaim-otr-2.0.1.tar.gz) = 34691
diff --git a/security/gaim-otr/files/patch-Makefile b/security/gaim-otr/files/patch-Makefile
index 61a09b299f92..ef5cde9de6af 100644
--- a/security/gaim-otr/files/patch-Makefile
+++ b/security/gaim-otr/files/patch-Makefile
@@ -1,10 +1,33 @@
---- Makefile.bak Fri Dec 17 16:19:08 2004
-+++ Makefile Fri Dec 17 16:19:16 2004
-@@ -1,4 +1,4 @@
- all install clean distclean:
-- make -C libotr $@
-- make -C gaim-otr $@
-- make -C tools $@
-+ gmake -C libotr $@
-+ gmake -C gaim-otr $@
-+ gmake -C tools $@
+--- Makefile.orig Wed Feb 23 14:49:10 2005
++++ Makefile Mon Mar 21 18:31:51 2005
+@@ -2,7 +2,7 @@
+ GAIM_OTR_VERSION = 2.0.1
+
+ # Replace this with the path to the GAIM headers
+-GAIM_SOURCE ?= /usr/include/gaim
++GAIM_SOURCE ?= %%X11BASE%%/include/gaim
+
+ # If you don't have pkg-config, put the appropriate -I entry on the next line
+ GTK_HDRS ?= `pkg-config --cflags glib-2.0 gtk+-2.0`
+@@ -10,10 +10,10 @@
+ # The location of the libotr include files. Note that if, for example,
+ # the full path of message.h is /usr/include/libotr/message.h, you
+ # should put /usr/include on the next line, not /usr/include/libotr
+-LIBOTRINCDIR = /usr/include
++LIBOTRINCDIR = %%LOCALBASE%%/include
+
+ # The locataion of libotr.a.
+-LIBOTRLIBDIR = /usr/lib
++LIBOTRLIBDIR = %%LOCALBASE%%/lib
+
+ # The target
+ TARGET = gaim-otr.so
+@@ -29,7 +29,7 @@
+ -lgcrypt -lgpg-error
+ else
+ FPIC = -fPIC
+-LDFLAGS = -module -avoid-version
++LDFLAGS = -module -avoid-version -L%%LOCALBASE%%/lib
+ LDLIBS = -lotr -lgcrypt
+ endif
+
diff --git a/security/gaim-otr/files/patch-gaim-otr-Makefile b/security/gaim-otr/files/patch-gaim-otr-Makefile
deleted file mode 100644
index a8f0ce0348c7..000000000000
--- a/security/gaim-otr/files/patch-gaim-otr-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- gaim-otr/Makefile.bak Fri Dec 17 17:11:49 2004
-+++ gaim-otr/Makefile Fri Dec 17 17:12:57 2004
-@@ -1,5 +1,5 @@
- # Replace this with the path to the GAIM headers
--GAIM_SOURCE ?= /usr/include/gaim
-+GAIM_SOURCE ?= %%X11BASE%%/include/gaim
-
- # If you don't have pkg-config, put the appropriate -I entry on the next line
- GTK_HDRS ?= `pkg-config --cflags glib-2.0 gtk+-2.0`
-@@ -19,10 +19,10 @@
- all: $(TARGET)
-
- $(TARGET): otr-plugin.o ui.o dialogs.o $(LIBOTR_DIR)/libotr.a
-- $(CC) -g -shared -module -avoid-version $^ -o $@ -lgcrypt
-+ $(CC) -g -shared -module -avoid-version -L %%LOCALBASE%%/lib $^ -o $@ -lgcrypt
-
- $(LIBOTR_DIR)/libotr.a: FORCE
-- make -C $(LIBOTR_DIR) libotr.a
-+ gmake -C $(LIBOTR_DIR) libotr.a
-
- install: all
- install -d $(INSTALLDIR)
diff --git a/security/gaim-otr/files/patch-gtk-dialog.c b/security/gaim-otr/files/patch-gtk-dialog.c
new file mode 100644
index 000000000000..b53d75000b7f
--- /dev/null
+++ b/security/gaim-otr/files/patch-gtk-dialog.c
@@ -0,0 +1,19 @@
+--- gtk-dialog.c.orig Tue Feb 8 18:31:12 2005
++++ gtk-dialog.c Thu Apr 21 17:31:33 2005
+@@ -156,6 +156,7 @@
+ const char *protocol_print;
+ GtkWidget *label;
+ GtkWidget *dialog;
++ OtrgDialogWaitHandle handle;
+
+ p = gaim_find_prpl(protocol);
+ protocol_print = (p ? p->info->name : "Unknown");
+@@ -166,7 +167,7 @@
+
+ dialog = create_dialog(GAIM_NOTIFY_MSG_INFO, title, primary, secondary,
+ 0, &label);
+- OtrgDialogWaitHandle handle = malloc(sizeof(struct s_OtrgDialogWait));
++ handle = malloc(sizeof(struct s_OtrgDialogWait));
+ handle->dialog = dialog;
+ handle->label = label;
+
diff --git a/security/gaim-otr/files/patch-libotr-Makefile b/security/gaim-otr/files/patch-libotr-Makefile
deleted file mode 100644
index 1fb1dc7167ad..000000000000
--- a/security/gaim-otr/files/patch-libotr-Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
---- libotr/Makefile.bak Fri Dec 17 16:31:14 2004
-+++ libotr/Makefile Fri Dec 17 16:31:53 2004
-@@ -1,5 +1,5 @@
- CC ?= gcc
--override CFLAGS += -g -Wall -fPIC
-+CFLAGS += -g -Wall -fPIC -I %%LOCALBASE%%/include
- LDFLAGS ?= -lgcrypt -g
-
- all: libotr.a
diff --git a/security/gaim-otr/files/patch-libotr-context b/security/gaim-otr/files/patch-libotr-context
deleted file mode 100644
index 63c6ea038f9f..000000000000
--- a/security/gaim-otr/files/patch-libotr-context
+++ /dev/null
@@ -1,11 +0,0 @@
---- libotr/context.h.bak Fri Dec 17 17:14:42 2004
-+++ libotr/context.h Fri Dec 17 17:14:53 2004
-@@ -20,7 +20,7 @@
- #ifndef __CONTEXT_H__
- #define __CONTEXT_H__
-
--#include "gcrypt.h"
-+#include <gcrypt.h>
- #include "dh.h"
-
- typedef enum {
diff --git a/security/gaim-otr/files/patch-libotr-privkey b/security/gaim-otr/files/patch-libotr-privkey
deleted file mode 100644
index f5a7f5be53c6..000000000000
--- a/security/gaim-otr/files/patch-libotr-privkey
+++ /dev/null
@@ -1,11 +0,0 @@
---- libotr/privkey.c.bak Fri Dec 17 16:24:41 2004
-+++ libotr/privkey.c Fri Dec 17 16:24:54 2004
-@@ -24,7 +24,7 @@
- #include <sys/stat.h>
-
- /* libgcrypt headers */
--#include "gcrypt.h"
-+#include <gcrypt.h>
-
- /* libotr headers */
- #include "proto.h"
diff --git a/security/gaim-otr/files/patch-tools-Makefile b/security/gaim-otr/files/patch-tools-Makefile
deleted file mode 100644
index 8e538a7c082a..000000000000
--- a/security/gaim-otr/files/patch-tools-Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
---- tools/Makefile.bak Fri Dec 17 17:18:13 2004
-+++ tools/Makefile Fri Dec 17 17:20:57 2004
-@@ -9,7 +9,7 @@
- INSTALLMANDIR = $(DESTDIR)/usr/share/man/man1
-
- CC ?= gcc
--override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -fPIC
-+override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -I%%LOCALBASE%%/include -L%%LOCALBASE%%/lib -fPIC
-
- TARGETS = $(TARGET_DIR)/otr_parse \
- $(TARGET_DIR)/otr_sesskeys \
-@@ -21,25 +21,25 @@
- all: $(TARGETS)
-
- $(TARGET_DIR)/otr_parse: otr_parse.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
-- $(CC) -g $^ -o $@ -lgcrypt
-+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
-
- $(TARGET_DIR)/otr_sesskeys: otr_sesskeys.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
-- $(CC) -g $^ -o $@ -lgcrypt
-+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
-
- $(TARGET_DIR)/otr_mackey: otr_mackey.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
-- $(CC) -g $^ -o $@ -lgcrypt
-+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
-
- $(TARGET_DIR)/otr_readforge: otr_readforge.o readotr.o sesskeys.o parse.o sha1hmac.o aes.o ctrmode.o $(LIBOTR_DIR)/libotr.a
-- $(CC) -g $^ -o $@ -lgcrypt
-+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
-
- $(TARGET_DIR)/otr_modify: otr_modify.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
-- $(CC) -g $^ -o $@ -lgcrypt
-+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
-
- $(TARGET_DIR)/otr_remac: otr_remac.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
-- $(CC) -g $^ -o $@ -lgcrypt
-+ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
-
- $(LIBOTR_DIR)/libotr.a: FORCE
-- make -C $(LIBOTR_DIR) libotr.a
-+ gmake -C $(LIBOTR_DIR) libotr.a
-
- install: all
- install -d $(INSTALLBINDIR)
diff --git a/security/gaim-otr/pkg-plist b/security/gaim-otr/pkg-plist
index a8bb7bc96d4b..362781970305 100644
--- a/security/gaim-otr/pkg-plist
+++ b/security/gaim-otr/pkg-plist
@@ -1,7 +1 @@
lib/gaim/gaim-otr.so
-bin/otr_parse
-bin/otr_sesskeys
-bin/otr_mackey
-bin/otr_readforge
-bin/otr_modify
-bin/otr_remac