aboutsummaryrefslogtreecommitdiff
path: root/security/gnome-gpg/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-10-14 09:10:57 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-10-14 09:10:57 +0000
commit70cd04b258ef8e080ec4dadd31604886141dfa7f (patch)
treea7169ed130dc90bb1877e533db4e24892872f1f5 /security/gnome-gpg/Makefile
parent3543e1ec2efaf1b9e0ac814880417d8aaf873032 (diff)
Notes
Diffstat (limited to 'security/gnome-gpg/Makefile')
-rw-r--r--security/gnome-gpg/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/gnome-gpg/Makefile b/security/gnome-gpg/Makefile
new file mode 100644
index 000000000000..4eeff95fef14
--- /dev/null
+++ b/security/gnome-gpg/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gnome-gpg
+# Date created: 2006-09-02
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/security/gnome-gpg/Makefile,v 1.1 2006/09/02 15:20:58 ahze Exp $
+
+PORTNAME= gnome-gpg
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Simple commandline wrapper around gpg for gnome-keyring
+
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+LIB_DEPENDS= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= libgnomeui
+
+PLIST_FILES= bin/gnome-gpg
+MAN1= gnome-gpg.1
+
+.include <bsd.port.mk>