aboutsummaryrefslogtreecommitdiff
path: root/security/gnome-keyring-sharp/Makefile
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-09-30 18:23:42 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-09-30 18:23:42 +0000
commit231213ccac5faef7eefcbf0d00758d62704cc57c (patch)
treed3b339962693b5bdf4b4a310108b31857790ac71 /security/gnome-keyring-sharp/Makefile
parenta89eaae57b78de96826f7b561f8b16a7e2d13084 (diff)
Notes
Diffstat (limited to 'security/gnome-keyring-sharp/Makefile')
-rw-r--r--security/gnome-keyring-sharp/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/gnome-keyring-sharp/Makefile b/security/gnome-keyring-sharp/Makefile
new file mode 100644
index 000000000000..fa9e648b2fd5
--- /dev/null
+++ b/security/gnome-keyring-sharp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gnome-keyring-sharp
+# Date created: 2008-10-08
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-keyring-sharp
+PORTVERSION= 1.0.2
+CATEGORIES= security
+MASTER_SITES= http://www.go-mono.com/archive/${PORTNAME}/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Fully managed implementation of gnome-keyring
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-1.0.pc:${PORTSDIR}/devel/ndesk-dbus \
+ ${LOCALBASE}/libdata/pkgconfig/gnome-keyring-1.pc:${PORTSDIR}/security/gnome-keyring
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtksharp20
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>