aboutsummaryrefslogtreecommitdiff
path: root/security/gnome-keyring
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /security/gnome-keyring
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
Notes
Diffstat (limited to 'security/gnome-keyring')
-rw-r--r--security/gnome-keyring/Makefile13
-rw-r--r--security/gnome-keyring/distinfo6
-rw-r--r--security/gnome-keyring/files/patch-configure20
-rw-r--r--security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c10
-rw-r--r--security/gnome-keyring/files/patch-library_gnome-keyring.c11
-rw-r--r--security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c10
-rw-r--r--security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-module.c10
-rw-r--r--security/gnome-keyring/pkg-plist9
8 files changed, 79 insertions, 10 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index f286bda257f9..7a93115cf71b 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -3,31 +3,30 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/security/gnome-keyring/Makefile,v 1.1 2007/11/30 19:09:39 marcus Exp $
+# $MCom: ports/security/gnome-keyring/Makefile,v 1.59 2008/03/09 18:30:40 mezz Exp $
#
PORTNAME= gnome-keyring
-PORTVERSION= 2.20.3
-PORTREVISION= 1
+PORTVERSION= 2.22.0
CATEGORIES= security gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-DISTNAME= gnome-keyring-${PORTVERSION}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A program that keeps passwords and other secrets
LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal \
+ tasn1.3:${PORTSDIR}/security/libtasn1 \
gcrypt.15:${PORTSDIR}/security/libgcrypt
USE_BZIP2= yes
-USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack
+USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack intlhack gconf2
USE_GMAKE= yes
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= gnome-keyring.schemas
.include <bsd.port.mk>
diff --git a/security/gnome-keyring/distinfo b/security/gnome-keyring/distinfo
index 53d4eb46d43a..43065d85acc2 100644
--- a/security/gnome-keyring/distinfo
+++ b/security/gnome-keyring/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-keyring-2.20.3.tar.bz2) = 2205177a168e745fa803c96a4fb62102
-SHA256 (gnome2/gnome-keyring-2.20.3.tar.bz2) = 5bfb69897c9042968637c33beca098a4bbabcb4b9863f3f49504bc82089fa970
-SIZE (gnome2/gnome-keyring-2.20.3.tar.bz2) = 541431
+MD5 (gnome2/gnome-keyring-2.22.0.tar.bz2) = d27c5bf11579069eb694f93b71364bb4
+SHA256 (gnome2/gnome-keyring-2.22.0.tar.bz2) = d5aa2c467fcb842b035a4fc424031dcc5a67ece01bc8f1c38fe10cbc3adbbd42
+SIZE (gnome2/gnome-keyring-2.22.0.tar.bz2) = 882416
diff --git a/security/gnome-keyring/files/patch-configure b/security/gnome-keyring/files/patch-configure
new file mode 100644
index 000000000000..235656df1b7e
--- /dev/null
+++ b/security/gnome-keyring/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2008-02-11 21:29:42.000000000 -0500
++++ configure 2008-02-11 21:29:51.000000000 -0500
+@@ -23793,7 +23793,7 @@ else
+ tests_status="no"
+ fi
+
+- if test "$enable_tests" == "yes"; then
++ if test "$enable_tests" = "yes"; then
+ WITH_TESTS_TRUE=
+ WITH_TESTS_FALSE='#'
+ else
+@@ -25228,7 +25228,7 @@ fi
+
+ dbus_status=$DBUS_VERSION
+ fi
+- if test "$enable_dbus" == "yes"; then
++ if test "$enable_dbus" = "yes"; then
+ WITH_DBUS_TRUE=
+ WITH_DBUS_FALSE='#'
+ else
diff --git a/security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c b/security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c
new file mode 100644
index 000000000000..185e929dd298
--- /dev/null
+++ b/security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c
@@ -0,0 +1,10 @@
+--- keyrings/gkr-keyrings.c.orig 2008-02-11 21:30:10.000000000 -0500
++++ keyrings/gkr-keyrings.c 2008-02-11 21:30:19.000000000 -0500
+@@ -35,6 +35,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <string.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <sys/types.h>
diff --git a/security/gnome-keyring/files/patch-library_gnome-keyring.c b/security/gnome-keyring/files/patch-library_gnome-keyring.c
new file mode 100644
index 000000000000..625a65cc72c0
--- /dev/null
+++ b/security/gnome-keyring/files/patch-library_gnome-keyring.c
@@ -0,0 +1,11 @@
+--- library/gnome-keyring.c.orig 2008-02-26 22:05:10.000000000 -0600
++++ library/gnome-keyring.c 2008-02-26 22:05:30.000000000 -0600
+@@ -50,6 +50,8 @@
+ #include <dbus/dbus.h>
+ #endif
+
++extern char **environ;
++
+ typedef enum {
+ CALLBACK_DONE,
+ CALLBACK_GET_STRING,
diff --git a/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c b/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c
new file mode 100644
index 000000000000..4bd5a923f4f4
--- /dev/null
+++ b/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c
@@ -0,0 +1,10 @@
+--- pkcs11/gkr-pkcs11-daemon.c.orig 2008-02-11 21:30:48.000000000 -0500
++++ pkcs11/gkr-pkcs11-daemon.c 2008-02-11 21:30:58.000000000 -0500
+@@ -35,6 +35,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <string.h>
+ #include <errno.h>
+ #include <unistd.h>
+
diff --git a/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-module.c b/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-module.c
new file mode 100644
index 000000000000..57d2f1888016
--- /dev/null
+++ b/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-module.c
@@ -0,0 +1,10 @@
+--- pkcs11/gkr-pkcs11-module.c.orig 2008-02-11 21:26:56.000000000 -0500
++++ pkcs11/gkr-pkcs11-module.c 2008-02-11 21:27:08.000000000 -0500
+@@ -36,6 +36,7 @@
+ #include <sys/socket.h>
+ #include <sys/un.h>
+
++#include <string.h>
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <pthread.h>
diff --git a/security/gnome-keyring/pkg-plist b/security/gnome-keyring/pkg-plist
index bde5f3d2a70e..1607e5fcbb6a 100644
--- a/security/gnome-keyring/pkg-plist
+++ b/security/gnome-keyring/pkg-plist
@@ -2,6 +2,9 @@ bin/gnome-keyring-daemon
include/gnome-keyring-1/gnome-keyring-memory.h
include/gnome-keyring-1/gnome-keyring-result.h
include/gnome-keyring-1/gnome-keyring.h
+lib/gnome-keyring/gnome-keyring-pkcs11.a
+lib/gnome-keyring/gnome-keyring-pkcs11.la
+lib/gnome-keyring/gnome-keyring-pkcs11.so
lib/libgnome-keyring.a
lib/libgnome-keyring.la
lib/libgnome-keyring.so
@@ -11,9 +14,11 @@ lib/security/pam_gnome_keyring.la
lib/security/pam_gnome_keyring.so
libdata/pkgconfig/gnome-keyring-1.pc
libexec/gnome-keyring-ask
+share/dbus-1/services/org.gnome.keyring.service
%%DOCSDIR%%/ch01.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-acl.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-attributes.html
+%%DOCSDIR%%/gnome-keyring-gnome-keyring-daemon.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-find.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-generic-callbacks.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-item-info.html
@@ -23,6 +28,7 @@ libexec/gnome-keyring-ask
%%DOCSDIR%%/gnome-keyring-gnome-keyring-memory.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-misc.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-network.html
+%%DOCSDIR%%/gnome-keyring-gnome-keyring-password.html
%%DOCSDIR%%/gnome-keyring-gnome-keyring-result.html
%%DOCSDIR%%/gnome-keyring.devhelp
%%DOCSDIR%%/gnome-keyring.devhelp2
@@ -58,6 +64,7 @@ share/locale/fi/LC_MESSAGES/gnome-keyring.mo
share/locale/fr/LC_MESSAGES/gnome-keyring.mo
share/locale/gl/LC_MESSAGES/gnome-keyring.mo
share/locale/gu/LC_MESSAGES/gnome-keyring.mo
+share/locale/he/LC_MESSAGES/gnome-keyring.mo
share/locale/hi/LC_MESSAGES/gnome-keyring.mo
share/locale/hr/LC_MESSAGES/gnome-keyring.mo
share/locale/hu/LC_MESSAGES/gnome-keyring.mo
@@ -78,6 +85,7 @@ share/locale/ms/LC_MESSAGES/gnome-keyring.mo
share/locale/nb/LC_MESSAGES/gnome-keyring.mo
share/locale/ne/LC_MESSAGES/gnome-keyring.mo
share/locale/nl/LC_MESSAGES/gnome-keyring.mo
+share/locale/nn/LC_MESSAGES/gnome-keyring.mo
share/locale/oc/LC_MESSAGES/gnome-keyring.mo
share/locale/or/LC_MESSAGES/gnome-keyring.mo
share/locale/pa/LC_MESSAGES/gnome-keyring.mo
@@ -106,6 +114,7 @@ share/locale/zh_HK/LC_MESSAGES/gnome-keyring.mo
share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
@dirrm %%DOCSDIR%%
@dirrmtry lib/security
+@dirrm lib/gnome-keyring
@dirrm include/gnome-keyring-1
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK