aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-08-26 15:01:02 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-08-26 15:01:02 +0000
commit1eaf6724ff51af28321bfa018c02be576afe4df2 (patch)
treec33deb929fbda64eedd9f02acd1182246a7ef8a3 /security/gnupg/Makefile
parentd86e2f1b5a1ae66c72dc2651d6ec76fcd46fdd08 (diff)
downloadports-1eaf6724ff51af28321bfa018c02be576afe4df2.tar.gz
ports-1eaf6724ff51af28321bfa018c02be576afe4df2.zip
Notes
Diffstat (limited to 'security/gnupg/Makefile')
-rw-r--r--security/gnupg/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 451a725d30c0..bed90fe01f17 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -35,14 +35,15 @@ TEST_TARGET= check
SUB_FILES= pkg-message
-OPTIONS_DEFINE= DOCS GNUTLS LARGE_RSA LDAP NLS SCDAEMON SUID_GPG
-OPTIONS_DEFAULT=GNUTLS SCDAEMON
+OPTIONS_DEFINE= DOCS GNUTLS LARGE_RSA LDAP NLS SCDAEMON SUID_GPG WKS_SERVER
+OPTIONS_DEFAULT=GNUTLS SCDAEMON WKS_SERVER
OPTIONS_SUB= yes
LARGE_RSA_DESC= Enable support for 8192-bit RSA keys
LDAP_DESC= LDAP keyserver interface
SCDAEMON_DESC= Enable Smartcard daemon (with libusb)
SUID_GPG_DESC= Install GPG with suid
+WKS_SERVER= Install the Web Key Service server
GNUTLS_CONFIGURE_ENABLE=gnutls
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
@@ -58,6 +59,8 @@ NLS_USES= gettext
SCDAEMON_CONFIGURE_ENABLE= scdaemon
+WKS_SERVER_CONFIGURE_ENABLE= wks-tools
+
post-install:
@${MV} ${STAGEDIR}${DATADIR}/help*.txt ${STAGEDIR}${DOCSDIR}