aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-08-05 09:41:57 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-08-05 09:41:57 +0000
commitf31630bb91f27d1f0245554b56f472cb698138b6 (patch)
tree03aebbb1aea26ff8227c7f2ebdb1fc30b1b3abcf /security/gnupg/Makefile
parentf5fc5cd8ae082b9afeef694a5daa5376a227ebef (diff)
Notes
Diffstat (limited to 'security/gnupg/Makefile')
-rw-r--r--security/gnupg/Makefile63
1 files changed, 33 insertions, 30 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index e89fe5b8f5fb..54410140f384 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 2.0.19
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
@@ -16,16 +17,17 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= The GNU Privacy Guard
-LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
- gcrypt.18:${PORTSDIR}/security/libgcrypt \
- gpg-error:${PORTSDIR}/security/libgpg-error \
- ksba.19:${PORTSDIR}/security/libksba \
- pth.20:${PORTSDIR}/devel/pth
-
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LIB
+
+LIB_DEPENDS= assuan:${PORTSDIR}/security/libassuan \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ gpg-error:${PORTSDIR}/security/libgpg-error \
+ ksba:${PORTSDIR}/security/libksba \
+ pth:${PORTSDIR}/devel/pth
+
USE_BZIP2= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -37,37 +39,38 @@ CONFIGURE_ARGS+= --disable-doc
.else
MAN1= gpg2.1 gpgsm.1 gpgv2.1 gpg-agent.1 scdaemon.1 watchgnupg.1 \
gpgconf.1 gpg-preset-passphrase.1 gpg-connect-agent.1 \
- gpgparsemail.1 symcryptrun.1 gpgsm-gencert.sh.1 gpg-zip.1
+ gpgparsemail.1 symcryptrun.1 gpgsm-gencert.sh.1
MAN8= addgnupghome.8 applygnupgdefaults.8
INFO= gnupg
.endif
-OPTIONS= PINENTRY "Use pinentry" off \
- LDAP "LDAP keyserver interface" off \
- SCDAEMON "Enable Smartcard daemon (with libusb)" off \
- CURL "Use the real curl library (worked around if no)" on \
- GPGSM "Enable GPGSM (requires LDAP)" off \
- KDNS "Use DNS CERT helper" off \
- STD_SOCKET "Use standard socket for agent" off \
- NLS "National Language Support" off
+OPTIONS_DEFINE= PINENTRY LDAP SCDAEMON CURL GPGSM KDNS STD_SOCKET NLS
+PINENTRY_DESC= Use pinentry
+LDAP_DESC= LDAP keyserver interface
+SCDAEMON_DESC= Enable Smartcard daemon (with libusb)
+CURL_DESC= Use the real curl library (worked around if no)
+GPGSM_DESC= Enable GPGSM (requires LDAP)
+KDNS_DESC= Use DNS CERT helper
+STD_SOCKET_DESC= Use standard socket for agent
+OPTIONS_DEFAULT= CURL
+NO_OPTIONS_SORT= YES
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PINENTRY)
+.if ${PORT_OPTIONS:MPINENTRY}
RUN_DEPENDS+= pinentry>0:${PORTSDIR}/security/pinentry
.endif
-.if defined(WITHOUT_GPGSM)
-CONFIGURE_ARGS+=--disable-gpgsm
-PLIST_SUB+= GPGSM="@comment "
-.else
+.if ${PORT_OPTIONS:MGPGSM}
RUN_DEPENDS+= dirmngr:${PORTSDIR}/security/dirmngr
-WITH_LDAP= YES
-.undef WITHOUT_LDAP
+PORT_OPTIONS+= LDAP
PLIST_SUB+= GPGSM=""
+.else
+CONFIGURE_ARGS+=--disable-gpgsm
+PLIST_SUB+= GPGSM="@comment "
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= YES
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
PLIST_SUB+= LDAP=""
@@ -76,7 +79,7 @@ CONFIGURE_ARGS+=--disable-ldap
PLIST_SUB+= LDAP="@comment "
.endif
-.if defined(WITH_KDNS) && !defined(WITHOUT_KDNS)
+.if ${PORT_OPTIONS:MKDNS}
LIB_DEPENDS+= adns:${PORTSDIR}/dns/adns
PLIST_SUB+= ADNS=""
.else
@@ -84,11 +87,11 @@ CONFIGURE_SUB= -e '/GPGKEYS_KDNS=/s/".*"/""/'
PLIST_SUB+= ADNS="@comment "
.endif
-.if defined(WITH_STD_SOCKET) && !defined(WITHOUT_STD_SOCKET)
+.if ${PORT_OPTIONS:MSTD_SOCKET}
CONFIGURE_ARGS+=--enable-standard-socket
.endif
-.if defined(WITH_NLS) && !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= YES
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -97,7 +100,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_SCDAEMON)
+.if ${PORT_OPTIONS:MSCDAEMON}
CONFIGURE_ARGS+=--enable-scdaemon
. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
@@ -108,7 +111,7 @@ CONFIGURE_ARGS+=--disable-scdaemon
PLIST_SUB+= SCDAEMON="@comment "
.endif
-.if defined(WITHOUT_CURL)
+.if ${PORT_OPTIONS:MCURL}
CONFIGURE_ARGS+=--without-libcurl
.else
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
@@ -131,4 +134,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>