aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg1/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-10-30 21:20:29 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-10-30 21:20:29 +0000
commitf0c7327ec18545ef0394b26f825412bec0c6b2e2 (patch)
treec7cc30868142ff3e9ecd1ba5c5b250782a18c590 /security/gnupg1/Makefile
parent94cb7e99a60ce470c29ac68ab59e76ee08778c1e (diff)
A number of simplifications and improvements.
- Don't download the unusued signature - Use the standard ICONV knob instead of LIBICONV - Improve option descriptions and proper capitalization - Handle the SUID chmod in the plist instead of the Makefile - Simplify CFLAGS modification and skip the unnecessary -std=c89 addition - Don't patch docs installation out, just let pkg DTRT - Switch WWW to https No PORTREVISION bump because most of these changes are NOOPs, except the WWW change which isn't worth forcing a rebuild for.
Notes
Notes: svn path=/head/; revision=424964
Diffstat (limited to 'security/gnupg1/Makefile')
-rw-r--r--security/gnupg1/Makefile28
1 files changed, 11 insertions, 17 deletions
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index 4d942058c003..b9a81672c730 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -5,8 +5,6 @@ PORTVERSION= 1.4.21
CATEGORIES= security
MASTER_SITES= GNUPG
PKGNAMESUFFIX= 1
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= adamw@FreeBSD.org
COMMENT= The GNU Privacy Guard
@@ -25,23 +23,22 @@ PORTDOCS= *
TEST_TARGET= check
-OPTIONS_DEFINE= CURL DOCS LDAP LIBICONV LIBUSB NLS SUID_GPG
+OPTIONS_DEFINE= CURL DOCS LDAP ICONV LIBUSB NLS SUID_GPG
OPTIONS_DEFAULT=CURL
OPTIONS_SUB= yes
-CURL_DESC= use libcurl for the keyserver interface
+CURL_DESC= Use libcurl for the keyserver interface
LDAP_DESC= LDAP keyserver interface
-LIBICONV_DESC= use libiconv
-LIBUSB_DESC= use libusb
-SUID_GPG_DESC= install GPG with suid
+LIBUSB_DESC= Support for USB smart cards
+SUID_GPG_DESC= Install GPG setuid
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_WITH= libcurl=${LOCALBASE}
# Work around a GnuPG configure buglet
CURL_CONFIGURE_ENV= _libcurl_config=${LOCALBASE}/bin/curl-config
-LIBICONV_USES= iconv
-LIBICONV_CONFIGURE_ENABLE= gnupg-iconv
+ICONV_USES= iconv
+ICONV_CONFIGURE_ENABLE= gnupg-iconv
LIBUSB_CONFIGURE_WITH= libusb=${LOCALBASE}
@@ -51,13 +48,13 @@ LDAP_CONFIGURE_WITH= ldap=${LOCALBASE}
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
+SUID_GPG_PLIST_SUB= GPGMODE=4555
+SUID_GPG_PLIST_SUB_OFF= GPGMODE=
+
.include <bsd.port.options.mk>
-.if ${CC} == "clang" || ${OSVERSION} >= 1000024
-CFLAGS:= ${CFLAGS:S/$/ -std=c89/}
-.if (${ARCH} == "i386")
-CFLAGS:= ${CFLAGS:S/$/ -fheinous-gnu-extensions/}
-.endif
+.if ${ARCH} == "i386" && (${CC} == "clang" || ${OSVERSION} >= 1000024)
+CFLAGS+= -fheinous-gnu-extensions
.endif
post-install-DOCS-on:
@@ -70,7 +67,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-post-install-SUID_GPG-on:
- ${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/gpg
-
.include <bsd.port.mk>