aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-12-16 02:16:11 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-12-16 02:16:11 +0000
commit1b09038d56e1aca89e2aefbfac590a8f9e700271 (patch)
tree6b6aa0fc882dc7b7897d11883b3f2d4a7b21c990 /security/gnupg
parent1e29810185e7b4df21d2714dcbf292caeb6bab8b (diff)
downloadports-1b09038d56e1aca89e2aefbfac590a8f9e700271.tar.gz
ports-1b09038d56e1aca89e2aefbfac590a8f9e700271.zip
Notes
Diffstat (limited to 'security/gnupg')
-rw-r--r--security/gnupg/Makefile1
-rw-r--r--security/gnupg/files/patch-keygen.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 446a3708c492..330f5b2e283e 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
diff --git a/security/gnupg/files/patch-keygen.c b/security/gnupg/files/patch-keygen.c
new file mode 100644
index 000000000000..2024ed3f567c
--- /dev/null
+++ b/security/gnupg/files/patch-keygen.c
@@ -0,0 +1,16 @@
+--- g10/keygen.c.orig Tue Jun 21 21:22:17 2005
++++ g10/keygen.c Fri Dec 16 11:03:19 2005
+@@ -3244,11 +3244,13 @@
+ write_keyblock( IOBUF out, KBNODE node )
+ {
+ for( ; node ; node = node->next ) {
++ if(!is_deleted_kbnode(node)) {
+ int rc = build_packet( out, node->pkt );
+ if( rc ) {
+ log_error("build_packet(%d) failed: %s\n",
+ node->pkt->pkttype, g10_errstr(rc) );
+ return G10ERR_WRITE_FILE;
++ }
+ }
+ }
+ return 0;