aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-11-29 15:16:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-11-29 15:16:28 +0000
commitc8db721432cee7bea04b4dbae843fe937d4dcf01 (patch)
tree00524de239993e1fc33f8eb7552e90b089d2a299 /security/gnupg
parentc3dab1a628879bf6ecd1ce94de2e8d77e6c5ea19 (diff)
Notes
Diffstat (limited to 'security/gnupg')
-rw-r--r--security/gnupg/Makefile54
1 files changed, 16 insertions, 38 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 5d86e2b60c76..8ed67b98e259 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -41,23 +41,28 @@ OPTIONS_DEFAULT= CURL
NO_OPTIONS_SORT= YES
OPTIONS_SUB= YES
+DOCS_CONFIGURE_ENABLE= doc
+PINENTRY_RUN_DEPENDS= pinentry>0:${PORTSDIR}/security/pinentry
+GPGSM_RUN_DEPENDS= dirmngr:${PORTSDIR}/security/dirmngr
+GPGSM_CONFIGURE_ENABLE= gpgsm
+MKDNS_LIB_DEPENDS= libadns.so:${PORTSDIR}/dns/adns
+MKDNS_CONFIGURE_ON= --with-adns=${LOCALBASE}
+STD_SOCKET_CONFIGURE_ENABLE= socket
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+SCDAEMON_CONFIGURE_ENABLE= scdaemon
+CURL_LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_ON= --with-libcurl=${LOCALBASE}
+CURL_CONFIGURE_OFF= --without-libcurl
+
.include <bsd.port.options.mk>
-.if ! ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+= --disable-doc
-.else
+.if ${PORT_OPTIONS:MDOCS}
INFO= gnupg
.endif
-.if ${PORT_OPTIONS:MPINENTRY}
-RUN_DEPENDS+= pinentry>0:${PORTSDIR}/security/pinentry
-.endif
-
.if ${PORT_OPTIONS:MGPGSM}
-RUN_DEPENDS+= dirmngr:${PORTSDIR}/security/dirmngr
PORT_OPTIONS+= LDAP
-.else
-CONFIGURE_ARGS+=--disable-gpgsm
.endif
.if ${PORT_OPTIONS:MLDAP}
@@ -67,37 +72,10 @@ CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
CONFIGURE_ARGS+=--disable-ldap
.endif
-.if ${PORT_OPTIONS:MKDNS}
-LIB_DEPENDS+= libadns.so:${PORTSDIR}/dns/adns
-CONFIGURE_ARGS+= --with-adns=${LOCALBASE}
-.else
+.if ! ${PORT_OPTIONS:MKDNS}
CONFIGURE_SUB= -e '/GPGKEYS_KDNS=/s/".*"/""/'
.endif
-.if ${PORT_OPTIONS:MSTD_SOCKET}
-CONFIGURE_ARGS+=--enable-standard-socket
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-.else
-CONFIGURE_ARGS+=--disable-nls
-.endif
-
-.if ${PORT_OPTIONS:MSCDAEMON}
-CONFIGURE_ARGS+=--enable-scdaemon
-.else
-CONFIGURE_ARGS+=--disable-scdaemon
-.endif
-
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+=--with-libcurl=${LOCALBASE}
-.else
-CONFIGURE_ARGS+=--without-libcurl
-.endif
-
verify: checksum
gpg2 --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig