aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2007-01-14 07:27:47 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2007-01-14 07:27:47 +0000
commitb741dbc496ac733740192d470980a28156c799fe (patch)
tree25eba27f3cf717f655e0a3fa4edb30073e5c6e5c /security/gnupg
parent3af2b32e0912cc2aefee83a8dbed013fd0de8646 (diff)
Notes
Diffstat (limited to 'security/gnupg')
-rw-r--r--security/gnupg/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index febb9ad395d7..0e3bb000ac9d 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -41,10 +41,10 @@ MAN8= addgnupghome.8
INFO= gnupg
OPTIONS= LDAP "LDAP keyserver interface" off \
+ NLS "National Language Support" off \
SCDAEMON "Enable Smartcard daemon (with libusb)" off \
CURL "Use the real curl library (worked around if no)" on \
GPGSM "Enable GPGSM" on
-PLIST_SUB= NLS=""
.include <bsd.port.pre.mk>
@@ -66,6 +66,14 @@ CONFIGURE_ARGS+=--disable-ldap
PLIST_SUB+= LDAP="@comment "
.endif
+.if defined(WITH_NLS)
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.if defined(WITH_SCDAEMON)
CONFIGURE_ARGS+=--enable-scdaemon
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb