aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls-devel/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-22 09:15:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-22 09:15:57 +0000
commitc3ba4971e69a27097f346187bd9b004857bd03ee (patch)
tree2aa3d7ef46627e8807b45c6d357df496cf35a4a3 /security/gnutls-devel/Makefile
parente21b86607c4237cf41b748c436a5a777ade416f7 (diff)
Mark broken: Does not build
With gcc: gnome-libtool: compile: cc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -I./../../gl -I./../includes -I./../includes -I./.. -I/usr/local/include -fPIC -O2 -pipe -fno-strict-aliasing -I/usr/local/include/p11-kit-1 -MT x509.lo -MD -MP -MF .deps/x509.Tpo -c x509.c -fPIC -DPIC -o .libs/x509.o x509.c: In function 'gnutls_x509_dn_get_rdn_ava': x509.c:2018: error: dereferencing pointer to incomplete type x509.c:2019: error: dereferencing pointer to incomplete type x509.c:2033: error: dereferencing pointer to incomplete type x509.c:2034: error: dereferencing pointer to incomplete type With clang: x509.c:2018:23: error: incomplete definition of type 'struct asn1_node_st' ava->oid.data = elem->value; ~~~~^ /usr/local/include/libtasn1.h:117:18: note: forward declaration of 'struct asn1_node_st' typedef struct asn1_node_st asn1_node_st; ^ x509.c:2019:23: error: incomplete definition of type 'struct asn1_node_st' ava->oid.size = elem->value_len; ~~~~^ /usr/local/include/libtasn1.h:117:18: note: forward declaration of 'struct asn1_node_st' typedef struct asn1_node_st asn1_node_st; ^ x509.c:2033:13: error: incomplete definition of type 'struct asn1_node_st' ptr = elem->value; ~~~~^ /usr/local/include/libtasn1.h:117:18: note: forward declaration of 'struct asn1_node_st' typedef struct asn1_node_st asn1_node_st; ^ x509.c:2034:16: error: incomplete definition of type 'struct asn1_node_st' remlen = elem->value_len; ~~~~^ /usr/local/include/libtasn1.h:117:18: note: forward declaration of 'struct asn1_node_st' typedef struct asn1_node_st asn1_node_st; ^ Reported by: pkg-fallout since november 2013
Notes
Notes: svn path=/head/; revision=345572
Diffstat (limited to 'security/gnutls-devel/Makefile')
-rw-r--r--security/gnutls-devel/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index 80b405075961..a842b1ed32d6 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -12,6 +12,8 @@ PKGNAMESUFFIX= -devel
MAINTAINER= novel@FreeBSD.org
COMMENT= GNU Transport Layer Security library
+BROKEN= Does not build
+
LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error \
nettle.4:${PORTSDIR}/security/nettle \
p11-kit.0:${PORTSDIR}/security/p11-kit