aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls-devel
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2009-01-09 07:21:29 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2009-01-09 07:21:29 +0000
commit846abd338363c88c4bd1c7f5fa76f9ab2464a412 (patch)
tree2905444dcf1e14417fb58a4955d437c52957e9cb /security/gnutls-devel
parent1f34119679c2ce7031ccc1498d212965a90e2bd8 (diff)
downloadports-846abd338363c88c4bd1c7f5fa76f9ab2464a412.tar.gz
ports-846abd338363c88c4bd1c7f5fa76f9ab2464a412.zip
Notes
Diffstat (limited to 'security/gnutls-devel')
-rw-r--r--security/gnutls-devel/Makefile84
-rw-r--r--security/gnutls-devel/Makefile.man550
-rw-r--r--security/gnutls-devel/distinfo3
-rw-r--r--security/gnutls-devel/pkg-descr17
-rw-r--r--security/gnutls-devel/pkg-plist78
5 files changed, 732 insertions, 0 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
new file mode 100644
index 000000000000..e69f8d4f11ae
--- /dev/null
+++ b/security/gnutls-devel/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: gnutls-devel
+# Date created: 8 Jan 2009
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnutls
+PORTVERSION= 2.7.4
+CATEGORIES= security net
+MASTER_SITES= http://alpha.gnu.org/gnu/gnutls/
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= GNU Transport Layer Security library
+
+LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt \
+ gpg-error.0:${PORTSDIR}/security/libgpg-error
+
+CONFLICTS= gnutls-[0-9]*
+
+USE_BZIP2= yes
+USE_ICONV= yes
+USE_GNOME= pkgconfig ltverhack
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -fPIC" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --disable-guile
+MANCOMPRESSED= no
+
+.include <bsd.port.pre.mk>
+
+.if (defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)) && !defined(WITHOUT_LIBTASN1)
+LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
+.else
+CONFIGURE_ARGS+= --with-included-libtasn1
+.endif
+
+.if (defined(WITH_LZO) || exists(${LOCALBASE}/lib/liblzo2.so)) && !defined(WITHOUT_LZO)
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+CONFIGURE_ARGS+= --with-lzo
+.else
+CONFIGURE_ARGS+= --with-lzo=no
+.endif
+
+.if defined(WITHOUT_CXX)
+CONFIGURE_ARGS+= --disable-cxx
+PLIST_SUB+= CXX="@comment "
+.else
+PLIST_SUB+= CXX=""
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS NEWS README THANKS
+.endif
+EXAMPLES= doc/examples/*.c
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/libextra/Makefile.in
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include "Makefile.man"
+.include <bsd.port.post.mk>
diff --git a/security/gnutls-devel/Makefile.man b/security/gnutls-devel/Makefile.man
new file mode 100644
index 000000000000..b1383e06bf77
--- /dev/null
+++ b/security/gnutls-devel/Makefile.man
@@ -0,0 +1,550 @@
+# vi:ft=make
+# $FreeBSD$
+
+INFO= gnutls
+
+MAN1= \
+ certtool.1 \
+ gnutls-cli.1 \
+ gnutls-cli-debug.1 \
+ gnutls-serv.1 \
+ psktool.1 \
+ srptool.1
+
+MAN3= \
+ gnutls_alert_get_name.3 \
+ gnutls_alert_send.3 \
+ gnutls_alert_send_appropriate.3 \
+ gnutls_anon_allocate_client_credentials.3 \
+ gnutls_anon_allocate_server_credentials.3 \
+ gnutls_anon_free_client_credentials.3 \
+ gnutls_anon_free_server_credentials.3 \
+ gnutls_anon_set_params_function.3 \
+ gnutls_anon_set_server_dh_params.3 \
+ gnutls_anon_set_server_params_function.3 \
+ gnutls_auth_client_get_type.3 \
+ gnutls_auth_get_type.3 \
+ gnutls_auth_server_get_type.3 \
+ gnutls_bye.3 \
+ gnutls_certificate_activation_time_peers.3 \
+ gnutls_certificate_allocate_credentials.3 \
+ gnutls_certificate_client_get_request_status.3 \
+ gnutls_certificate_client_set_retrieve_function.3 \
+ gnutls_certificate_expiration_time_peers.3 \
+ gnutls_certificate_free_ca_names.3 \
+ gnutls_certificate_free_cas.3 \
+ gnutls_certificate_free_credentials.3 \
+ gnutls_certificate_free_crls.3 \
+ gnutls_certificate_free_keys.3 \
+ gnutls_certificate_get_openpgp_keyring.3 \
+ gnutls_certificate_set_openpgp_key_mem2.3 \
+ gnutls_certificate_set_openpgp_key_file2.3 \
+ gnutls_certificate_get_ours.3 \
+ gnutls_certificate_get_x509_cas.3 \
+ gnutls_certificate_get_x509_crls.3 \
+ gnutls_certificate_send_x509_rdn_sequence.3 \
+ gnutls_certificate_server_set_request.3 \
+ gnutls_certificate_server_set_retrieve_function.3 \
+ gnutls_certificate_set_dh_params.3 \
+ gnutls_certificate_set_openpgp_key.3 \
+ gnutls_certificate_set_openpgp_key_file.3 \
+ gnutls_certificate_set_openpgp_key_mem.3 \
+ gnutls_certificate_set_openpgp_keyring_file.3 \
+ gnutls_certificate_set_openpgp_keyring_mem.3 \
+ gnutls_certificate_set_params_function.3 \
+ gnutls_certificate_set_rsa_export_params.3 \
+ gnutls_certificate_set_verify_flags.3 \
+ gnutls_certificate_set_verify_limits.3 \
+ gnutls_certificate_set_x509_crl.3 \
+ gnutls_certificate_set_x509_crl_file.3 \
+ gnutls_certificate_set_x509_crl_mem.3 \
+ gnutls_certificate_set_x509_key.3 \
+ gnutls_certificate_set_x509_key_file.3 \
+ gnutls_certificate_set_x509_key_mem.3 \
+ gnutls_certificate_set_x509_simple_pkcs12_file.3 \
+ gnutls_certificate_set_x509_simple_pkcs12_mem.3 \
+ gnutls_certificate_set_x509_trust.3 \
+ gnutls_certificate_set_x509_trust_file.3 \
+ gnutls_certificate_set_x509_trust_mem.3 \
+ gnutls_certificate_type_get.3 \
+ gnutls_certificate_type_get_id.3 \
+ gnutls_certificate_type_get_name.3 \
+ gnutls_certificate_type_list.3 \
+ gnutls_certificate_type_set_priority.3 \
+ gnutls_certificate_verify_peers.3 \
+ gnutls_certificate_verify_peers2.3 \
+ gnutls_check_version.3 \
+ gnutls_cipher_get.3 \
+ gnutls_cipher_get_id.3 \
+ gnutls_cipher_get_key_size.3 \
+ gnutls_cipher_get_name.3 \
+ gnutls_cipher_list.3 \
+ gnutls_cipher_set_priority.3 \
+ gnutls_cipher_suite_get_name.3 \
+ gnutls_cipher_suite_info.3 \
+ gnutls_compression_get.3 \
+ gnutls_compression_get_id.3 \
+ gnutls_compression_get_name.3 \
+ gnutls_compression_list.3 \
+ gnutls_compression_set_priority.3 \
+ gnutls_credentials_clear.3 \
+ gnutls_credentials_set.3 \
+ gnutls_crypto_bigint_register2.3 \
+ gnutls_crypto_cipher_register2.3 \
+ gnutls_crypto_digest_register2.3 \
+ gnutls_crypto_mac_register2.3 \
+ gnutls_crypto_pk_register2.3 \
+ gnutls_crypto_rnd_register2.3 \
+ gnutls_crypto_single_cipher_register2.3 \
+ gnutls_crypto_single_digest_register2.3 \
+ gnutls_crypto_single_mac_register2.3 \
+ gnutls_db_check_entry.3 \
+ gnutls_db_get_ptr.3 \
+ gnutls_db_remove_session.3 \
+ gnutls_db_set_cache_expiration.3 \
+ gnutls_db_set_ptr.3 \
+ gnutls_db_set_remove_function.3 \
+ gnutls_db_set_retrieve_function.3 \
+ gnutls_db_set_store_function.3 \
+ gnutls_deinit.3 \
+ gnutls_dh_get_group.3 \
+ gnutls_dh_get_peers_public_bits.3 \
+ gnutls_dh_get_prime_bits.3 \
+ gnutls_dh_get_pubkey.3 \
+ gnutls_dh_get_secret_bits.3 \
+ gnutls_dh_params_cpy.3 \
+ gnutls_dh_params_deinit.3 \
+ gnutls_dh_params_export_pkcs3.3 \
+ gnutls_dh_params_export_raw.3 \
+ gnutls_dh_params_generate2.3 \
+ gnutls_dh_params_import_pkcs3.3 \
+ gnutls_dh_params_import_raw.3 \
+ gnutls_dh_params_init.3 \
+ gnutls_dh_set_prime_bits.3 \
+ gnutls_error_is_fatal.3 \
+ gnutls_error_to_alert.3 \
+ gnutls_ext_register.3 \
+ gnutls_extra_check_version.3 \
+ gnutls_fingerprint.3 \
+ gnutls_free.3 \
+ gnutls_global_deinit.3 \
+ gnutls_global_init.3 \
+ gnutls_global_init_extra.3 \
+ gnutls_global_set_log_function.3 \
+ gnutls_global_set_log_level.3 \
+ gnutls_global_set_mem_functions.3 \
+ gnutls_handshake.3 \
+ gnutls_handshake_get_last_in.3 \
+ gnutls_handshake_get_last_out.3 \
+ gnutls_handshake_set_max_packet_length.3 \
+ gnutls_handshake_set_post_client_hello_function.3 \
+ gnutls_handshake_set_private_extensions.3 \
+ gnutls_hex2bin.3 \
+ gnutls_hex_decode.3 \
+ gnutls_hex_encode.3 \
+ gnutls_ia_allocate_client_credentials.3 \
+ gnutls_ia_allocate_server_credentials.3 \
+ gnutls_ia_enable.3 \
+ gnutls_ia_endphase_send.3 \
+ gnutls_ia_extract_inner_secret.3 \
+ gnutls_ia_free_client_credentials.3 \
+ gnutls_ia_free_server_credentials.3 \
+ gnutls_ia_generate_challenge.3 \
+ gnutls_ia_get_client_avp_ptr.3 \
+ gnutls_ia_get_server_avp_ptr.3 \
+ gnutls_ia_handshake.3 \
+ gnutls_ia_handshake_p.3 \
+ gnutls_ia_permute_inner_secret.3 \
+ gnutls_ia_recv.3 \
+ gnutls_ia_send.3 \
+ gnutls_ia_set_client_avp_function.3 \
+ gnutls_ia_set_client_avp_ptr.3 \
+ gnutls_ia_set_server_avp_function.3 \
+ gnutls_ia_set_server_avp_ptr.3 \
+ gnutls_ia_verify_endphase.3 \
+ gnutls_init.3 \
+ gnutls_kx_get.3 \
+ gnutls_kx_get_id.3 \
+ gnutls_kx_get_name.3 \
+ gnutls_kx_list.3 \
+ gnutls_kx_set_priority.3 \
+ gnutls_mac_get.3 \
+ gnutls_mac_get_id.3 \
+ gnutls_mac_get_key_size.3 \
+ gnutls_mac_get_name.3 \
+ gnutls_mac_list.3 \
+ gnutls_mac_set_priority.3 \
+ gnutls_malloc.3 \
+ gnutls_openpgp_crt_init.3 \
+ gnutls_openpgp_crt_deinit.3 \
+ gnutls_openpgp_crt_import.3 \
+ gnutls_openpgp_crt_export.3 \
+ gnutls_openpgp_crt_get_fingerprint.3 \
+ gnutls_openpgp_crt_get_name.3 \
+ gnutls_openpgp_crt_get_pk_algorithm.3 \
+ gnutls_openpgp_crt_get_version.3 \
+ gnutls_openpgp_crt_get_creation_time.3 \
+ gnutls_openpgp_crt_get_expiration_time.3 \
+ gnutls_openpgp_crt_check_hostname.3 \
+ gnutls_openpgp_crt_get_key_usage.3 \
+ gnutls_openpgp_crt_verify_ring.3 \
+ gnutls_openpgp_crt_verify_self.3 \
+ gnutls_openpgp_crt_get_key_id.3 \
+ gnutls_openpgp_crt_get_revoked_status.3 \
+ gnutls_openpgp_crt_get_subkey_count.3 \
+ gnutls_openpgp_crt_get_subkey_fingerprint.3 \
+ gnutls_openpgp_crt_get_subkey_revoked_status.3 \
+ gnutls_openpgp_crt_get_subkey_pk_algorithm.3 \
+ gnutls_openpgp_crt_get_subkey_creation_time.3 \
+ gnutls_openpgp_crt_get_subkey_expiration_time.3 \
+ gnutls_openpgp_crt_get_subkey_id.3 \
+ gnutls_openpgp_crt_get_subkey_idx.3 \
+ gnutls_openpgp_crt_get_subkey_usage.3 \
+ gnutls_openpgp_crt_get_pk_rsa_raw.3 \
+ gnutls_openpgp_crt_get_pk_dsa_raw.3 \
+ gnutls_openpgp_crt_get_subkey_pk_rsa_raw.3 \
+ gnutls_openpgp_crt_get_subkey_pk_dsa_raw.3 \
+ gnutls_openpgp_crt_get_preferred_key_id.3 \
+ gnutls_openpgp_crt_set_preferred_key_id.3 \
+ gnutls_openpgp_crt_get_auth_subkey.3 \
+ gnutls_openpgp_keyring_init.3 \
+ gnutls_openpgp_keyring_deinit.3 \
+ gnutls_openpgp_keyring_check_id.3 \
+ gnutls_openpgp_keyring_import.3 \
+ gnutls_openpgp_keyring_get_crt_count.3 \
+ gnutls_openpgp_keyring_get_crt.3 \
+ gnutls_openpgp_crt_print.3 \
+ gnutls_openpgp_privkey_init.3 \
+ gnutls_openpgp_privkey_deinit.3 \
+ gnutls_openpgp_privkey_import.3 \
+ gnutls_openpgp_privkey_get_pk_algorithm.3 \
+ gnutls_openpgp_privkey_sign_hash.3 \
+ gnutls_openpgp_privkey_export.3 \
+ gnutls_openpgp_privkey_get_revoked_status.3 \
+ gnutls_openpgp_privkey_get_fingerprint.3 \
+ gnutls_openpgp_privkey_get_key_id.3 \
+ gnutls_openpgp_privkey_get_subkey_count.3 \
+ gnutls_openpgp_privkey_get_subkey_fingerprint.3 \
+ gnutls_openpgp_privkey_get_subkey_idx.3 \
+ gnutls_openpgp_privkey_get_subkey_revoked_status.3 \
+ gnutls_openpgp_privkey_get_subkey_pk_algorithm.3 \
+ gnutls_openpgp_privkey_get_subkey_creation_time.3 \
+ gnutls_openpgp_privkey_get_subkey_expiration_time.3 \
+ gnutls_openpgp_privkey_get_subkey_id.3 \
+ gnutls_openpgp_privkey_export_rsa_raw.3 \
+ gnutls_openpgp_privkey_export_dsa_raw.3 \
+ gnutls_openpgp_privkey_export_subkey_rsa_raw.3 \
+ gnutls_openpgp_privkey_export_subkey_dsa_raw.3 \
+ gnutls_openpgp_privkey_get_preferred_key_id.3 \
+ gnutls_openpgp_privkey_set_preferred_key_id.3 \
+ gnutls_openpgp_send_cert.3 \
+ gnutls_openpgp_set_recv_key_function.3 \
+ gnutls_oprfi_enable_client.3 \
+ gnutls_oprfi_enable_server.3 \
+ gnutls_pem_base64_decode.3 \
+ gnutls_pem_base64_decode_alloc.3 \
+ gnutls_pem_base64_encode.3 \
+ gnutls_pem_base64_encode_alloc.3 \
+ gnutls_perror.3 \
+ gnutls_pk_algorithm_get_name.3 \
+ gnutls_pk_get_id.3 \
+ gnutls_pk_get_name.3 \
+ gnutls_pk_list.3 \
+ gnutls_pkcs12_bag_decrypt.3 \
+ gnutls_pkcs12_bag_deinit.3 \
+ gnutls_pkcs12_bag_encrypt.3 \
+ gnutls_pkcs12_bag_get_count.3 \
+ gnutls_pkcs12_bag_get_data.3 \
+ gnutls_pkcs12_bag_get_friendly_name.3 \
+ gnutls_pkcs12_bag_get_key_id.3 \
+ gnutls_pkcs12_bag_get_type.3 \
+ gnutls_pkcs12_bag_init.3 \
+ gnutls_pkcs12_bag_set_crl.3 \
+ gnutls_pkcs12_bag_set_crt.3 \
+ gnutls_pkcs12_bag_set_data.3 \
+ gnutls_pkcs12_bag_set_friendly_name.3 \
+ gnutls_pkcs12_bag_set_key_id.3 \
+ gnutls_pkcs12_deinit.3 \
+ gnutls_pkcs12_export.3 \
+ gnutls_pkcs12_generate_mac.3 \
+ gnutls_pkcs12_get_bag.3 \
+ gnutls_pkcs12_import.3 \
+ gnutls_pkcs12_init.3 \
+ gnutls_pkcs12_set_bag.3 \
+ gnutls_pkcs12_verify_mac.3 \
+ gnutls_pkcs7_deinit.3 \
+ gnutls_pkcs7_delete_crl.3 \
+ gnutls_pkcs7_delete_crt.3 \
+ gnutls_pkcs7_export.3 \
+ gnutls_pkcs7_get_crl_count.3 \
+ gnutls_pkcs7_get_crl_raw.3 \
+ gnutls_pkcs7_get_crt_count.3 \
+ gnutls_pkcs7_get_crt_raw.3 \
+ gnutls_pkcs7_import.3 \
+ gnutls_pkcs7_init.3 \
+ gnutls_pkcs7_set_crl.3 \
+ gnutls_pkcs7_set_crl_raw.3 \
+ gnutls_pkcs7_set_crt.3 \
+ gnutls_pkcs7_set_crt_raw.3 \
+ gnutls_prf.3 \
+ gnutls_prf_raw.3 \
+ gnutls_priority_deinit.3 \
+ gnutls_priority_init.3 \
+ gnutls_priority_set.3 \
+ gnutls_priority_set_direct.3 \
+ gnutls_protocol_get_id.3 \
+ gnutls_protocol_get_name.3 \
+ gnutls_protocol_get_version.3 \
+ gnutls_protocol_list.3 \
+ gnutls_protocol_set_priority.3 \
+ gnutls_psk_allocate_client_credentials.3 \
+ gnutls_psk_allocate_server_credentials.3 \
+ gnutls_psk_client_get_hint.3 \
+ gnutls_psk_free_client_credentials.3 \
+ gnutls_psk_free_server_credentials.3 \
+ gnutls_psk_netconf_derive_key.3 \
+ gnutls_psk_server_get_username.3 \
+ gnutls_psk_set_client_credentials.3 \
+ gnutls_psk_set_client_credentials_function.3 \
+ gnutls_psk_set_params_function.3 \
+ gnutls_psk_set_server_credentials_file.3 \
+ gnutls_psk_set_server_credentials_function.3 \
+ gnutls_psk_set_server_credentials_hint.3 \
+ gnutls_psk_set_server_dh_params.3 \
+ gnutls_psk_set_server_params_function.3 \
+ gnutls_record_check_pending.3 \
+ gnutls_record_disable_padding.3 \
+ gnutls_record_get_direction.3 \
+ gnutls_record_get_max_size.3 \
+ gnutls_record_recv.3 \
+ gnutls_record_send.3 \
+ gnutls_record_set_max_size.3 \
+ gnutls_register_md5_handler.3 \
+ gnutls_rehandshake.3 \
+ gnutls_rsa_export_get_modulus_bits.3 \
+ gnutls_rsa_export_get_pubkey.3 \
+ gnutls_rsa_params_cpy.3 \
+ gnutls_rsa_params_deinit.3 \
+ gnutls_rsa_params_export_pkcs1.3 \
+ gnutls_rsa_params_export_raw.3 \
+ gnutls_rsa_params_generate2.3 \
+ gnutls_rsa_params_import_pkcs1.3 \
+ gnutls_rsa_params_import_raw.3 \
+ gnutls_rsa_params_init.3 \
+ gnutls_server_name_get.3 \
+ gnutls_server_name_set.3 \
+ gnutls_session_enable_compatibility_mode.3 \
+ gnutls_session_get_client_random.3 \
+ gnutls_session_get_data.3 \
+ gnutls_session_get_data2.3 \
+ gnutls_session_get_id.3 \
+ gnutls_session_get_master_secret.3 \
+ gnutls_session_get_ptr.3 \
+ gnutls_session_get_server_random.3 \
+ gnutls_session_is_resumed.3 \
+ gnutls_session_set_data.3 \
+ gnutls_session_set_finished_function.3 \
+ gnutls_session_set_ptr.3 \
+ gnutls_set_default_export_priority.3 \
+ gnutls_set_default_priority.3 \
+ gnutls_sign_algorithm_get_name.3 \
+ gnutls_sign_callback_set.3 \
+ gnutls_sign_callback_get.3 \
+ gnutls_sign_get_id.3 \
+ gnutls_sign_get_name.3 \
+ gnutls_sign_list.3 \
+ gnutls_srp_allocate_client_credentials.3 \
+ gnutls_srp_allocate_server_credentials.3 \
+ gnutls_srp_base64_decode.3 \
+ gnutls_srp_base64_decode_alloc.3 \
+ gnutls_srp_base64_encode.3 \
+ gnutls_srp_base64_encode_alloc.3 \
+ gnutls_srp_free_client_credentials.3 \
+ gnutls_srp_free_server_credentials.3 \
+ gnutls_srp_server_get_username.3 \
+ gnutls_srp_set_client_credentials.3 \
+ gnutls_srp_set_client_credentials_function.3 \
+ gnutls_srp_set_prime_bits.3 \
+ gnutls_srp_set_server_credentials_file.3 \
+ gnutls_srp_set_server_credentials_function.3 \
+ gnutls_srp_verifier.3 \
+ gnutls_strerror.3 \
+ gnutls_strerror_name.3 \
+ gnutls_transport_get_ptr.3 \
+ gnutls_transport_get_ptr2.3 \
+ gnutls_transport_set_errno.3 \
+ gnutls_transport_set_global_errno.3 \
+ gnutls_transport_set_lowat.3 \
+ gnutls_transport_set_ptr.3 \
+ gnutls_transport_set_ptr2.3 \
+ gnutls_transport_set_pull_function.3 \
+ gnutls_transport_set_push_function.3 \
+ gnutls_x509_dn_deinit.3 \
+ gnutls_x509_dn_export.3 \
+ gnutls_x509_dn_init.3 \
+ gnutls_x509_dn_import.3 \
+ gnutls_x509_crl_check_issuer.3 \
+ gnutls_x509_crl_deinit.3 \
+ gnutls_x509_crl_export.3 \
+ gnutls_x509_crl_get_authority_key_id.3 \
+ gnutls_x509_crl_get_crt_count.3 \
+ gnutls_x509_crl_get_crt_serial.3 \
+ gnutls_x509_crl_get_dn_oid.3 \
+ gnutls_x509_crl_get_extension_oid.3 \
+ gnutls_x509_crl_get_extension_info.3 \
+ gnutls_x509_crl_get_extension_data.3 \
+ gnutls_x509_crt_get_extension_info.3 \
+ gnutls_x509_crt_get_extension_data.3 \
+ gnutls_x509_crl_get_issuer_dn.3 \
+ gnutls_x509_crl_get_issuer_dn_by_oid.3 \
+ gnutls_x509_crl_get_next_update.3 \
+ gnutls_x509_crl_get_number.3 \
+ gnutls_x509_crt_get_raw_issuer_dn.3 \
+ gnutls_x509_crt_get_raw_dn.3 \
+ gnutls_x509_crt_get_signature.3 \
+ gnutls_x509_crl_get_signature_algorithm.3 \
+ gnutls_x509_crt_get_subject_alt_othername_oid.3 \
+ gnutls_x509_crl_get_this_update.3 \
+ gnutls_x509_crl_get_version.3 \
+ gnutls_x509_crl_import.3 \
+ gnutls_x509_crl_init.3 \
+ gnutls_x509_crl_print.3 \
+ gnutls_x509_crt_print.3 \
+ gnutls_x509_crl_set_authority_key_id.3 \
+ gnutls_x509_crl_set_crt.3 \
+ gnutls_x509_crl_set_crt_serial.3 \
+ gnutls_x509_crl_set_next_update.3 \
+ gnutls_x509_crl_set_number.3 \
+ gnutls_x509_crl_set_this_update.3 \
+ gnutls_x509_crl_set_version.3 \
+ gnutls_x509_crl_sign.3 \
+ gnutls_x509_crl_sign2.3 \
+ gnutls_x509_crl_verify.3 \
+ gnutls_x509_crq_deinit.3 \
+ gnutls_x509_crq_export.3 \
+ gnutls_x509_crq_get_attribute_by_oid.3 \
+ gnutls_x509_crq_get_attribute_info.3 \
+ gnutls_x509_crq_get_attribute_data.3 \
+ gnutls_x509_crq_get_basic_constraints.3 \
+ gnutls_x509_crq_get_challenge_password.3 \
+ gnutls_x509_crq_get_dn.3 \
+ gnutls_x509_crq_get_dn_by_oid.3 \
+ gnutls_x509_crq_get_dn_oid.3 \
+ gnutls_x509_crq_get_extension_by_oid.3 \
+ gnutls_x509_crq_get_extension_info.3 \
+ gnutls_x509_crq_get_extension_data.3 \
+ gnutls_x509_crq_get_key_id.3 \
+ gnutls_x509_crq_get_key_purpose_oid.3 \
+ gnutls_x509_crq_get_key_rsa_raw.3 \
+ gnutls_x509_crq_get_key_usage.3 \
+ gnutls_x509_crq_get_pk_algorithm.3 \
+ gnutls_x509_crq_get_subject_alt_name.3 \
+ gnutls_x509_crq_get_subject_alt_othername_oid.3 \
+ gnutls_x509_crq_get_version.3 \
+ gnutls_x509_crq_import.3 \
+ gnutls_x509_crq_init.3 \
+ gnutls_x509_crq_print.3 \
+ gnutls_x509_crq_set_attribute_by_oid.3 \
+ gnutls_x509_crq_set_basic_constraints.3 \
+ gnutls_x509_crq_set_challenge_password.3 \
+ gnutls_x509_crq_set_dn_by_oid.3 \
+ gnutls_x509_crq_set_key.3 \
+ gnutls_x509_crq_set_key_purpose_oid.3 \
+ gnutls_x509_crq_set_key_rsa_raw.3 \
+ gnutls_x509_crq_set_key_usage.3 \
+ gnutls_x509_crq_set_subject_alt_name.3 \
+ gnutls_x509_crq_set_version.3 \
+ gnutls_x509_crq_sign.3 \
+ gnutls_x509_crq_sign2.3 \
+ gnutls_x509_crt_check_hostname.3 \
+ gnutls_x509_crt_check_issuer.3 \
+ gnutls_x509_crt_cpy_crl_dist_points.3 \
+ gnutls_x509_crt_deinit.3 \
+ gnutls_x509_crt_export.3 \
+ gnutls_x509_crt_get_activation_time.3 \
+ gnutls_x509_crt_get_authority_key_id.3 \
+ gnutls_x509_crt_get_basic_constraints.3 \
+ gnutls_x509_crt_get_crl_dist_points.3 \
+ gnutls_x509_crt_get_dn.3 \
+ gnutls_x509_crt_get_dn_by_oid.3 \
+ gnutls_x509_crt_get_dn_oid.3 \
+ gnutls_x509_crt_get_expiration_time.3 \
+ gnutls_x509_crt_get_extension_oid.3 \
+ gnutls_x509_crt_get_fingerprint.3 \
+ gnutls_x509_crt_get_issuer_dn.3 \
+ gnutls_x509_crt_get_issuer_dn_by_oid.3 \
+ gnutls_x509_crt_get_issuer_dn_oid.3 \
+ gnutls_x509_crt_get_key_id.3 \
+ gnutls_x509_crt_get_key_purpose_oid.3 \
+ gnutls_x509_crt_get_key_usage.3 \
+ gnutls_x509_crt_get_pk_algorithm.3 \
+ gnutls_x509_crt_get_pk_dsa_raw.3 \
+ gnutls_x509_crt_get_pk_rsa_raw.3 \
+ gnutls_x509_crt_get_proxy.3 \
+ gnutls_x509_crt_get_serial.3 \
+ gnutls_x509_crl_get_signature.3 \
+ gnutls_x509_crt_get_signature_algorithm.3 \
+ gnutls_x509_crt_get_subject_alt_name.3 \
+ gnutls_x509_crt_get_subject_alt_name2.3 \
+ gnutls_x509_crt_get_subject_key_id.3 \
+ gnutls_x509_crt_get_version.3 \
+ gnutls_x509_crt_import.3 \
+ gnutls_x509_crt_list_import.3 \
+ gnutls_x509_crt_list_verify.3 \
+ gnutls_x509_crt_set_activation_time.3 \
+ gnutls_x509_crt_set_authority_key_id.3 \
+ gnutls_x509_crt_set_basic_constraints.3 \
+ gnutls_x509_crt_set_ca_status.3 \
+ gnutls_x509_crt_set_crl_dist_points.3 \
+ gnutls_x509_crt_set_crl_dist_points2.3 \
+ gnutls_x509_crt_set_crq_extensions.3 \
+ gnutls_x509_crt_set_dn_by_oid.3 \
+ gnutls_x509_crt_set_expiration_time.3 \
+ gnutls_x509_crt_set_extension_by_oid.3 \
+ gnutls_x509_crt_set_issuer_dn_by_oid.3 \
+ gnutls_x509_crt_set_key.3 \
+ gnutls_x509_crt_set_key_purpose_oid.3 \
+ gnutls_x509_crt_set_key_usage.3 \
+ gnutls_x509_crt_set_proxy.3 \
+ gnutls_x509_crt_set_proxy_dn.3 \
+ gnutls_x509_crt_set_serial.3 \
+ gnutls_x509_crt_set_subject_alt_name.3 \
+ gnutls_x509_crt_set_subject_alternative_name.3 \
+ gnutls_x509_crt_set_subject_key_id.3 \
+ gnutls_x509_crt_sign2.3 \
+ gnutls_x509_crt_verify.3 \
+ gnutls_x509_dn_oid_known.3 \
+ gnutls_x509_privkey_cpy.3 \
+ gnutls_x509_privkey_deinit.3 \
+ gnutls_x509_privkey_export.3 \
+ gnutls_x509_privkey_export_dsa_raw.3 \
+ gnutls_x509_privkey_export_pkcs8.3 \
+ gnutls_x509_privkey_export_rsa_raw.3 \
+ gnutls_x509_privkey_fix.3 \
+ gnutls_x509_privkey_generate.3 \
+ gnutls_x509_privkey_get_key_id.3 \
+ gnutls_x509_privkey_get_pk_algorithm.3 \
+ gnutls_x509_privkey_import.3 \
+ gnutls_x509_privkey_import_dsa_raw.3 \
+ gnutls_x509_privkey_import_pkcs8.3 \
+ gnutls_x509_privkey_import_rsa_raw.3 \
+ gnutls_x509_privkey_init.3 \
+ gnutls_x509_privkey_sign_data.3 \
+ gnutls_x509_privkey_sign_hash.3 \
+ gnutls_x509_privkey_verify_data.3 \
+ gnutls_x509_rdn_get.3 \
+ gnutls_x509_rdn_get_by_oid.3 \
+ gnutls_x509_rdn_get_oid.3 \
+ gnutls_alert_get.3 \
+ gnutls_certificate_get_peers.3 \
+ gnutls_x509_crt_check_revocation.3 \
+ gnutls_x509_crt_get_ca_status.3 \
+ gnutls_x509_crt_get_extension_by_oid.3 \
+ gnutls_x509_crt_get_subject.3 \
+ gnutls_x509_crt_get_issuer.3 \
+ gnutls_x509_crt_init.3 \
+ gnutls_x509_crt_set_crq.3 \
+ gnutls_x509_crt_set_version.3 \
+ gnutls_x509_crt_sign.3 \
+ gnutls_x509_crt_verify_data.3 \
+ gnutls_x509_dn_get_rdn_ava.3
diff --git a/security/gnutls-devel/distinfo b/security/gnutls-devel/distinfo
new file mode 100644
index 000000000000..538ea3645ab0
--- /dev/null
+++ b/security/gnutls-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnutls-2.7.4.tar.bz2) = f50dd0a58bece90d0600a201e934087d
+SHA256 (gnutls-2.7.4.tar.bz2) = 9d6490a999a45ae0c431215f3df1f649b93d771bc0e55a57c3072ae755481b64
+SIZE (gnutls-2.7.4.tar.bz2) = 6033353
diff --git a/security/gnutls-devel/pkg-descr b/security/gnutls-devel/pkg-descr
new file mode 100644
index 000000000000..eb3b18b04920
--- /dev/null
+++ b/security/gnutls-devel/pkg-descr
@@ -0,0 +1,17 @@
+GnuTLS is a portable ANSI C based library which implements the TLS 1.0 and
+SSL 3.0 protocols. The library does not include any patented algorithms and
+is available under the GNU Lesser GPL license.
+
+Important features of the GnuTLS library include:
+- Thread safety
+- Support for both TLS 1.0 and SSL 3.0 protocols
+- Support for both X.509 and OpenPGP certificates
+- Support for basic parsing and verification of certificates
+- Support for SRP for TLS authentication
+- Support for TLS Extension mechanism
+- Support for TLS Compression Methods
+
+Additionaly GnuTLS provides an emulation API for the widely used
+OpenSSL library, to ease integration with existing applications.
+
+WWW: http://www.gnutls.org/
diff --git a/security/gnutls-devel/pkg-plist b/security/gnutls-devel/pkg-plist
new file mode 100644
index 000000000000..bd84c0251820
--- /dev/null
+++ b/security/gnutls-devel/pkg-plist
@@ -0,0 +1,78 @@
+@comment $FreeBSD$
+bin/certtool
+bin/gnutls-cli
+bin/gnutls-cli-debug
+bin/gnutls-serv
+bin/psktool
+bin/srptool
+info/gnutls-certificate-user-use-case.png
+info/gnutls-extensions_st.png
+info/gnutls-handshake-state.png
+info/gnutls-layers.png
+info/gnutls-mod_auth_st.png
+info/gnutls-pgp.png
+info/gnutls-client-server-use-case.png
+info/gnutls-handshake-sequence.png
+info/gnutls-internals.png
+info/gnutls-logo.png
+info/gnutls-objects.png
+info/gnutls-x509.png
+include/gnutls/compat.h
+include/gnutls/crypto.h
+include/gnutls/extra.h
+include/gnutls/gnutls.h
+include/gnutls/openpgp.h
+include/gnutls/openssl.h
+include/gnutls/pkcs12.h
+include/gnutls/x509.h
+%%CXX%%include/gnutls/gnutlsxx.h
+%%CXX%%lib/libgnutlsxx.so.39
+%%CXX%%lib/libgnutlsxx.so
+%%CXX%%lib/libgnutlsxx.la
+%%CXX%%lib/libgnutlsxx.a
+lib/libgnutls-extra.a
+lib/libgnutls-extra.la
+lib/libgnutls-extra.so
+lib/libgnutls-extra.so.39
+lib/libgnutls-openssl.a
+lib/libgnutls-openssl.la
+lib/libgnutls-openssl.so
+lib/libgnutls-openssl.so.39
+lib/libgnutls.a
+lib/libgnutls.la
+lib/libgnutls.so
+lib/libgnutls.so.39
+libdata/pkgconfig/gnutls-extra.pc
+libdata/pkgconfig/gnutls.pc
+%%EXAMPLESDIR%%/ex-alert.c
+%%EXAMPLESDIR%%/ex-cert-select.c
+%%EXAMPLESDIR%%/ex-client-psk.c
+%%EXAMPLESDIR%%/ex-client-resume.c
+%%EXAMPLESDIR%%/ex-client-srp.c
+%%EXAMPLESDIR%%/ex-client-tlsia.c
+%%EXAMPLESDIR%%/ex-client1.c
+%%EXAMPLESDIR%%/ex-client2.c
+%%EXAMPLESDIR%%/ex-crq.c
+%%EXAMPLESDIR%%/ex-pkcs12.c
+%%EXAMPLESDIR%%/ex-rfc2818.c
+%%EXAMPLESDIR%%/ex-serv-anon.c
+%%EXAMPLESDIR%%/ex-serv-export.c
+%%EXAMPLESDIR%%/ex-serv-pgp.c
+%%EXAMPLESDIR%%/ex-serv-psk.c
+%%EXAMPLESDIR%%/ex-serv-srp.c
+%%EXAMPLESDIR%%/ex-serv1.c
+%%EXAMPLESDIR%%/ex-session-info.c
+%%EXAMPLESDIR%%/ex-verify.c
+%%EXAMPLESDIR%%/ex-x509-info.c
+%%EXAMPLESDIR%%/tcp.c
+%%NLS%%share/locale/de/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/libgnutls.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/libgnutls.mo
+@dirrm %%EXAMPLESDIR%%
+@dirrm include/gnutls