aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls-devel
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-12-22 18:38:02 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-12-22 18:38:02 +0000
commit2cfe65ba241d37348ed58f0dde738e6e26ff3ee7 (patch)
tree0b718a0c45546bb206f1d559d46c8c045cc8ccea /security/gnutls-devel
parentd4f77ce3e4a6af817a85086d849b56515ee1140a (diff)
downloadports-2cfe65ba241d37348ed58f0dde738e6e26ff3ee7.tar.gz
ports-2cfe65ba241d37348ed58f0dde738e6e26ff3ee7.zip
Notes
Diffstat (limited to 'security/gnutls-devel')
-rw-r--r--security/gnutls-devel/Makefile16
-rw-r--r--security/gnutls-devel/Makefile.man34
-rw-r--r--security/gnutls-devel/distinfo6
-rw-r--r--security/gnutls-devel/pkg-plist7
4 files changed, 46 insertions, 17 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index a8892ca0e6fc..d9ca061fdc4d 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= gnutls-devel
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.2
CATEGORIES= security net
-MASTER_SITES= ${MASTER_SITE_GNUPG} \
- http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
- ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/ \
- http://josefsson.org/gnutls/releases/ \
- ftp://ftp.gnutls.org/pub/gnutls/
+MASTER_SITES= http://josefsson.org/gnutls/releases/ \
+ ${MASTER_SITE_GNUPG} \
+ http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/ \
+ ftp://ftp.gnutls.org/pub/gnutls/
MASTER_SITE_SUBDIR= alpha/gnutls
DISTNAME= gnutls-${PORTVERSION}
@@ -42,9 +42,9 @@ USE_AUTOTOOLS= libtool:15:inc
INSTALLS_SHLIB= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ARGS= MAKEINFO="${PREFIX}/bin/makeinfo"
+MAKE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo"
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- MAKEINFO="${PREFIX}/bin/makeinfo"
+ MAKEINFO="${LOCALBASE}/bin/makeinfo"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-included-lzo --disable-static
MANCOMPRESSED= no
diff --git a/security/gnutls-devel/Makefile.man b/security/gnutls-devel/Makefile.man
index 21318eb4222a..9ab66b4a5f63 100644
--- a/security/gnutls-devel/Makefile.man
+++ b/security/gnutls-devel/Makefile.man
@@ -10,7 +10,8 @@ MAN1= certtool.1 \
psktool.1 \
srptool.1
-MAN3= gnutls_hex_decode.3 \
+MAN3= gnutls_anon_set_server_params_function.3 \
+ gnutls_hex_decode.3 \
gnutls_hex_encode.3 \
gnutls_srp_base64_encode.3 \
gnutls_srp_base64_encode_alloc.3 \
@@ -52,7 +53,6 @@ MAN3= gnutls_hex_decode.3 \
gnutls_certificate_server_set_request.3 \
gnutls_certificate_client_set_retrieve_function.3 \
gnutls_certificate_server_set_retrieve_function.3 \
- gnutls_certificate_verify_peers.3 \
gnutls_certificate_verify_peers2.3 \
gnutls_db_set_ptr.3 \
gnutls_certificate_expiration_time_peers.3 \
@@ -121,6 +121,8 @@ MAN3= gnutls_hex_decode.3 \
gnutls_session_get_data2.3 \
gnutls_session_get_id.3 \
gnutls_session_set_data.3 \
+ gnutls_session_get_client_random.3 \
+ gnutls_session_get_server_random.3 \
gnutls_srp_free_client_credentials.3 \
gnutls_srp_set_client_credentials.3 \
gnutls_srp_allocate_client_credentials.3 \
@@ -139,6 +141,7 @@ MAN3= gnutls_hex_decode.3 \
gnutls_deinit.3 \
gnutls_openpgp_send_key.3 \
gnutls_certificate_send_x509_rdn_sequence.3 \
+ gnutls_certificate_set_x509_simple_pkcs12_file.3 \
gnutls_handshake_set_private_extensions.3 \
gnutls_session_is_resumed.3 \
gnutls_session_get_ptr.3 \
@@ -377,4 +380,29 @@ MAN3= gnutls_hex_decode.3 \
gnutls_psk_set_server_credentials_file.3 \
gnutls_psk_set_server_credentials_function.3 \
gnutls_psk_set_client_credentials_function.3 \
- gnutls_psk_server_get_username.3
+ gnutls_psk_server_get_username.3 \
+ gnutls_psk_set_server_dh_params.3 \
+ gnutls_psk_set_server_params_function.3 \
+ gnutls_psk_set_params_function.3 \
+ gnutls_prf_raw.3 \
+ gnutls_prf.3 \
+ gnutls_ia_permute_inner_secret.3 \
+ gnutls_ia_generate_challenge.3 \
+ gnutls_ia_endphase_send.3 \
+ gnutls_ia_extract_inner_secret.3 \
+ gnutls_ia_verify_endphase.3 \
+ gnutls_ia_send.3 \
+ gnutls_ia_recv.3 \
+ gnutls_ia_handshake_p.3 \
+ gnutls_ia_handshake.3 \
+ gnutls_ia_allocate_client_credentials.3 \
+ gnutls_ia_free_client_credentials.3 \
+ gnutls_ia_set_client_avp_function.3 \
+ gnutls_ia_set_client_avp_ptr.3 \
+ gnutls_ia_get_client_avp_ptr.3 \
+ gnutls_ia_allocate_server_credentials.3 \
+ gnutls_ia_free_server_credentials.3 \
+ gnutls_ia_set_server_avp_function.3 \
+ gnutls_ia_set_server_avp_ptr.3 \
+ gnutls_ia_get_server_avp_ptr.3 \
+ gnutls_ia_require_inner_phase.3
diff --git a/security/gnutls-devel/distinfo b/security/gnutls-devel/distinfo
index 43b520b5dac4..e41dadcf73e9 100644
--- a/security/gnutls-devel/distinfo
+++ b/security/gnutls-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnutls-1.3.0.tar.bz2) = e5caf8f1240088a97e53c8e20b117afd
-SHA256 (gnutls-1.3.0.tar.bz2) = daa9f0be19d9b77afecdcba081788e856dc9639524110cdb35a13dd0ee0f37e6
-SIZE (gnutls-1.3.0.tar.bz2) = 3087449
+MD5 (gnutls-1.3.2.tar.bz2) = 6bfdcdb914ed9630a5363da27267b5ea
+SHA256 (gnutls-1.3.2.tar.bz2) = e80a69c8a358fbf8dcc23ed2e8c2f41f667d66eebf167a5d21ac1b549e2fc7b3
+SIZE (gnutls-1.3.2.tar.bz2) = 3173209
diff --git a/security/gnutls-devel/pkg-plist b/security/gnutls-devel/pkg-plist
index 40a419f16124..5e7afe91e8ef 100644
--- a/security/gnutls-devel/pkg-plist
+++ b/security/gnutls-devel/pkg-plist
@@ -16,13 +16,13 @@ include/gnutls/pkcs12.h
include/gnutls/x509.h
lib/libgnutls-extra.la
lib/libgnutls-extra.so
-lib/libgnutls-extra.so.16
+lib/libgnutls-extra.so.13
lib/libgnutls-openssl.la
lib/libgnutls-openssl.so
-lib/libgnutls-openssl.so.16
+lib/libgnutls-openssl.so.13
lib/libgnutls.la
lib/libgnutls.so
-lib/libgnutls.so.16
+lib/libgnutls.so.13
libdata/pkgconfig/gnutls-extra.pc
libdata/pkgconfig/gnutls.pc
@comment info/gnutls.info-1
@@ -33,6 +33,7 @@ share/aclocal/libgnutls.m4
%%EXAMPLESDIR%%/ex-cert-select.c
%%EXAMPLESDIR%%/ex-client-resume.c
%%EXAMPLESDIR%%/ex-client-srp.c
+%%EXAMPLESDIR%%/ex-client-tlsia.c
%%EXAMPLESDIR%%/ex-client1.c
%%EXAMPLESDIR%%/ex-client2.c
%%EXAMPLESDIR%%/ex-crq.c