aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2008-03-03 11:52:35 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2008-03-03 11:52:35 +0000
commit4585b4adc053c2df42c76e150ac9354191402282 (patch)
tree6ac8d7b15059a353266ee0fcaaedd2738ef5cf72 /security/gnutls
parent1929c1743b1696eef4671cc4a7184f502567e473 (diff)
downloadports-4585b4adc053c2df42c76e150ac9354191402282.tar.gz
ports-4585b4adc053c2df42c76e150ac9354191402282.zip
Notes
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile3
-rw-r--r--security/gnutls/Makefile.man65
-rw-r--r--security/gnutls/distinfo6
-rw-r--r--security/gnutls/pkg-plist9
4 files changed, 46 insertions, 37 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 36a3ec3c4995..6d6d8d6adea0 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnutls
-PORTVERSION= 2.0.2
-PORTREVISION= 2
+PORTVERSION= 2.2.2
CATEGORIES= security net
MASTER_SITES= http://josefsson.org/gnutls/releases/ \
ftp://ftp.gnutls.org/pub/gnutls/ \
diff --git a/security/gnutls/Makefile.man b/security/gnutls/Makefile.man
index 4fabb0cbf190..f616f9fd478d 100644
--- a/security/gnutls/Makefile.man
+++ b/security/gnutls/Makefile.man
@@ -46,8 +46,6 @@ MAN3= \
gnutls_certificate_set_openpgp_key_mem.3 \
gnutls_certificate_set_openpgp_keyring_file.3 \
gnutls_certificate_set_openpgp_keyring_mem.3 \
- gnutls_certificate_set_openpgp_keyserver.3 \
- gnutls_certificate_set_openpgp_trustdb.3 \
gnutls_certificate_set_params_function.3 \
gnutls_certificate_set_rsa_export_params.3 \
gnutls_certificate_set_verify_flags.3 \
@@ -63,6 +61,7 @@ MAN3= \
gnutls_certificate_set_x509_trust_file.3 \
gnutls_certificate_set_x509_trust_mem.3 \
gnutls_certificate_type_get.3 \
+ gnutls_certificate_type_get_id.3 \
gnutls_certificate_type_get_name.3 \
gnutls_certificate_type_list.3 \
gnutls_certificate_type_set_priority.3 \
@@ -70,6 +69,7 @@ MAN3= \
gnutls_certificate_verify_peers2.3 \
gnutls_check_version.3 \
gnutls_cipher_get.3 \
+ gnutls_cipher_get_id.3 \
gnutls_cipher_get_key_size.3 \
gnutls_cipher_get_name.3 \
gnutls_cipher_list.3 \
@@ -77,6 +77,7 @@ MAN3= \
gnutls_cipher_suite_get_name.3 \
gnutls_cipher_suite_info.3 \
gnutls_compression_get.3 \
+ gnutls_compression_get_id.3 \
gnutls_compression_get_name.3 \
gnutls_compression_list.3 \
gnutls_compression_set_priority.3 \
@@ -120,6 +121,7 @@ MAN3= \
gnutls_handshake_get_last_in.3 \
gnutls_handshake_get_last_out.3 \
gnutls_handshake_set_max_packet_length.3 \
+ gnutls_handshake_set_post_client_hello_function.3 \
gnutls_handshake_set_private_extensions.3 \
gnutls_hex_decode.3 \
gnutls_hex_encode.3 \
@@ -145,45 +147,45 @@ MAN3= \
gnutls_ia_verify_endphase.3 \
gnutls_init.3 \
gnutls_kx_get.3 \
+ gnutls_kx_get_id.3 \
gnutls_kx_get_name.3 \
gnutls_kx_list.3 \
gnutls_kx_set_priority.3 \
gnutls_mac_get.3 \
+ gnutls_mac_get_id.3 \
+ gnutls_mac_get_key_size.3 \
gnutls_mac_get_name.3 \
gnutls_mac_list.3 \
gnutls_mac_set_priority.3 \
gnutls_malloc.3 \
- gnutls_openpgp_key_check_hostname.3 \
- gnutls_openpgp_key_deinit.3 \
- gnutls_openpgp_key_export.3 \
- gnutls_openpgp_key_get_creation_time.3 \
- gnutls_openpgp_key_get_expiration_time.3 \
- gnutls_openpgp_key_get_fingerprint.3 \
- gnutls_openpgp_key_get_id.3 \
- gnutls_openpgp_key_get_key_usage.3 \
- gnutls_openpgp_key_get_name.3 \
- gnutls_openpgp_key_get_pk_algorithm.3 \
- gnutls_openpgp_key_get_version.3 \
- gnutls_openpgp_key_import.3 \
- gnutls_openpgp_key_init.3 \
- gnutls_openpgp_key_to_xml.3 \
- gnutls_openpgp_key_verify_ring.3 \
- gnutls_openpgp_key_verify_self.3 \
- gnutls_openpgp_key_verify_trustdb.3 \
- gnutls_openpgp_keyring_check_id.3 \
+ gnutls_openpgp_crt_init.3 \
+ gnutls_openpgp_crt_deinit.3 \
+ gnutls_openpgp_crt_import.3 \
+ gnutls_openpgp_crt_export.3 \
+ gnutls_openpgp_crt_get_fingerprint.3 \
+ gnutls_openpgp_crt_get_name.3 \
+ gnutls_openpgp_crt_get_pk_algorithm.3 \
+ gnutls_openpgp_crt_get_version.3 \
+ gnutls_openpgp_crt_get_creation_time.3 \
+ gnutls_openpgp_crt_get_expiration_time.3 \
+ gnutls_openpgp_crt_get_id.3 \
+ gnutls_openpgp_crt_check_hostname.3 \
+ gnutls_openpgp_crt_get_key_usage.3 \
+ gnutls_openpgp_crt_verify_ring.3 \
+ gnutls_openpgp_crt_verify_self.3 \
+ gnutls_openpgp_keyring_init.3 \
gnutls_openpgp_keyring_deinit.3 \
+ gnutls_openpgp_keyring_check_id.3 \
gnutls_openpgp_keyring_import.3 \
- gnutls_openpgp_keyring_init.3 \
+ gnutls_openpgp_privkey_init.3 \
gnutls_openpgp_privkey_deinit.3 \
- gnutls_openpgp_privkey_get_pk_algorithm.3 \
gnutls_openpgp_privkey_import.3 \
- gnutls_openpgp_privkey_init.3 \
+ gnutls_openpgp_privkey_get_pk_algorithm.3 \
gnutls_openpgp_privkey_sign_hash.3 \
- gnutls_openpgp_send_key.3 \
+ gnutls_openpgp_send_cert.3 \
gnutls_openpgp_set_recv_key_function.3 \
- gnutls_openpgp_trustdb_deinit.3 \
- gnutls_openpgp_trustdb_import_file.3 \
- gnutls_openpgp_trustdb_init.3 \
+ gnutls_oprfi_enable_client.3 \
+ gnutls_oprfi_enable_server.3 \
gnutls_pem_base64_decode.3 \
gnutls_pem_base64_decode_alloc.3 \
gnutls_pem_base64_encode.3 \
@@ -228,6 +230,11 @@ MAN3= \
gnutls_pkcs7_set_crt_raw.3 \
gnutls_prf.3 \
gnutls_prf_raw.3 \
+ gnutls_priority_deinit.3 \
+ gnutls_priority_init.3 \
+ gnutls_priority_set.3 \
+ gnutls_priority_set_direct.3 \
+ gnutls_protocol_get_id.3 \
gnutls_protocol_get_name.3 \
gnutls_protocol_get_version.3 \
gnutls_protocol_list.3 \
@@ -245,6 +252,7 @@ MAN3= \
gnutls_psk_set_server_dh_params.3 \
gnutls_psk_set_server_params_function.3 \
gnutls_record_check_pending.3 \
+ gnutls_record_disable_padding.3 \
gnutls_record_get_direction.3 \
gnutls_record_get_max_size.3 \
gnutls_record_recv.3 \
@@ -263,6 +271,7 @@ MAN3= \
gnutls_rsa_params_init.3 \
gnutls_server_name_get.3 \
gnutls_server_name_set.3 \
+ gnutls_session_enable_compatibility_mode.3 \
gnutls_session_get_client_random.3 \
gnutls_session_get_data.3 \
gnutls_session_get_data2.3 \
@@ -379,6 +388,7 @@ MAN3= \
gnutls_x509_crl_get_signature.3 \
gnutls_x509_crt_get_signature_algorithm.3 \
gnutls_x509_crt_get_subject_alt_name.3 \
+ gnutls_x509_crt_get_subject_alt_name2.3 \
gnutls_x509_crt_get_subject_key_id.3 \
gnutls_x509_crt_get_version.3 \
gnutls_x509_crt_import.3 \
@@ -402,7 +412,6 @@ MAN3= \
gnutls_x509_crt_set_subject_alternative_name.3 \
gnutls_x509_crt_set_subject_key_id.3 \
gnutls_x509_crt_sign2.3 \
- gnutls_x509_crt_to_xml.3 \
gnutls_x509_crt_verify.3 \
gnutls_x509_dn_oid_known.3 \
gnutls_x509_privkey_cpy.3 \
diff --git a/security/gnutls/distinfo b/security/gnutls/distinfo
index 5a7bdc34be6a..cdfafdbc049b 100644
--- a/security/gnutls/distinfo
+++ b/security/gnutls/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnutls-2.0.2.tar.bz2) = e22aafc38991dd6ed937376156ea2efc
-SHA256 (gnutls-2.0.2.tar.bz2) = 71b11b1668d9ac5df7387d3dd09f3339a958f135b9139ef93a78718ebdd383b7
-SIZE (gnutls-2.0.2.tar.bz2) = 4831867
+MD5 (gnutls-2.2.2.tar.bz2) = 90fb4b7c74d29bb6ee5bd8de85942f42
+SHA256 (gnutls-2.2.2.tar.bz2) = cbb0e76c28a8b8ee93d49e1fea4cb31549904d95cd8f488309126f7f5046d616
+SIZE (gnutls-2.2.2.tar.bz2) = 4923519
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index 859f839a29d0..e699255ef96b 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -27,22 +27,22 @@ include/gnutls/openssl.h
include/gnutls/pkcs12.h
include/gnutls/x509.h
%%CXX%%include/gnutls/gnutlsxx.h
-%%CXX%%lib/libgnutlsxx.so.13
+%%CXX%%lib/libgnutlsxx.so.26
%%CXX%%lib/libgnutlsxx.so
%%CXX%%lib/libgnutlsxx.la
%%CXX%%lib/libgnutlsxx.a
lib/libgnutls-extra.a
lib/libgnutls-extra.la
lib/libgnutls-extra.so
-lib/libgnutls-extra.so.13
+lib/libgnutls-extra.so.26
lib/libgnutls-openssl.a
lib/libgnutls-openssl.la
lib/libgnutls-openssl.so
-lib/libgnutls-openssl.so.13
+lib/libgnutls-openssl.so.26
lib/libgnutls.a
lib/libgnutls.la
lib/libgnutls.so
-lib/libgnutls.so.13
+lib/libgnutls.so.26
libdata/pkgconfig/gnutls-extra.pc
libdata/pkgconfig/gnutls.pc
share/aclocal/libgnutls-extra.m4
@@ -70,6 +70,7 @@ share/aclocal/libgnutls.m4
%%NLS%%share/locale/en@boldquot/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/en@quot/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/ms/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/pl/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/sv/LC_MESSAGES/gnutls.mo
@dirrm %%EXAMPLESDIR%%