aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2012-04-10 11:06:28 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2012-04-10 11:06:28 +0000
commit92e600045d3d72bb0bef6f2415151bf3fefbad8c (patch)
treee10fa9edc61fd898300719dae401f65f99dd0df0 /security/gnutls
parent71cc8837ce3f993a3ce4b6c3984ad3fd44a47a64 (diff)
downloadports-92e600045d3d72bb0bef6f2415151bf3fefbad8c.tar.gz
ports-92e600045d3d72bb0bef6f2415151bf3fefbad8c.zip
Notes
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile9
-rw-r--r--security/gnutls/pkg-plist21
2 files changed, 5 insertions, 25 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 549697bfe070..e84ca30e8813 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -64,14 +64,15 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.if !defined(NOPORTDOCS)
PORTDOCS= AUTHORS NEWS README THANKS
-.endif
-EXAMPLES= doc/examples/*.c
+PORTEXAMPLES= *.c
post-install:
+.if !defined (NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES:C,^,doc/examples/,} \
+ ${EXAMPLESDIR}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index 867ad26992f0..fec6d57b3753 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -48,26 +48,6 @@ lib/libgnutls.so
lib/libgnutls.so.47
libdata/pkgconfig/gnutls-extra.pc
libdata/pkgconfig/gnutls.pc
-%%EXAMPLESDIR%%/ex-alert.c
-%%EXAMPLESDIR%%/ex-cert-select-pkcs11.c
-%%EXAMPLESDIR%%/ex-cert-select.c
-%%EXAMPLESDIR%%/ex-client-psk.c
-%%EXAMPLESDIR%%/ex-client-resume.c
-%%EXAMPLESDIR%%/ex-client-srp.c
-%%EXAMPLESDIR%%/ex-client1.c
-%%EXAMPLESDIR%%/ex-client2.c
-%%EXAMPLESDIR%%/ex-crq.c
-%%EXAMPLESDIR%%/ex-pkcs12.c
-%%EXAMPLESDIR%%/ex-rfc2818.c
-%%EXAMPLESDIR%%/ex-serv-anon.c
-%%EXAMPLESDIR%%/ex-serv-pgp.c
-%%EXAMPLESDIR%%/ex-serv-psk.c
-%%EXAMPLESDIR%%/ex-serv-srp.c
-%%EXAMPLESDIR%%/ex-serv1.c
-%%EXAMPLESDIR%%/ex-session-info.c
-%%EXAMPLESDIR%%/ex-verify.c
-%%EXAMPLESDIR%%/ex-x509-info.c
-%%EXAMPLESDIR%%/tcp.c
%%NLS%%share/locale/cs/LC_MESSAGES/libgnutls.mo
%%NLS%%share/locale/de/LC_MESSAGES/libgnutls.mo
%%NLS%%share/locale/en@boldquot/LC_MESSAGES/libgnutls.mo
@@ -80,5 +60,4 @@ libdata/pkgconfig/gnutls.pc
%%NLS%%share/locale/sv/LC_MESSAGES/libgnutls.mo
%%NLS%%share/locale/vi/LC_MESSAGES/libgnutls.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/libgnutls.mo
-@dirrm %%EXAMPLESDIR%%
@dirrm include/gnutls