aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2007-01-02 08:52:38 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2007-01-02 08:52:38 +0000
commit47f7062f8daf1af7f064d90f971d4749a42363e2 (patch)
tree9175be29d8da27cd6952421292f72b2251f13217 /security/gnutls
parent2e6164d6dfadc13e59e18781b274523ccf5688d7 (diff)
downloadports-47f7062f8daf1af7f064d90f971d4749a42363e2.tar.gz
ports-47f7062f8daf1af7f064d90f971d4749a42363e2.zip
Notes
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile11
-rw-r--r--security/gnutls/Makefile.man2
-rw-r--r--security/gnutls/distinfo6
-rw-r--r--security/gnutls/pkg-plist11
4 files changed, 22 insertions, 8 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index fd8891bb227b..87ea912bb406 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnutls
-PORTVERSION= 1.4.5
+PORTVERSION= 1.6.1
CATEGORIES= security net
MASTER_SITES= http://josefsson.org/gnutls/releases/ \
ftp://ftp.gnutls.org/pub/gnutls/ \
@@ -30,7 +30,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -fPIC" LDFLAGS="${LDFLAGS}" \
MAKEINFO="${LOCALBASE}/bin/makeinfo"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-included-lzo \
@@ -50,6 +50,13 @@ LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
.endif
+.if defined(WITHOUT_CXX)
+CONFIGURE_ARGS+= --disable-cxx
+PLIST_SUB+= CXX="@comment "
+.else
+PLIST_SUB+= CXX=""
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
diff --git a/security/gnutls/Makefile.man b/security/gnutls/Makefile.man
index c71e85a35aa3..203547f57650 100644
--- a/security/gnutls/Makefile.man
+++ b/security/gnutls/Makefile.man
@@ -285,6 +285,8 @@ MAN3= \
gnutls_strerror.3 \
gnutls_transport_get_ptr.3 \
gnutls_transport_get_ptr2.3 \
+ gnutls_transport_set_errno.3 \
+ gnutls_transport_set_global_errno.3 \
gnutls_transport_set_lowat.3 \
gnutls_transport_set_ptr.3 \
gnutls_transport_set_ptr2.3 \
diff --git a/security/gnutls/distinfo b/security/gnutls/distinfo
index 7a5ac310fee6..661618dc42b2 100644
--- a/security/gnutls/distinfo
+++ b/security/gnutls/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnutls-1.4.5.tar.bz2) = 30b8449e079c50a952926fd288dc6773
-SHA256 (gnutls-1.4.5.tar.bz2) = 88580ab55ddcb2c6f3585ef22e3a349f453d15ce546549f9dae34d333b6d7341
-SIZE (gnutls-1.4.5.tar.bz2) = 4045874
+MD5 (gnutls-1.6.1.tar.bz2) = fc3cc2509aa93e150cafd39619de7428
+SHA256 (gnutls-1.6.1.tar.bz2) = 7711a351913731db25e12b20bc6f51e488f28df9c2673efdfa6e35034884cb41
+SIZE (gnutls-1.6.1.tar.bz2) = 4226536
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index 01e1d2652595..8c48a8973668 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -14,18 +14,23 @@ include/gnutls/openpgp.h
include/gnutls/openssl.h
include/gnutls/pkcs12.h
include/gnutls/x509.h
+%%CXX%%include/gnutls/gnutlsxx.h
+%%CXX%%lib/libgnutlsxx.so.15
+%%CXX%%lib/libgnutlsxx.so
+%%CXX%%lib/libgnutlsxx.la
+%%CXX%%lib/libgnutlsxx.a
lib/libgnutls-extra.a
lib/libgnutls-extra.la
lib/libgnutls-extra.so
-lib/libgnutls-extra.so.13
+lib/libgnutls-extra.so.15
lib/libgnutls-openssl.a
lib/libgnutls-openssl.la
lib/libgnutls-openssl.so
-lib/libgnutls-openssl.so.13
+lib/libgnutls-openssl.so.15
lib/libgnutls.a
lib/libgnutls.la
lib/libgnutls.so
-lib/libgnutls.so.13
+lib/libgnutls.so.15
libdata/pkgconfig/gnutls-extra.pc
libdata/pkgconfig/gnutls.pc
share/aclocal/libgnutls-extra.m4