aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2005-02-18 12:14:05 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2005-02-18 12:14:05 +0000
commit808556826efab4f2d6006ad0f8c00f1b33ab7ce9 (patch)
tree889277a1bc41bc26f81ff7d6a4e3d3321ff33410 /security/gnutls
parente317d86f7f150510ddad6e855b8c2808c54e8773 (diff)
downloadports-808556826efab4f2d6006ad0f8c00f1b33ab7ce9.tar.gz
ports-808556826efab4f2d6006ad0f8c00f1b33ab7ce9.zip
Notes
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile7
-rw-r--r--security/gnutls/files/patch-lib_Makefile.in11
-rw-r--r--security/gnutls/files/patch-libextra_Makefile.in11
3 files changed, 7 insertions, 22 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index f28a4314b05e..90009b1249c8 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnutls
PORTVERSION= 1.0.24
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
@@ -34,6 +35,8 @@ USE_GPG?= yes
SIG_SUFFIX= .sig
USE_ICONV= yes
USE_GETTEXT= yes
+USE_GNOME= pkgconfig
+USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -47,6 +50,10 @@ MAN1= certtool.1 gnutls-cli.1 gnutls-cli-debug.1 \
DOCS= AUTHORS NEWS README THANKS doc/tex/*.ps
EXAMPLES= doc/examples/*.c
+post-patch:
+ @${REINPLACE_CMD} -e 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/libextra/Makefile.in
+
post-install:
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
diff --git a/security/gnutls/files/patch-lib_Makefile.in b/security/gnutls/files/patch-lib_Makefile.in
deleted file mode 100644
index edc8e9ace966..000000000000
--- a/security/gnutls/files/patch-lib_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Sun Nov 14 00:54:35 2004
-+++ lib/Makefile.in Fri Jan 28 16:11:24 2005
-@@ -296,7 +296,7 @@
- m4data_DATA = libgnutls.m4
-
- # Pkg-config script.
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = gnutls.pc
- DISTCLEANFILES = $(pkgconfig_DATA)
- LIBGNUTLS_EXPORTS = -export-symbols-regex '^(_gnutls|gnutls|_E_).*'
diff --git a/security/gnutls/files/patch-libextra_Makefile.in b/security/gnutls/files/patch-libextra_Makefile.in
deleted file mode 100644
index 3c088dfd7e51..000000000000
--- a/security/gnutls/files/patch-libextra_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libextra/Makefile.in.orig Fri Jan 28 16:38:05 2005
-+++ libextra/Makefile.in Fri Jan 28 16:38:25 2005
-@@ -306,7 +306,7 @@ m4datadir = $(datadir)/aclocal
- m4data_DATA = libgnutls-extra.m4
-
- # Pkg-config script.
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = gnutls-extra.pc
- DISTCLEANFILES = $(pkgconfig_DATA)
- LIBGNUTLS_EXTRA_EXPORTS = -export-symbols-regex '^gnutls.*'