aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-06-04 18:51:20 +0000
committerCy Schubert <cy@FreeBSD.org>2014-06-04 18:51:20 +0000
commit8887883116024154590c7b87479a63e45dd906e6 (patch)
treee07fad23f756498f3145b143e9e9ffaeb49f70f6 /security/gnutls
parent42945633ebafbeeac613f8ea0a3a405a0d7208f5 (diff)
Notes
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile2
-rw-r--r--security/gnutls/files/patch-lib-gnutls_handshake.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 009e98c310a0..7b4dfcdc8a9b 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnutls
PORTVERSION= 2.12.23
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security net
MASTER_SITES= \
ftp://ftp.gnutls.org/gcrypt/gnutls/v${PORTVERSION:C/.[0-9]+$//}/ \
diff --git a/security/gnutls/files/patch-lib-gnutls_handshake.c b/security/gnutls/files/patch-lib-gnutls_handshake.c
new file mode 100644
index 000000000000..8ecac0686495
--- /dev/null
+++ b/security/gnutls/files/patch-lib-gnutls_handshake.c
@@ -0,0 +1,11 @@
+--- lib/gnutls_handshake.c.orig 2012-11-03 06:03:47.000000000 -0700
++++ lib/gnutls_handshake.c 2014-06-04 07:55:49.138570114 -0700
+@@ -1797,7 +1797,7 @@
+ DECR_LEN (len, 1);
+ session_id_len = data[pos++];
+
+- if (len < session_id_len)
++ if (len < session_id_len || session_id_len > TLS_MAX_SESSION_ID_SIZE)
+ {
+ gnutls_assert ();
+ return GNUTLS_E_UNSUPPORTED_VERSION_PACKET;