aboutsummaryrefslogtreecommitdiff
path: root/security/go.crypto
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2016-07-26 16:47:59 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2016-07-26 16:47:59 +0000
commit07fcb7c2b20a15c24404078ec566b0d8d2ecd733 (patch)
tree8bfa9d671692f5373601f0e03901bd73adb77d2d /security/go.crypto
parent1f9e9d9abfbd418e01d4f68ce91c2168628a6f5c (diff)
downloadports-07fcb7c2b20a15c24404078ec566b0d8d2ecd733.tar.gz
ports-07fcb7c2b20a15c24404078ec566b0d8d2ecd733.zip
Notes
Diffstat (limited to 'security/go.crypto')
-rw-r--r--security/go.crypto/Makefile14
-rw-r--r--security/go.crypto/distinfo5
-rw-r--r--security/go.crypto/pkg-plist29
3 files changed, 44 insertions, 4 deletions
diff --git a/security/go.crypto/Makefile b/security/go.crypto/Makefile
index 052533a6f30e..61b7cca42faa 100644
--- a/security/go.crypto/Makefile
+++ b/security/go.crypto/Makefile
@@ -1,13 +1,18 @@
# $FreeBSD$
PORTNAME= go.crypto
-PORTVERSION= 20160105
+PORTVERSION= 20160709
CATEGORIES= security devel
-MASTER_SITES= http://www.c-s.li/ports/
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Additional cryptography packages for Go
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= golang
+GH_PROJECT= crypto
+GH_TAGNAME= c2f4947f41766b144bb09066e919466da5eddeae
USES= go
GO_PKGNAME= golang.org/x/crypto
GO_TARGET= ${GO_PKGNAME}/bcrypt \
@@ -15,6 +20,8 @@ GO_TARGET= ${GO_PKGNAME}/bcrypt \
${GO_PKGNAME}/bn256 \
${GO_PKGNAME}/cast5 \
${GO_PKGNAME}/curve25519 \
+ ${GO_PKGNAME}/ed25519 \
+ ${GO_PKGNAME}/ed25519/internal/edwards25519\
${GO_PKGNAME}/hkdf \
${GO_PKGNAME}/md4 \
${GO_PKGNAME}/nacl/box \
@@ -29,6 +36,8 @@ GO_TARGET= ${GO_PKGNAME}/bcrypt \
${GO_PKGNAME}/openpgp/s2k \
${GO_PKGNAME}/otr \
${GO_PKGNAME}/pbkdf2 \
+ ${GO_PKGNAME}/pkcs12 \
+ ${GO_PKGNAME}/pkcs12/internal/rc2\
${GO_PKGNAME}/poly1305 \
${GO_PKGNAME}/ripemd160 \
${GO_PKGNAME}/salsa20 \
@@ -40,6 +49,7 @@ GO_TARGET= ${GO_PKGNAME}/bcrypt \
${GO_PKGNAME}/ssh/terminal \
${GO_PKGNAME}/ssh/test \
${GO_PKGNAME}/ssh/testdata \
+ ${GO_PKGNAME}/tea \
${GO_PKGNAME}/twofish \
${GO_PKGNAME}/xtea \
${GO_PKGNAME}/xts
diff --git a/security/go.crypto/distinfo b/security/go.crypto/distinfo
index f6c4ae500f62..7fe61590fc45 100644
--- a/security/go.crypto/distinfo
+++ b/security/go.crypto/distinfo
@@ -1,2 +1,3 @@
-SHA256 (go.crypto-20160105.tar.gz) = eb3266d8c19a2400a69c6fcafed5a4418106bedad229a4ec3ff72f1c83485251
-SIZE (go.crypto-20160105.tar.gz) = 900243
+TIMESTAMP = 1468178973
+SHA256 (golang-crypto-20160709-c2f4947f41766b144bb09066e919466da5eddeae_GH0.tar.gz) = 793910f411bcf5ddec4490b18308bc4b9f333bcbb7861fdec84d262bb47a78a5
+SIZE (golang-crypto-20160709-c2f4947f41766b144bb09066e919466da5eddeae_GH0.tar.gz) = 1028056
diff --git a/security/go.crypto/pkg-plist b/security/go.crypto/pkg-plist
index 07da82654f9e..088be294d686 100644
--- a/security/go.crypto/pkg-plist
+++ b/security/go.crypto/pkg-plist
@@ -3,6 +3,8 @@
%%GO_LIBDIR%%/%%GO_PKGNAME%%/bn256.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/cast5.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/curve25519.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/ed25519.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/ed25519/internal/edwards25519.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/hkdf.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/md4.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/nacl/box.a
@@ -17,6 +19,8 @@
%%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp/s2k.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/otr.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/pbkdf2.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/pkcs12.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/pkcs12/internal/rc2.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/poly1305.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ripemd160.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/salsa20.a
@@ -28,6 +32,7 @@
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ssh/terminal.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ssh/test.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ssh/testdata.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/tea.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/twofish.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/xtea.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/xts.a
@@ -60,6 +65,11 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/curve25519/mont25519_amd64.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/curve25519/mul_amd64.s
%%GO_SRCDIR%%/%%GO_PKGNAME%%/curve25519/square_amd64.s
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ed25519/ed25519.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ed25519/ed25519_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ed25519/internal/edwards25519/const.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ed25519/internal/edwards25519/edwards25519.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ed25519/testdata/sign.input.gz
%%GO_SRCDIR%%/%%GO_PKGNAME%%/hkdf/example_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/hkdf/hkdf.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/hkdf/hkdf_test.go
@@ -128,6 +138,21 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/otr/smp.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/pbkdf2/pbkdf2.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/pbkdf2/pbkdf2_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/bmp-string.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/bmp-string_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/crypto.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/crypto_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/errors.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/internal/rc2/bench_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/internal/rc2/rc2.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/internal/rc2/rc2_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/mac.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/mac_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/pbkdf.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/pbkdf_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/pkcs12.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/pkcs12_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pkcs12/safebags.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/const_amd64.s
%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/poly1305.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/poly1305_amd64.s
@@ -162,6 +187,7 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/sha3/xor_unaligned.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent/client.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent/client_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent/example_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent/forward.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent/keyring.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent/keyring_test.go
@@ -206,6 +232,7 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util_bsd.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util_linux.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util_plan9.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util_windows.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/agent_unix_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/cert_test.go
@@ -220,6 +247,8 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/testdata_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/transport.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/transport_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/tea/cipher.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/tea/tea_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/twofish/twofish.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/twofish/twofish_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/xtea/block.go