aboutsummaryrefslogtreecommitdiff
path: root/security/goptlib/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2014-04-18 20:28:52 +0000
committerCarlo Strub <cs@FreeBSD.org>2014-04-18 20:28:52 +0000
commitccdbd803e1edf63696f330ee81f24e5bfca0b6f9 (patch)
tree885f9872b9f0ed33902e6dab6d1b2f737778bd84 /security/goptlib/Makefile
parentfbaf8a7377541bc016b170d205d19d9f30150271 (diff)
Notes
Diffstat (limited to 'security/goptlib/Makefile')
-rw-r--r--security/goptlib/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/security/goptlib/Makefile b/security/goptlib/Makefile
new file mode 100644
index 000000000000..615a0cca5055
--- /dev/null
+++ b/security/goptlib/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= goptlib
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= http://c-s.li/ports/
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Go pluggable transports library
+
+GO_PKGNAME= git.torproject.org/pluggable-transports/${PORTNAME}.git
+GO_TARGET= ${GO_PKGNAME}
+
+post-extract:
+ @${MKDIR} ${GO_WRKSRC:H}
+ @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>