aboutsummaryrefslogtreecommitdiff
path: root/security/gpasman
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-07 19:59:26 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-07 19:59:26 +0000
commit89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df (patch)
treedab293772a4c12d5e7f6c0f30c1e8ae09e1cfe4d /security/gpasman
parent65b63032bfb3a3f1c8ac4ee660ac83927b43c92a (diff)
downloadports-89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df.tar.gz
ports-89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df.zip
Notes
Diffstat (limited to 'security/gpasman')
-rw-r--r--security/gpasman/Makefile3
-rw-r--r--security/gpasman/files/patch-ab13
2 files changed, 14 insertions, 2 deletions
diff --git a/security/gpasman/Makefile b/security/gpasman/Makefile
index cda66d2fe764..b340deace0fb 100644
--- a/security/gpasman/Makefile
+++ b/security/gpasman/Makefile
@@ -14,9 +14,12 @@ MAINTAINER= domi@saargate.de
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTKCONFIG="${GTK_CONFIG}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/gpasman ${PREFIX}/bin
diff --git a/security/gpasman/files/patch-ab b/security/gpasman/files/patch-ab
index c24e3b261bb0..abbcf95df031 100644
--- a/security/gpasman/files/patch-ab
+++ b/security/gpasman/files/patch-ab
@@ -1,5 +1,5 @@
---- src/Makefile.in.orig Sun Sep 19 13:56:52 1999
-+++ src/Makefile.in Sun Sep 19 13:57:20 1999
+--- src/Makefile.in.orig Fri Sep 3 00:50:10 1999
++++ src/Makefile.in Sat Jul 1 18:19:43 2000
@@ -26,9 +26,9 @@
@@ -12,3 +12,12 @@
INSTALL = @INSTALL@
SRCS = librc2.c file.c gpasman.c
+@@ -39,7 +39,7 @@
+ $(CC) -o gpasman $(OBJS) $(LDFLAGS) $(LIBS)
+
+ .c.o: $(SRCS)
+- $(CC) -O2 -Wall $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ clean:
+ rm -f $(OBJS) gpasman core *~ *.bak