aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-11 05:32:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-11 05:32:48 +0000
commit8967054a683476cdf3815ce4d3a8785cf144b435 (patch)
tree0d96c918d4119c8e9f5a37365d0fd6377ebeffae /security/gpgme/Makefile
parent19ae22908e75570bbafd646d469dc1a121e73e79 (diff)
Notes
Diffstat (limited to 'security/gpgme/Makefile')
-rw-r--r--security/gpgme/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 1d06e7f2c43a..07d8661da61c 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gpgme
-PORTVERSION= 0.3.16
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gpgme
@@ -16,11 +15,14 @@ MAINTAINER= markun@onohara.to
COMMENT= A library to make access to GnuPG easier
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-pth \
+ --without-pth-test \
+ --with-gpg=${LOCALBASE}/bin/gpg
INFO= gpgme
@@ -32,6 +34,7 @@ WITH_GPGSM= yes
.if defined(WITH_GPGSM)
BUILD_DEPENDS+= gpgsm:${PORTSDIR}/security/gnupg-devel
+CONFIGURE_ARGS+=--with-gpgsm=${LOCALBASE}/bin/gpgsm
.else
CONFIGURE_ARGS+= --without-gpgsm
.endif