aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme03/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-12-21 08:59:42 +0000
committerClement Laforet <clement@FreeBSD.org>2004-12-21 08:59:42 +0000
commit7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8 (patch)
tree14e5daf0321e5bcec6a69cf36c14c650a67788ed /security/gpgme03/Makefile
parent01b976f45a05e3b5dd2a265a53effbf87560d087 (diff)
downloadports-7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8.tar.gz
ports-7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8.zip
Notes
Diffstat (limited to 'security/gpgme03/Makefile')
-rw-r--r--security/gpgme03/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/security/gpgme03/Makefile b/security/gpgme03/Makefile
index e6780f6d4fe1..8a7aa1b4512d 100644
--- a/security/gpgme03/Makefile
+++ b/security/gpgme03/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gpgme
PORTVERSION= 0.3.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gpgme
@@ -24,9 +24,13 @@ LATEST_LINK= gpgme03
USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
+USE_AUTOCONF_VER= 259
INSTALLS_SHLIB= yes
+USE_REINPLACE= YES
-INFO= gpgme
+INFO= gpgme03
+
+CONFIGURE_ARGS+= --includedir=${PREFIX}/include/gpgme03
.include <bsd.port.pre.mk>
@@ -40,4 +44,10 @@ BUILD_DEPENDS+= gpgsm:${PORTSDIR}/security/gnupg-devel
CONFIGURE_ARGS+= --without-gpgsm
.endif
+post-patch:
+.for i in tests tests/gpg tests/gpgsm
+ @${REINPLACE_CMD} -e 's/libgpgme.la/libgpgme03.la/' \
+ ${WRKSRC}/${i}/Makefile.in
+.endfor
+
.include <bsd.port.post.mk>