aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-06-22 07:07:42 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-06-22 07:07:42 +0000
commitdcf209ebbf03953c95ded6ab4e4e33f9848b327c (patch)
treec9d60b813aa64ac4e1bf9f0f20982530b4778f62 /security/gpgme
parent1e0521cde78a4beda53da2eca65c0c06af6273b4 (diff)
downloadports-dcf209ebbf03953c95ded6ab4e4e33f9848b327c.tar.gz
ports-dcf209ebbf03953c95ded6ab4e4e33f9848b327c.zip
Notes
Diffstat (limited to 'security/gpgme')
-rw-r--r--security/gpgme/Makefile30
-rw-r--r--security/gpgme/distinfo6
-rw-r--r--security/gpgme/pkg-plist4
3 files changed, 8 insertions, 32 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 578ebf3508d5..b618e3fa388d 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -2,13 +2,9 @@
# $FreeBSD$
PORTNAME= gpgme
-PORTVERSION= 1.4.3
-PORTREVISION= 1
+PORTVERSION= 1.5.0
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_GNUPG}
-MASTER_SITE_SUBDIR= gpgme
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES= GNUPG/gpgme
MAINTAINER= jhale@FreeBSD.org
COMMENT= Library to make access to GnuPG easier
@@ -22,8 +18,7 @@ GNU_CONFIGURE= yes
USES= gmake libtool:keepla tar:bzip2
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/gpgme \
- --with-g13=no
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/gpgme
INFO= gpgme
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
@@ -36,32 +31,14 @@ OPTIONS_DEFAULT= GNUPG2 UISERVER
GNUPG1_DESC= Build gpgme library for GnuPG 1.x
GNUPG1_BUILD_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
GNUPG1_RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
-GNUPG1_CONFIGURE_ON= --with-gpg=${LOCALBASE}/bin/gpg \
- --with-gpgconf=no \
- --with-gpgsm=no
GNUPG2_DESC= Build gpgme library for GnuPG 2.x
GNUPG2_BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
GNUPG2_RUN_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
-GNUPG2_CONFIGURE_ON= --with-gpg=${LOCALBASE}/bin/gpg2 \
- --with-gpgconf=${LOCALBASE}/bin/gpgconf
UISERVER_DESC= GnuPG UI server support
UISERVER_CONFIGURE_ENABLE= fd-passing
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGNUPG2}
-.if exists(${LOCALBASE}/bin/gpgsm)
-CONFIGURE_ARGS+=--with-gpgsm=${LOCALBASE}/bin/gpgsm
-.else
-CONFIGURE_ARGS+=--with-gpgsm=no
-.endif
-.endif
-
-verify: checksum
- gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT} \
@@ -74,5 +51,6 @@ post-patch:
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgpgme*.so.*
.include <bsd.port.mk>
diff --git a/security/gpgme/distinfo b/security/gpgme/distinfo
index 4be0035fd9cb..08baf8dc6831 100644
--- a/security/gpgme/distinfo
+++ b/security/gpgme/distinfo
@@ -1,4 +1,2 @@
-SHA256 (gpgme-1.4.3.tar.bz2) = 2d1cc12411753752d9c5b9037e6fd3fd363517af720154768cc7b46b60120496
-SIZE (gpgme-1.4.3.tar.bz2) = 972497
-SHA256 (gpgme-1.4.3.tar.bz2.sig) = 5b8269678c1ec6a73ad56475f731c1247359167a921b1dc0ae3b1e8d38a9273c
-SIZE (gpgme-1.4.3.tar.bz2.sig) = 287
+SHA256 (gpgme-1.5.0.tar.bz2) = d1127ed730976468255e692d91f1c25b49fe2a97aad1379fc443f2c83c683c83
+SIZE (gpgme-1.5.0.tar.bz2) = 964134
diff --git a/security/gpgme/pkg-plist b/security/gpgme/pkg-plist
index 7cd9cd441e2a..f978f1d3c793 100644
--- a/security/gpgme/pkg-plist
+++ b/security/gpgme/pkg-plist
@@ -6,11 +6,11 @@ lib/common-lisp/gpgme/gpgme.lisp
lib/libgpgme-pthread.la
lib/libgpgme-pthread.so
lib/libgpgme-pthread.so.11
-lib/libgpgme-pthread.so.11.11.0
+lib/libgpgme-pthread.so.11.12.0
lib/libgpgme.la
lib/libgpgme.so
lib/libgpgme.so.11
-lib/libgpgme.so.11.11.0
+lib/libgpgme.so.11.12.0
share/aclocal/gpgme.m4
@dirrm lib/common-lisp/gpgme
@dirrmtry lib/common-lisp