aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-02-02 23:30:34 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-02-02 23:30:34 +0000
commit0ed45d94036a6efcb238f6e09e14f2927c57e622 (patch)
tree5b901af42e538050dc6ebb3d21304ed142075485 /security/gpgme
parent5faa586c7092862f64e72d0d3ec078cef502453c (diff)
downloadports-0ed45d94036a6efcb238f6e09e14f2927c57e622.tar.gz
ports-0ed45d94036a6efcb238f6e09e14f2927c57e622.zip
Notes
Diffstat (limited to 'security/gpgme')
-rw-r--r--security/gpgme/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index cdcad4fe5f05..dd9911ea4029 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gpgme
PORTVERSION= 1.10.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= security
MASTER_SITES= GNUPG/gpgme
@@ -31,7 +31,7 @@ CONFIGURE_ARGS+=--enable-languages="cl"
INFO= gpgme
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
-OPTIONS_DEFINE= DOCS UISERVER
+OPTIONS_DEFINE= DOCS TEST UISERVER
OPTIONS_SINGLE= GNUPG
OPTIONS_SINGLE_GNUPG= GNUPG1 GNUPG2
OPTIONS_DEFAULT= GNUPG2 UISERVER
@@ -44,16 +44,21 @@ GNUPG2_DESC= Build gpgme library for GnuPG 2.x
GNUPG2_BUILD_DEPENDS= gpg2:security/gnupg
GNUPG2_RUN_DEPENDS= gpg2:security/gnupg
+# Tests may fail if the test directory path length surpasses the socket path
+# length limitation of 104 characters. Due to the way gnupg creates sockets,
+# the easiest way to overcome this is to create a /var/run/user/${UID}
+# directory set with 700 permissions and owned by the effective user building
+# the port.
+TEST_CONFIGURE_ENABLE= g13-test gpg-test gpgconf-test gpgsm-test
+TEST_PREVENTS= GNUPG1
+TEST_PREVENTS_MSG= TEST option is mainly designed for use with the GNUPG2 option
+
UISERVER_DESC= GnuPG UI server support
UISERVER_CONFIGURE_ENABLE= fd-passing
.endif
.include <bsd.port.options.mk>
-.if !exists(${LOCALBASE}/bin/gpgsm)
-CONFIGURE_ARGS+= --disable-gpgsm-test
-.endif
-
.if defined(SLAVEPORT)
LIB_DEPENDS+= libgpgme.so:security/gpgme
BUILD_WRKSRC= ${WRKSRC}/lang/${BINDING_NAME}
@@ -82,11 +87,6 @@ USES+= python
USE_PYTHON= py3kplist flavors
CONFIGURE_ENV+= SWIG=${LOCALBASE}/bin/swig3.0
PLIST_SUB+= VERSION=${PORTVERSION}
-. if ${FLAVOR:Upy27:Mpy2*}
-CONFIGURE_ARGS+=--enable-languages="python2"
-. else
-CONFIGURE_ARGS+=--enable-languages="python3"
-. endif
. endif
.endif
@@ -100,7 +100,11 @@ post-patch:
. endif
.endif
@${REINPLACE_CMD} -e 's|^clfilesdir.*|clfilesdir=$$\(libdir\)/common-lisp/gpgme|g' \
- ${WRKSRC}/lang/cl/Makefile.in
+ ${WRKSRC}/lang/cl/Makefile.in
+ @${REINPLACE_CMD} -e '/SUBDIRS/s|tests||' \
+ ${WRKSRC}/lang/python/Makefile.in \
+ ${WRKSRC}/lang/qt/Makefile.in
+
.if !defined(SLAVEPORT)
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}