aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-07-27 18:07:06 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-07-27 18:07:06 +0000
commitc4b0f0b1beb55c093568a340db960ab213fea4cf (patch)
tree09180aac9c7ee83b75e2aa90074463d545435044 /security/gpgme
parentb1b6d2a0545a17f97e3ec8562f90bcafd81519f7 (diff)
downloadports-c4b0f0b1beb55c093568a340db960ab213fea4cf.tar.gz
ports-c4b0f0b1beb55c093568a340db960ab213fea4cf.zip
Notes
Diffstat (limited to 'security/gpgme')
-rw-r--r--security/gpgme/Makefile5
-rw-r--r--security/gpgme/files/patch-src__engine-gpgconf.c10
2 files changed, 2 insertions, 13 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 5cc17277079e..e0dceaecb673 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -16,7 +16,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bsdkaffee@gmail.com
COMMENT= A library to make access to GnuPG easier
-LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error
+LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
+ gpg-error.0:${PORTSDIR}/security/libgpg-error
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:22
@@ -52,7 +53,6 @@ RUN_DEPENDS+= gpg2:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--with-gpg=${LOCALBASE}/bin/gpg2 \
--with-gpgconf=${LOCALBASE}/bin/gpgconf
.if exists(${LOCALBASE}/bin/gpgsm)
-LIB_DEPENDS+= assuan.0:${PORTSDIR}/security/libassuan
CONFIGURE_ARGS+=--with-gpgsm=${LOCALBASE}/bin/gpgsm
.else
CONFIGURE_ARGS+=--with-gpgsm=no
@@ -69,7 +69,6 @@ PLIST_SUB+= WITH_PTH='@comment '
.if defined(WITH_UISERVER)
CONFIGURE_ARGS+=--enable-fd-passing
-LIB_DEPENDS+= assuan.0:${PORTSDIR}/security/libassuan
.endif
verify: checksum
diff --git a/security/gpgme/files/patch-src__engine-gpgconf.c b/security/gpgme/files/patch-src__engine-gpgconf.c
deleted file mode 100644
index d14f81c78f43..000000000000
--- a/security/gpgme/files/patch-src__engine-gpgconf.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/engine-gpgconf.c.orig 2009-06-15 07:59:37.000000000 -0400
-+++ ./src/engine-gpgconf.c 2009-12-05 03:03:51.000000000 -0500
-@@ -38,7 +38,6 @@
- #include "priv-io.h"
- #include "sema.h"
-
--#include "assuan.h"
- #include "debug.h"
-
- #include "engine-backend.h"