aboutsummaryrefslogtreecommitdiff
path: root/security/gringotts
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-29 11:15:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-29 11:15:11 +0000
commit671e00583554fe3ca5c778e60f4b27a46c976c0d (patch)
treedeabf93b50e4d5928e582e77ad417b2809122c59 /security/gringotts
parente83d16d10810647d018dff4a421749c3901a00f6 (diff)
downloadports-671e00583554fe3ca5c778e60f4b27a46c976c0d.tar.gz
ports-671e00583554fe3ca5c778e60f4b27a46c976c0d.zip
Notes
Diffstat (limited to 'security/gringotts')
-rw-r--r--security/gringotts/Makefile53
-rw-r--r--security/gringotts/distinfo6
-rw-r--r--security/gringotts/files/patch-grg_safe.c25
-rw-r--r--security/gringotts/files/patch-po-Makefile.in.in11
-rw-r--r--security/gringotts/files/patch-src-Makefile.in10
-rw-r--r--security/gringotts/pkg-plist16
6 files changed, 49 insertions, 72 deletions
diff --git a/security/gringotts/Makefile b/security/gringotts/Makefile
index 245f3bf07f2d..99bbf485c23f 100644
--- a/security/gringotts/Makefile
+++ b/security/gringotts/Makefile
@@ -6,44 +6,39 @@
#
PORTNAME= gringotts
-PORTVERSION= 1.2.8
-PORTREVISION= 7
+PORTVERSION= 1.2.10
CATEGORIES= security
-MASTER_SITES= BERLIOS \
- ftp://ftp.nuug.no/pub/anders/distfiles/
+MASTER_SITES= BERLIOS
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK application to securely store sensitive data
-LIB_DEPENDS= gringotts.2:${PORTSDIR}/security/libgringotts \
- popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ gringotts.2:${PORTSDIR}/security/libgringotts
-USE_BZIP2= yes
-GNU_CONFIGURE= yes
USE_GNOME= gtk20
-WANT_GNOME= yes
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
-CONFIGURE_ARGS+= --disable-env-check
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mgnomehier}!=""
-USE_GNOME+= gnomehier
-PLIST_SUB+= GNOMEHIER=''
-.else
-PLIST_SUB+= GNOMEHIER='@comment '
-.endif
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
post-patch:
- ${REINPLACE_CMD} -E -e "s|^(gringottsdocdir =).*|\1 ${DOCSDIR}|;s|md5sum|md5|g" ${WRKSRC}/Makefile.in
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-D.*_DISABLE_DEPRECATED||g'
-.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} -E -e "s|^(install-data-am:.*)install-gringottsdocDATA|\1|" ${WRKSRC}/Makefile.in
-.endif
-.if ${HAVE_GNOME:Mgnomehier}==""
- ${REINPLACE_CMD} -E -e "s|^(install-data-am:.*)install-DsktpDATA|\1|" \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/^install-data-am:/s|install-DsktpDATA|| ; \
+ /^install-data-am:/s|install-docDATA|| ; \
+ s|@md5sum|@md5|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/^install-exec-am:/s|install-exec-local||' ${WRKSRC}/src/Makefile.in
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS BUGS ChangeLog FAQ NEWS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/gringotts/distinfo b/security/gringotts/distinfo
index adc181aa6433..8b0a1dfcbe93 100644
--- a/security/gringotts/distinfo
+++ b/security/gringotts/distinfo
@@ -1,3 +1,3 @@
-MD5 (gringotts-1.2.8.tar.bz2) = f84add2aadca642a354105f63c117dec
-SHA256 (gringotts-1.2.8.tar.bz2) = cc4640cf57f0dc31799a6a4db44b9d9a06ee08be14f1c565512db28d3ae8d6f0
-SIZE (gringotts-1.2.8.tar.bz2) = 174175
+MD5 (gringotts-1.2.10.tar.gz) = 6f17589f1cb7d08be73728843dcf286a
+SHA256 (gringotts-1.2.10.tar.gz) = 19784f68f76b211d076124c74d2f5ca5a156e4af7ed32d72a1ba45547782179d
+SIZE (gringotts-1.2.10.tar.gz) = 251963
diff --git a/security/gringotts/files/patch-grg_safe.c b/security/gringotts/files/patch-grg_safe.c
index 22053cc8fa0f..1b8b273ca9f7 100644
--- a/security/gringotts/files/patch-grg_safe.c
+++ b/security/gringotts/files/patch-grg_safe.c
@@ -1,34 +1,35 @@
---- src/grg_safe.c.orig Wed May 14 02:02:13 2003
-+++ src/grg_safe.c Wed May 14 02:03:43 2003
+--- src/grg_safe.c.orig 2008-01-04 22:08:43.000000000 +0900
++++ src/grg_safe.c 2009-12-22 04:53:36.000000000 +0900
@@ -33,6 +33,7 @@
#include <stdlib.h>
#include <string.h>
+#include <sys/types.h>
+ #include <errno.h>
#include <regex.h>
#include <unistd.h>
- #include <fcntl.h>
-@@ -43,7 +44,6 @@
+@@ -44,7 +45,6 @@
#include <sys/fsuid.h>
#endif
#include <sys/time.h>
-#include <sys/types.h>
#include <sys/resource.h>
- #include <sys/stat.h>
-
-@@ -59,8 +59,6 @@
+ #ifdef linux
+ #include <sys/utsname.h>
+@@ -96,9 +96,6 @@
grg_mlockall_and_drop_root_privileges(void)
{
- // drop eventual group root privileges
+ /* drop eventual group root privileges */
- setgid(getgid());
-- setgid(getgid()); // twice for counter "saved IDs", cfr.
- // Secure Programming HowTo
+- setgid(getgid()); /* twice for counter "saved IDs", cfr. */
+- /* Secure Programming HowTo */
#ifdef HAVE_SYS_FSUID_H
setfsgid(getgid());
-@@ -84,8 +82,6 @@
+ setfsgid(getgid());
+@@ -148,8 +145,6 @@
#endif
- // drop root privileges
+ /* drop root privileges */
- setuid(getuid());
- setuid(getuid());
#ifdef HAVE_SYS_FSUID_H
diff --git a/security/gringotts/files/patch-po-Makefile.in.in b/security/gringotts/files/patch-po-Makefile.in.in
deleted file mode 100644
index 08e7d77f80d6..000000000000
--- a/security/gringotts/files/patch-po-Makefile.in.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Wed May 14 02:32:06 2003
-+++ po/Makefile.in.in Wed May 14 02:32:22 2003
-@@ -106,7 +106,7 @@
- @catalogs='$(CATALOGS)'; \
- for cat in $$catalogs; do \
- cat=`basename $$cat`; \
-- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
-+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
- dir=$(localedir)/$$lang/LC_MESSAGES; \
- $(mkinstalldirs) $(DESTDIR)$$dir; \
- if test -r $$cat; then \
diff --git a/security/gringotts/files/patch-src-Makefile.in b/security/gringotts/files/patch-src-Makefile.in
deleted file mode 100644
index 61285e201593..000000000000
--- a/security/gringotts/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Makefile.in.orig Tue Feb 18 22:06:05 2003
-+++ src/Makefile.in Tue Feb 18 22:06:33 2003
-@@ -399,7 +399,6 @@
-
- install-exec-local:
- strip $(DESTDIR)$(bindir)/gringotts
-- chmod u+s $(DESTDIR)$(bindir)/gringotts
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/security/gringotts/pkg-plist b/security/gringotts/pkg-plist
index b7dfbba3d743..506653fe384e 100644
--- a/security/gringotts/pkg-plist
+++ b/security/gringotts/pkg-plist
@@ -1,16 +1,18 @@
bin/gringotts
-share/pixmaps/gringotts.xpm
-share/locale/de/LC_MESSAGES/gringotts.mo
-share/locale/fr/LC_MESSAGES/gringotts.mo
-share/locale/it/LC_MESSAGES/gringotts.mo
-%%GNOMEHIER%%share/gnome/apps/Utilities/gringotts.desktop
-%%GNOMEHIER%%@unexec rmdir -p %D/share/gnome/apps/Utilities 2>/dev/null || true
+share/applications/gringotts.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/locale/de/LC_MESSAGES/gringotts.mo
+share/locale/fr/LC_MESSAGES/gringotts.mo
+share/locale/it/LC_MESSAGES/gringotts.mo
+share/locale/pl/LC_MESSAGES/gringotts.mo
+share/locale/ru/LC_MESSAGES/gringotts.mo
+share/pixmaps/gringotts.xpm
+share/pixmaps/gringotts-32.xpm
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications