aboutsummaryrefslogtreecommitdiff
path: root/security/gsasl/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-03 18:09:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-03 18:09:28 +0000
commitc4c31e009affa1c03332757a152f183911ebfbb0 (patch)
tree9f3efe7179f47a1264b2637fab2d18c789c85db8 /security/gsasl/Makefile
parentffbb864d7db8ad53841323fc48a20d8dfc0a3086 (diff)
downloadports-c4c31e009affa1c03332757a152f183911ebfbb0.tar.gz
ports-c4c31e009affa1c03332757a152f183911ebfbb0.zip
Notes
Diffstat (limited to 'security/gsasl/Makefile')
-rw-r--r--security/gsasl/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/security/gsasl/Makefile b/security/gsasl/Makefile
index aac653a822d1..aaf3fef5e97e 100644
--- a/security/gsasl/Makefile
+++ b/security/gsasl/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gsasl
PORTVERSION= 0.0.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://josefsson.org/${PORTNAME}/releases/ \
${MASTER_SITE_GNU_ALPHA}
@@ -18,10 +18,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNU SASL Library
LIB_DEPENDS= idn.13:${PORTSDIR}/devel/libidn \
- gcrypt.6:${PORTSDIR}/security/libgcrypt \
+ gcrypt.10:${PORTSDIR}/security/libgcrypt-devel \
ntlm.0:${PORTSDIR}/security/libntlm
-USE_GETTEXT= yes
USE_PERL5_BUILD= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GETOPT_LONG= yes
@@ -32,6 +31,14 @@ INSTALLS_SHLIB= yes
INFO= gsasl
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib