aboutsummaryrefslogtreecommitdiff
path: root/security/gss
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-02 21:00:59 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-02 21:00:59 +0000
commit2930ac304cd2f3d13f54ae533728da026ffaceca (patch)
tree82ace9ae2d4701da4df71157364a8d28caea4703 /security/gss
parent2762c618940c7ce63b8a74797c0ab21eb81a5be5 (diff)
downloadports-2930ac304cd2f3d13f54ae533728da026ffaceca.tar.gz
ports-2930ac304cd2f3d13f54ae533728da026ffaceca.zip
Notes
Diffstat (limited to 'security/gss')
-rw-r--r--security/gss/Makefile10
-rw-r--r--security/gss/distinfo4
-rw-r--r--security/gss/files/patch-ltmain.sh15
3 files changed, 8 insertions, 21 deletions
diff --git a/security/gss/Makefile b/security/gss/Makefile
index de4abde0e628..e83c6b28f2c5 100644
--- a/security/gss/Makefile
+++ b/security/gss/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gss
-PORTVERSION= 0.0.11
+PORTVERSION= 0.0.12
CATEGORIES= security
MASTER_SITES= http://josefsson.org/${PORTNAME}/releases/ \
${MASTER_SITE_GNU_ALPHA}
@@ -21,7 +21,7 @@ LIB_DEPENDS= shishi.0:${PORTSDIR}/security/shishi
USE_PERL5_BUILD= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GETOPT_LONG= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-kerberos5
INSTALLS_SHLIB= yes
@@ -31,6 +31,9 @@ INFO= gss
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include "Makefile.man"
+.include <bsd.port.pre.mk>
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
@@ -39,5 +42,4 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.include "Makefile.man"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/gss/distinfo b/security/gss/distinfo
index 7c9e81cea2e1..b478ef678049 100644
--- a/security/gss/distinfo
+++ b/security/gss/distinfo
@@ -1,2 +1,2 @@
-MD5 (gss-0.0.11.tar.gz) = 9e7d1f547c57486e03909c5a2a07460b
-SIZE (gss-0.0.11.tar.gz) = 1311180
+MD5 (gss-0.0.12.tar.gz) = e3da7f9f6ee39ac108a2708934598527
+SIZE (gss-0.0.12.tar.gz) = 1327465
diff --git a/security/gss/files/patch-ltmain.sh b/security/gss/files/patch-ltmain.sh
deleted file mode 100644
index c0c5873220f0..000000000000
--- a/security/gss/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Oct 30 14:37:50 2003
-+++ ltmain.sh Thu Oct 30 14:38:04 2003
-@@ -5457,10 +5457,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"