aboutsummaryrefslogtreecommitdiff
path: root/security/gtkpasman/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-28 13:59:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-28 13:59:59 +0000
commitbc142dc721f1477c29037da33dd105867e821f74 (patch)
tree41d4d4894e7fad52140b4d7b0282d88f0c8cf87b /security/gtkpasman/Makefile
parent65d78e0785d678623bf125bc1ec28d65725b9d8e (diff)
downloadports-bc142dc721f1477c29037da33dd105867e821f74.tar.gz
ports-bc142dc721f1477c29037da33dd105867e821f74.zip
Notes
Diffstat (limited to 'security/gtkpasman/Makefile')
-rw-r--r--security/gtkpasman/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/security/gtkpasman/Makefile b/security/gtkpasman/Makefile
index e1483bd2b6e0..f3023bf5bfe8 100644
--- a/security/gtkpasman/Makefile
+++ b/security/gtkpasman/Makefile
@@ -6,26 +6,26 @@
#
PORTNAME= gtkpasman
-PORTVERSION= 0.9
-PORTREVISION= 8
+PORTVERSION= 0.11
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-sources/${PORTVERSION}
MAINTAINER= cvs-src@yandex.ru
COMMENT= A GTK+ passwords manager for system and network administrators
-RUN_DEPENDS+= gpgv:${PORTSDIR}/security/gnupg1
+RUN_DEPENDS+= gpgv2:${PORTSDIR}/security/gnupg
USE_GMAKE= yes
-USE_GNOME= gtk20
+USE_GNOME= desktopfileutils gtk20
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-gtk2
USE_AUTOTOOLS= automake aclocal autoconf
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-DOCS= README src/gpasman4.sample
-PLIST_FILES= bin/gtkpasman
+DOCS= README data/gpasman4.sample
+PLIST_FILES= bin/gtkpasman share/applications/gtkpasman.desktop
ACLOCAL_ARGS?= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
.if !defined(NOPORTDOCS)
@@ -34,12 +34,17 @@ PORTDOCS= README gpasman4.sample
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/gtkpasman ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/data/gtkpasman.desktop \
+ ${PREFIX}/share/applications
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
post-install:
+.if !defined(NOPORTDOCS)
@${CAT} ${PKGMESSAGE}
+.endif
+ @-update-desktop-database
.include <bsd.port.mk>