aboutsummaryrefslogtreecommitdiff
path: root/security/gwee/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-09 18:21:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-09 18:21:28 +0000
commit6b80960850f534f05939a34d93f7e56f9a8528d5 (patch)
tree607825c61ac96950d9ba9b597aa0cf17debc155f /security/gwee/Makefile
parentdb82b73355790dda92f61ee55ae9bffedd010048 (diff)
downloadports-6b80960850f534f05939a34d93f7e56f9a8528d5.tar.gz
ports-6b80960850f534f05939a34d93f7e56f9a8528d5.zip
Notes
Diffstat (limited to 'security/gwee/Makefile')
-rw-r--r--security/gwee/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/gwee/Makefile b/security/gwee/Makefile
new file mode 100644
index 000000000000..83e8ded16acf
--- /dev/null
+++ b/security/gwee/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gwee
+# Date created: 2005-05-04
+# Whom: chinsan <chinsan@mail2000.com.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwee
+PORTVERSION= 1.36
+CATEGORIES= security www
+MASTER_SITES= http://tigerteam.se/dl/gwee/
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Tool to exploit command execution vulnerabilities in web scripts
+
+USE_OPENSSL= yes
+USE_PERL5= yes
+USE_PYTHON= yes
+
+LDFLAGS+= -lssl -lcrypto
+CFLAGS+= -DWITH_SSL
+
+MAN1= gwee.1
+PLIST_FILES= bin/gwee
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c \
+ -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>