aboutsummaryrefslogtreecommitdiff
path: root/security/heimdal
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2010-03-11 07:49:46 +0000
committerBrooks Davis <brooks@FreeBSD.org>2010-03-11 07:49:46 +0000
commit74ce33548fe8a7472b1fdcd0c1b78e43958f6043 (patch)
treea9be6c6eb718c813c2f4801e81d6d7a71d2efede /security/heimdal
parent16be93eb0af1173b83023d799b6c1834637ca1b0 (diff)
downloadports-74ce33548fe8a7472b1fdcd0c1b78e43958f6043.tar.gz
ports-74ce33548fe8a7472b1fdcd0c1b78e43958f6043.zip
Notes
Diffstat (limited to 'security/heimdal')
-rw-r--r--security/heimdal/Makefile2
-rw-r--r--security/heimdal/files/patch-kcm_connect.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 094938c5594f..b2e8ad12af5a 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= heimdal
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
diff --git a/security/heimdal/files/patch-kcm_connect.c b/security/heimdal/files/patch-kcm_connect.c
new file mode 100644
index 000000000000..88e3462bbeb3
--- /dev/null
+++ b/security/heimdal/files/patch-kcm_connect.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- kcm/connect.c.orig
++++ kcm/connect.c
+@@ -149,7 +149,7 @@
+ struct sockcred *sc;
+
+ memset(&msg, 0, sizeof(msg));
+- crmsgsize = CMSG_SPACE(SOCKCREDSIZE(NGROUPS));
++ crmsgsize = CMSG_SPACE(SOCKCREDSIZE(CMGROUP_MAX));
+ if (crmsgsize == 0)
+ return 1 ;
+