aboutsummaryrefslogtreecommitdiff
path: root/security/hitch
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2017-01-28 21:02:48 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2017-01-28 21:02:48 +0000
commitee87a247e116dcf3104073ac6a6277b8085dbe61 (patch)
treeb4f05fb129891ab26cbe3f0b9f5a595584decbd3 /security/hitch
parent096585ad3c56637cdabb18be34b3269985c6f43b (diff)
downloadports-ee87a247e116dcf3104073ac6a6277b8085dbe61.tar.gz
ports-ee87a247e116dcf3104073ac6a6277b8085dbe61.zip
Notes
Diffstat (limited to 'security/hitch')
-rw-r--r--security/hitch/Makefile12
-rw-r--r--security/hitch/distinfo5
-rw-r--r--security/hitch/pkg-plist3
3 files changed, 12 insertions, 8 deletions
diff --git a/security/hitch/Makefile b/security/hitch/Makefile
index fd33d66ad230..eecd5b28a0da 100644
--- a/security/hitch/Makefile
+++ b/security/hitch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hitch
-PORTVERSION= 1.1.1
+PORTVERSION= 1.4.4
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= security
@@ -11,19 +11,21 @@ COMMENT= TLS proxy to forward connections to an unencrypted backend
LICENSE= BSD2CLAUSE
-BUILD_DEPENDS= rst2man:textproc/py-docutils
+BUILD_DEPENDS= rst2man:textproc/py-docutils \
+ pkg-config:devel/pkgconf
LIB_DEPENDS= libev.so:devel/libev
USERS= nobody
GROUPS= nobody
-USES= autoreconf
+USES= autoreconf ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/run
-USE_OPENSSL= yes
+CONFIGURE_ENV= CRYPTO_CFLAGS="-I${OPENSSLINC}" CRYPTO_LIBS="-L${OPENSSLLIB}" \
+ SSL_CFLAGS="-I${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB}"
USE_RC_SUBR= ${PORTNAME}
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lcrypto -lssl
USE_GITHUB= yes
GH_ACCOUNT= varnish
diff --git a/security/hitch/distinfo b/security/hitch/distinfo
index cc68273d69e2..6ccb45912412 100644
--- a/security/hitch/distinfo
+++ b/security/hitch/distinfo
@@ -1,2 +1,3 @@
-SHA256 (varnish-hitch-hitch-1.1.1_GH0.tar.gz) = 48889282a1b39e05e982ae30d69f9a7a51039e6fc36e726f9b211e118af818e5
-SIZE (varnish-hitch-hitch-1.1.1_GH0.tar.gz) = 80989
+TIMESTAMP = 1485636726
+SHA256 (varnish-hitch-hitch-1.4.4_GH0.tar.gz) = 3c889637e1bc66010b8243fc91b9e26e134f6be77f38a770773dbbbb4dacdefc
+SIZE (varnish-hitch-hitch-1.4.4_GH0.tar.gz) = 125074
diff --git a/security/hitch/pkg-plist b/security/hitch/pkg-plist
index fcead5737fd3..2dd9b5403f51 100644
--- a/security/hitch/pkg-plist
+++ b/security/hitch/pkg-plist
@@ -1,6 +1,7 @@
+man/man5/hitch.conf.5.gz
man/man8/hitch.8.gz
sbin/hitch
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.rst
%%PORTDOCS%%%%DOCSDIR%%/README.md
-%%PORTDOCS%%%%DOCSDIR%%/hitch.conf.ex
+%%PORTDOCS%%%%DOCSDIR%%/hitch.conf.example
@sample etc/hitch.conf.sample