aboutsummaryrefslogtreecommitdiff
path: root/security/hostapd
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2004-12-12 22:16:22 +0000
committerWarner Losh <imp@FreeBSD.org>2004-12-12 22:16:22 +0000
commit837a9e8ca9b60bf7dda12ee06e59672ce80dcb9c (patch)
tree50454b4499e101dfed8037ec0bc61adcd61a079a /security/hostapd
parent85fe47d148dc47baf8a43e3179f06041165bbcd6 (diff)
Notes
Diffstat (limited to 'security/hostapd')
-rw-r--r--security/hostapd/Makefile25
-rw-r--r--security/hostapd/distinfo2
-rw-r--r--security/hostapd/files/config.bsd3
-rw-r--r--security/hostapd/pkg-descr9
-rw-r--r--security/hostapd/pkg-plist2
5 files changed, 41 insertions, 0 deletions
diff --git a/security/hostapd/Makefile b/security/hostapd/Makefile
new file mode 100644
index 000000000000..51b0183277ca
--- /dev/null
+++ b/security/hostapd/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: hostapd
+# Date created: 7 December 2004
+# Whom: sam
+#
+# $FreeBSD$
+#
+
+PORTNAME= hostapd
+PORTVERSION= 0.3.0
+CATEGORIES= security
+MASTER_SITES= http://hostap.epitest.fi/releases/
+DISTNAME= hostapd-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Authenticator (server) for WPA/802.1x protocols
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_GMAKE= yes
+
+post-extract:
+ @${CP} ${FILESDIR}/config.bsd ${WRKSRC}/.config
+
+.include <bsd.port.mk>
diff --git a/security/hostapd/distinfo b/security/hostapd/distinfo
new file mode 100644
index 000000000000..4182f5a49a4c
--- /dev/null
+++ b/security/hostapd/distinfo
@@ -0,0 +1,2 @@
+MD5 (hostapd-0.3.0.tar.gz) = 2fa275b17c0c395898dd4b1fb10545ce
+SIZE (hostapd-0.3.0.tar.gz) = 198308
diff --git a/security/hostapd/files/config.bsd b/security/hostapd/files/config.bsd
new file mode 100644
index 000000000000..814a97d5e283
--- /dev/null
+++ b/security/hostapd/files/config.bsd
@@ -0,0 +1,3 @@
+CONFIG_DRIVER_BSD=y
+CFLAGS += -I/usr/local/include
+LIBS += -L/usr/local/lib
diff --git a/security/hostapd/pkg-descr b/security/hostapd/pkg-descr
new file mode 100644
index 000000000000..bdf6c976e054
--- /dev/null
+++ b/security/hostapd/pkg-descr
@@ -0,0 +1,9 @@
+hostapd is an authenticator (server) for the WPA, 802.11i, and
+802.1x security protocols typically used over wireless networks.
+You must have a WPA, 802.11i, or 802.1x supplicant (client) to
+make use of this program.
+
+WWW: http://hostap.epitest.fi/
+
+- Sam Leffler
+sam@FreeBSD.org
diff --git a/security/hostapd/pkg-plist b/security/hostapd/pkg-plist
new file mode 100644
index 000000000000..71ec0e7e1ac7
--- /dev/null
+++ b/security/hostapd/pkg-plist
@@ -0,0 +1,2 @@
+bin/hostapd
+bin/hostapd_cli