aboutsummaryrefslogtreecommitdiff
path: root/security/hotssh/Makefile
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-19 22:58:47 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-19 22:58:47 +0000
commit6d108ef2b291f24aa1a7df0ce87572570f41ace3 (patch)
tree8835471ac7be92e9e1b8f6854c3de69e1d12c7c0 /security/hotssh/Makefile
parentc89b8b9aca9f56b1713d0049c063c56c8cad4553 (diff)
downloadports-6d108ef2b291f24aa1a7df0ce87572570f41ace3.tar.gz
ports-6d108ef2b291f24aa1a7df0ce87572570f41ace3.zip
Notes
Diffstat (limited to 'security/hotssh/Makefile')
-rw-r--r--security/hotssh/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index d129e1191a04..3ed6bead6d85 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hotssh
-PORTVERSION= 0.2.6
-PORTREVISION= 4
+PORTVERSION= 0.2.7
CATEGORIES= security gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -28,9 +27,17 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-
USE_GNOME= pygtk2 gnomedocutils libxslt glib20
USE_GETTEXT= yes
USE_PYTHON= 2.5+
+INSTALLS_ICONS= yes
+USE_BZIP2= yes
+
+B64DECODE?= /usr/bin/b64decode
+BSPATCH?= /usr/bin/bspatch
post-extract:
${GREP} -Rl '^#!/usr/bin/python$$' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's|^#!/usr/bin/python$$|#!/usr/bin/env python|g'
+ ${MV} ${WRKSRC}/waf ${WRKSRC}/waf.beforepatch
+ cd ${WRKSRC} && ${B64DECODE} -o waf.diff ${FILESDIR}/waf.diff && ${BSPATCH} waf.beforepatch waf waf.diff && ${CHMOD} 755 waf
+ ${GREP} -Rl '%%LOCALBASE%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g"
do-configure:
cd ${WRKSRC} && ./waf configure --prefix=${PREFIX}