aboutsummaryrefslogtreecommitdiff
path: root/security/hotssh
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2009-02-13 23:36:51 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2009-02-13 23:36:51 +0000
commita6ec929c8d3e904bbd9e20ac7766216b08012468 (patch)
treedcab42be3df29b08ccb80aa51d6ccdc98efe50ff /security/hotssh
parent6ca7e8f09afa5df8ea6c21bf308b5c1ab954eb8b (diff)
downloadports-a6ec929c8d3e904bbd9e20ac7766216b08012468.tar.gz
ports-a6ec929c8d3e904bbd9e20ac7766216b08012468.zip
Notes
Diffstat (limited to 'security/hotssh')
-rw-r--r--security/hotssh/Makefile43
-rw-r--r--security/hotssh/distinfo3
-rw-r--r--security/hotssh/pkg-descr15
-rw-r--r--security/hotssh/pkg-plist57
4 files changed, 118 insertions, 0 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
new file mode 100644
index 000000000000..827d2f72c20d
--- /dev/null
+++ b/security/hotssh/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: hotssh
+# Date created: 2009-01-30
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hotssh
+PORTVERSION= 0.2.6
+CATEGORIES= security gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= HotSSH is an interface to Secure Shell, for GNOME and OpenSSH
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+ ${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
+ ${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
+ ${PYTHON_SITELIBDIR}/pysqlite2/test/__init__.py:${PORTSDIR}/databases/py-pysqlite23 \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+ ${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
+ ${PYTHON_SITELIBDIR}/pysqlite2/test/__init__.py:${PORTSDIR}/databases/py-pysqlite23 \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
+
+USE_GNOME= pygtk2 gnomedocutils libxslt glib20
+USE_GETTEXT= yes
+USE_PYTHON= 2.5+
+
+post-extract:
+ ${GREP} -Rl '^#!/usr/bin/python$$' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's|^#!/usr/bin/python$$|#!/usr/bin/env python|g'
+
+do-configure:
+ cd ${WRKSRC} && ./waf configure --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ./waf
+
+do-install:
+ cd ${WRKSRC} && ./waf install
+
+.include <bsd.port.mk>
diff --git a/security/hotssh/distinfo b/security/hotssh/distinfo
new file mode 100644
index 000000000000..e8ebc04be279
--- /dev/null
+++ b/security/hotssh/distinfo
@@ -0,0 +1,3 @@
+MD5 (hotssh-0.2.6.tar.gz) = 5c54b750995626187b498590a67b8565
+SHA256 (hotssh-0.2.6.tar.gz) = a926f8baf5adb6d1fa5dbed2dd0005aa8420ee4525bb6b49e69c3898c793a00c
+SIZE (hotssh-0.2.6.tar.gz) = 166268
diff --git a/security/hotssh/pkg-descr b/security/hotssh/pkg-descr
new file mode 100644
index 000000000000..278d6e9cd2ac
--- /dev/null
+++ b/security/hotssh/pkg-descr
@@ -0,0 +1,15 @@
+HotSSH is an interface to Secure Shell, for GNOME and OpenSSH. It
+intends to be a better experience than simply invoking "ssh" from an
+existing terminal window.
+
+ * Fast search-based interface for new connections
+ * Also display and search of local (Avahi) SSH servers
+ * Tabbed display with automatic session saving (Firefox style)
+ * Status bar with information like latency to server and output of
+ remote uptime
+ * Close integration with OpenSSH features like connection sharing
+ (near-instant new tabs)
+ * NetworkManager integration to easily reconnect after a network
+ change, great for laptops
+
+WWW: http://projects.gnome.org/hotssh/
diff --git a/security/hotssh/pkg-plist b/security/hotssh/pkg-plist
new file mode 100644
index 000000000000..19e37cead11d
--- /dev/null
+++ b/security/hotssh/pkg-plist
@@ -0,0 +1,57 @@
+bin/hotssh
+%%PYTHON_SITELIBDIR%%/hotssh/__init__.py
+%%PYTHON_SITELIBDIR%%/hotssh/__init__.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/__init__.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/__init__.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/logutil.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/logutil.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/logutil.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/timesince.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/timesince.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib/timesince.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/__init__.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/__init__.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/__init__.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/msgarea.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/msgarea.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/msgarea.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/quickfind.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/quickfind.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui/quickfind.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/__init__.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/__init__.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/__init__.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/vteterm.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/vteterm.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/vteterm.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/vtewindow.py
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/vtewindow.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/hotvte/vtewindow.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/sshwindow.py
+%%PYTHON_SITELIBDIR%%/hotssh/sshwindow.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/sshwindow.pyo
+%%PYTHON_SITELIBDIR%%/hotssh/version.py
+%%PYTHON_SITELIBDIR%%/hotssh/version.pyc
+%%PYTHON_SITELIBDIR%%/hotssh/version.pyo
+share/applications/hotssh.desktop
+share/doc/hotssh-0.2.6/COPYING
+share/locale/ar/LC_MESSAGES/hotssh.mo
+share/locale/ca/LC_MESSAGES/hotssh.mo
+share/locale/es/LC_MESSAGES/hotssh.mo
+share/locale/fi/LC_MESSAGES/hotssh.mo
+share/locale/fr/LC_MESSAGES/hotssh.mo
+share/locale/ja/LC_MESSAGES/hotssh.mo
+share/locale/nb/LC_MESSAGES/hotssh.mo
+share/locale/pt/LC_MESSAGES/hotssh.mo
+share/locale/pt_BR/LC_MESSAGES/hotssh.mo
+share/locale/sl/LC_MESSAGES/hotssh.mo
+share/locale/sv/LC_MESSAGES/hotssh.mo
+@dirrm share/applications
+@dirrm share/doc/hotssh-0.2.6
+@dirrm %%PYTHON_SITELIBDIR%%/hotssh/hotvte
+@dirrm %%PYTHON_SITELIBDIR%%/hotssh/hotlib_ui
+@dirrm %%PYTHON_SITELIBDIR%%/hotssh/hotlib
+@dirrm %%PYTHON_SITELIBDIR%%/hotssh
+@dirrmtry %%PYTHON_SITELIBDIR%%