aboutsummaryrefslogtreecommitdiff
path: root/security/hotssh
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2014-06-30 12:04:09 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2014-06-30 12:04:09 +0000
commit8952e4e413e31663d65b4c902e2a1475804e42e6 (patch)
tree0b3d496aebd2e0e7c54f9bc2d22fd79d079281ef /security/hotssh
parent478ea62d4e6e4a2b3e55496da7b0873fcb8814e5 (diff)
Notes
Diffstat (limited to 'security/hotssh')
-rw-r--r--security/hotssh/Makefile20
-rw-r--r--security/hotssh/files/patch-wscript14
2 files changed, 25 insertions, 9 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index 439cb0001e8a..ecad26c4183a 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hotssh
PORTVERSION= 0.2.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -11,6 +11,9 @@ MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
MAINTAINER= ashish@FreeBSD.org
COMMENT= HotSSH is an interface to Secure Shell, for GNOME and OpenSSH
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
@@ -30,20 +33,19 @@ USE_BZIP2= yes
B64DECODE?= /usr/bin/b64decode
BSPATCH?= /usr/bin/bspatch
-NO_STAGE= yes
post-extract:
- ${GREP} -Rl '^#!/usr/bin/python$$' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's|^#!/usr/bin/python$$|#!/usr/bin/env python|g'
- ${MV} ${WRKSRC}/waf ${WRKSRC}/waf.beforepatch
- cd ${WRKSRC} && ${B64DECODE} -o waf.diff ${FILESDIR}/waf.diff && ${BSPATCH} waf.beforepatch waf waf.diff && ${CHMOD} 755 waf
- ${GREP} -Rl '%%LOCALBASE%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g"
+ @${GREP} -Rl '^#!/usr/bin/python$$' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's|^#!/usr/bin/python$$|#!/usr/bin/env python|g'
+ @${MV} ${WRKSRC}/waf ${WRKSRC}/waf.beforepatch
+ @cd ${WRKSRC} && ${B64DECODE} -o waf.diff ${FILESDIR}/waf.diff && ${BSPATCH} waf.beforepatch waf waf.diff && ${CHMOD} 755 waf
+ @${GREP} -Rl '%%LOCALBASE%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g"
do-configure:
- cd ${WRKSRC} && ./waf configure --prefix=${PREFIX}
+ @cd ${WRKSRC} && ./waf configure --prefix=${PREFIX}
do-build:
- cd ${WRKSRC} && ./waf
+ @cd ${WRKSRC} && ./waf
do-install:
- cd ${WRKSRC} && ./waf install
+ @cd ${WRKSRC} && ./waf install --destdir=${STAGEDIR}
.include <bsd.port.mk>
diff --git a/security/hotssh/files/patch-wscript b/security/hotssh/files/patch-wscript
new file mode 100644
index 000000000000..dd273a4616b5
--- /dev/null
+++ b/security/hotssh/files/patch-wscript
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- wscript.orig
++++ wscript
+@@ -14,7 +14,7 @@
+ opt.tool_options('python')
+
+ def configure(conf):
+- conf.check_tool('gcc gnome python intltool misc')
++ conf.check_tool('cc gnome python intltool misc')
+ conf.check_python_version((2,4,2))
+
+ conf.check_python_module('dbus')