aboutsummaryrefslogtreecommitdiff
path: root/security/hpenc
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-04-17 13:28:04 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-04-17 13:28:04 +0000
commit4ef5e905f9f5f4597cd21e1fb3a6fc2be93fa486 (patch)
treebb868378e4e74883300ce9a2415fc9ce867cee84 /security/hpenc
parente03616ea0dd9e4f45440096c20d7215fc3e84fbf (diff)
Notes
Diffstat (limited to 'security/hpenc')
-rw-r--r--security/hpenc/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index 5bb8a0eecf17..15b2b22c79e6 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= hpenc
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://highsecure.ru/distfiles/
@@ -12,7 +13,7 @@ LICENSE= BSD2CLAUSE
USES= tar:xz compiler:c++11-lib gmake
USE_OPENSSL= yes
-PLIST_FILES= bin/hpenc
+PLIST_FILES= bin/hpenc man/man1/hpenc.1.gz
MAKE_ARGS+= "ARCH=${ARCH:S/amd64/x86/:S/i386/x86/}"
CXXFLAGS+= -std=c++11 \
@@ -25,9 +26,17 @@ LDFLAGS+= -pthread -lcrypto -L${OPENSSLLIB}
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000036
WITH_OPENSSL_PORT= yes
+
+# XXX: brain damage warning
+# we need to .include bsd.openssl.mk manually here.because USE_OPENSSL only
+# works when it is defined before bsd.port{.pre}.mk is .included.
+# This makes it currently impossible to combine this macro with OSVERSION to
+# conditionally select WITH_OPENSSL_PORT for OSVERSIONS before 1000015
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif
post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/hpenc.1 ${STAGEDIR}${MANPREFIX}/man/man1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/hpenc
.include <bsd.port.post.mk>